LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-07-2003, 12:18 PM   #1
mrmojo
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1
Posts: 26

Rep: Reputation: 15
Cool playback device


ok, finally i've installed and make it works,
sound drivers
but......
I can play sound just by root, if i am a normal user when i start kde the first message he gives to me is unable to open playback device sound output will be sent to /dev/null.

So i try to modify permission on /dev/sound/dsp and /dev/sound/mixer.
But nothing to do.
Now i use i810_audio module, anyone knows how to solve thi problem.

one week i have linux and it makes me fell Soooooooooooooooo Goooooooooooooooooooooooood.......FREEEEEEEEEEEEEEDOOOOOM!

TNX FOR ANY ANSWER
 
Old 11-07-2003, 12:53 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Do you need to add your user to a group? Some distros require you to be a member of the audio group.

# Mandrake links
Mandrake home page
Mandrake Users website
Easy urpmi config for Mandrake
urpmi mini-HOWTO
Easy software management: Red Carpet
Maximum RPM
rpmfind
You didn't install the developmental packages? As root, command:
urpmi gcc
An Introduction to the Midnight Commander. You can install it by commanding:
urpmi mc
Midnight Commander home page
 
Old 11-08-2003, 11:39 AM   #3
mrmojo
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Cool Nothing to do

Thanks a lot for the information but as Guybrush Threepwood shuold say: It doesn't seem to work
 
Old 11-08-2003, 11:46 AM   #4
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
You aren't giving a whole lot of information.

I am assuming you have tried to configure the sound through the Mandrake Control Center and you are unsuccessful. If not, open the Mandrake Control Center and re-configure the sound that way.

To get error messages, run your app from a terminal and you can post the error messages generated.

Another possibility:

urpmi sndconfig

If it will install, then run sndconfig

How to get good answers with your questions about Linux

Last edited by fancypiper; 11-08-2003 at 11:55 AM.
 
Old 11-08-2003, 12:02 PM   #5
fideli
Member
 
Registered: Nov 2003
Location: Mississauga
Distribution: arch linux
Posts: 51

Rep: Reputation: 15
i had to modify permissions of my /dev/dsp0 and my /dev/mixer0
 
Old 11-08-2003, 12:07 PM   #6
mrmojo
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Here it is the error message

aARts Message

Sound server informational message:

Error while intializing the sound driver:

device: default can't be opened for playback (No such devices)

The sound server will continue using the null output device


THAT'S ALL
 
Old 11-08-2003, 12:15 PM   #7
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Does the device actually exist?

From the Mandrake User's Site:

Troubleshooting Sound

(Contributed by Mandrake Linux user Stewart Midwinter)

If you get no sound in Mandrake Linux, or if you can get sound when playing an audio file only, but not from the CD, here's what to check.

1. Some on-card sound chips are problematic (e.g SoundPro, aka CM8330).
2. The default sound volume might be zero (mute).
3. You don't have permission to access the audio devices.

1. Check the 'net for information on your particular card or chipset (e.g. on LhD. Also, rule out any physical problems: boot your PC with another operating system and ensure you can get audio that way.

2. The default sound volume might be zero (mute). Install and run 'aumix' from your Mandrake Linux CD, mute and then un-mute the volume channel.

3. chmod 777 /dev/audio*, /dev/dsp*, /dev/mixer*. [Notice that this won't work on Mandrake Linux 8.1 with devfd enabled (default), and opens a security hole on systems where it does work. tom]

4. If you can get sound when playing a file (play test.wav), but not when playing a CD, one workaround is to run a cable from the CD-ROM's headphone's jack to the line-in jack on your sound card. (works for me!). Another reason might be that the audio CD is mounted.

Mandrake Linux user Hian James solved his sound troubles this way:

In KDE mode, I first entered DrakConf. I went into HardDrake and SoundWizard to check that the configuration for I had is correct (ie. before I reboot and the conflict started).
Then, I went into DrakXServices in the DrakConf to remove (deselect) sound from the list of services to start upon booting.
I left KDE and rebooted my computer.
I've only been using KDE at the moment so I cannot say whether my solution is applicable to GNOME.
 
Old 11-08-2003, 12:26 PM   #8
mrmojo
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Unhappy OH MY GOD

've changed all permission but nothing to do. It's all rwx but the problem dowsn't want to die!
 
Old 11-08-2003, 12:34 PM   #9
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
I'm out of ideas
 
Old 11-08-2003, 12:36 PM   #10
mrmojo
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Does'n matter

It doesn't matter, thanx a lot anyway
 
Old 11-08-2003, 12:52 PM   #11
mrmojo
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Unhappy additionsl information

I have set up all permissions on

/dev/adsp*
/dev/amidi*
/dev/audio*
/dev/dsp*
/dev/midi*
/dev/mixer*
/dev/aload*
/dev/dmfm*
/dev/dmmidi*
/dev/music*
/dev/sequencer*
/dev/vc/0
/dev/vc/7
 
Old 11-10-2003, 04:05 PM   #12
mrmojo
LQ Newbie
 
Registered: Nov 2003
Distribution: Mandrake 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Lightbulb PROBLEM SOLVED

To solve the problem?
Simply disable the aARts sound server in KDE....

Big Penguin is wathcing you....
 
Old 12-06-2004, 10:46 PM   #13
mordjah
LQ Newbie
 
Registered: Dec 2004
Posts: 1

Rep: Reputation: 0
Wink yupyup

You are absolutly correct. in my 5 month estimation of linux (i threw Bill's @#$%ware off my box last summer..) the kde sound server is evil and should not be trusted with the administration of sound... alsa .. alsO.. ati's linux support is sorry.. im buying nvidie (then i get to go back to gentoo x64)

Happy Learning to all!

~Mordjah

.....Computers are like Air Conditioners.. they stop working when you open windows.........
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Audacity - No Playback device listed doobers Linux - Software 4 03-12-2005 12:26 AM
blue line at the top of TV playback, DIVX playback spiderworm Linux - Software 0 01-31-2005 02:33 PM
Cannot record from microphone device, playback via speakers work correctly habala Linux - Laptop and Netbook 0 01-16-2005 03:41 PM
Device can't be opened for playback zupermanz Mandriva 0 06-05-2004 06:46 AM
no playback device j-charles Linux - Newbie 3 08-19-2003 06:05 PM


All times are GMT -5. The time now is 06:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration