LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   plasma workspace crash (http://www.linuxquestions.org/questions/linux-newbie-8/plasma-workspace-crash-710156/)

kurquhart1 03-09-2009 12:14 AM

plasma workspace crash
 
i just installed kde 4.2 the website said it was stable, i had 4.1 and have only been using linux for 2 days. im using suse 11.1. as soon as i upgraded the kde i restarted and logged in and my screen goes black i cant go anything all i see is my mouse and i get a message saying,

plasma workspace has encountered a fatal error blah blah blah. is there a fix for this, or some way i can go back to kde 4.1. im currently using the gnome desktop.

kurquhart1 03-09-2009 03:21 PM

is there anyone who can help me? or had this same problem

bmsiller 03-09-2009 05:37 PM

Here's how you can roll back to KDE 4.1.3 using Yast:

First go to "Software Repositories" and change your repository priorities to make the OSS repository have a higher priority (lower number) than the KDE4:Factory repository.

Then, go to "Software Management", choose to filter by Repository, select the KDE4:Factory repository, then in the menu bar, select Package->All in this list->Update unconditionally.

If you do everything right, this should roll back all of your kde packages to the version in the OSS repository.

If you can't log into KDE to do this, you could either log into some other desktop environment (I believe openSUSE also installs IceWM by default), or you could run Yast from the command line.

kurquhart1 03-09-2009 06:11 PM

ok so i did half of that. im currently in gnome. i went to software management and chose filter by repository but then it doesnt give me the
"package" option in the top left corner


what i get is repositories language patterns or groups im also not sure where im supposed to do the update thing cause i dont get that option in this software management

bmsiller 03-09-2009 06:36 PM

I just remembered another trick that has saved me from plasma crashes in the past:

Go to the directory /home/username/.kde4/share/config and remove (or rename) the files 'plasmarc' and 'plasma-appletsrc'. Then when you boot to KDE, these files will be auto-generated, and it should reset all of the plasma settings to defaults. This may allow you to boot into KDE without crashing.

It's strange that your Yast software management menu bar is different from mine (I've got File, Edit, Package, Configuration...). I wouldn't think that this would be any different in Gnome than it is in KDE.

kurquhart1 03-09-2009 06:51 PM

are you using 11.1? thats what im using.

Junior Hacker 03-09-2009 07:11 PM

Quote:

Originally Posted by bmsiller (Post 3470177)
I just remembered another trick that has saved me from plasma crashes in the past:

Go to the directory /home/username/.kde4/share/config and remove (or rename) the files 'plasmarc' and 'plasma-appletsrc'. Then when you boot to KDE, these files will be auto-generated, and it should reset all of the plasma settings to defaults. This may allow you to boot into KDE without crashing.

It's strange that your Yast software management menu bar is different from mine (I've got File, Edit, Package, Configuration...). I wouldn't think that this would be any different in Gnome than it is in KDE.

It has happened many times for me also in Mandriva, below are the notes I kept in order to fix it:
Code:

Plasma workspace crashed caused signal 11

Remove ~/.kde4/share/config/plasma-appletsrc

Works everytime.

Billgatus of Borg 06-01-2009 01:29 AM

Quote:

Originally Posted by Junior Hacker (Post 3470204)
It has happened many times for me also in Mandriva, below are the notes I kept in order to fix it:
Code:

Plasma workspace crashed caused signal 11

Remove ~/.kde4/share/config/plasma-appletsrc

Works everytime.

Thank you for that information. i just managed to ruin my configuration this evening. Booted into IceWM and followed your instructions. It worked fine. Of course, i did have to remember how to set up my previous configuration, but that is more of a problem of advancing age and senility :D


All times are GMT -5. The time now is 10:22 PM.