LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-01-2002, 09:16 AM   #1
sandy
Member
 
Registered: Aug 2002
Location: Mumbai,India
Distribution: Linux Mint 12, Gentoo
Posts: 230

Rep: Reputation: 30
pkg-config problem


When I tried to install nautilus in my computer It gives the following error ..


checking for pkg-config... /usr/bin/pkg-config
checking for orbit2-config... no
checking for ORBit - version >= 2.3.0... no
*** The orbit2-config script installed by ORBIT could not be found
*** If ORBit was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the ORBIT_CONFIG environment variable to the
*** full path to orbit2-config.
checking for orbit-idl-2... :
*** Your version of pkg-config is too old. You need version 0.9.0 or newer.
*** See http://www.freedesktop.org/software/pkgconfig
configure: error: Library requirements ( esound >= 0.2.27 bonobo-activation-2.0 >= 1.0.0 eel-2.0 >= 2.0.4 glib-2.0 >= 2 gnome-desktop-2.0 >= 2.0.3 gnome-vfs-2.0 >= 1.9 gtk+-2.0 >= 2.0.5 libart-2.0 >= 2.3.10 libbonobo-2.0 >= 2.0.0 libbonoboui-2.0 >= 2.0.0 libgnome-2.0 >= 2.0.1 libgnomecanvas-2.0 >= 2.0 libgnomeui-2.0 >= 2.0 librsvg-2.0 >= 2.0.1 libxml-2.0 >= 2.4.7) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.


Then I installed pkg-config in my computer not in /usr/bin,but in other directory.I dont know how to set the PKG_CONFIG_PATH variable.

Please help me.. Also tell me that wether the error was only due to pkg-config.........

 
Old 09-01-2002, 09:33 AM   #2
dwd
Member
 
Registered: Aug 2002
Distribution: RedHat / Debian / Ubuntu
Posts: 35

Rep: Reputation: 15
Please answer the following:

a) What are you compiling?
b) What distribution are you using?
c) Do you actually have Gnome 2 installed? (Most (all?) shipping distributions only come with Gnome 1.4, if you're using Gnome 2 and also proclaim yourself a Newbie, you should probably be thinking again...)
 
Old 09-05-2002, 02:52 AM   #3
sandy
Member
 
Registered: Aug 2002
Location: Mumbai,India
Distribution: Linux Mint 12, Gentoo
Posts: 230

Original Poster
Rep: Reputation: 30
I was compiling nautlilus 2.04 . and am using gnome 1.4

the output while compiling i.e. consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them. ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
and I have installed pkg-config in a non-standard prefix and so I want to know how to "adjust" the PKG_CONFIG_PATH environment variable.
 
Old 09-05-2002, 04:11 AM   #4
dwd
Member
 
Registered: Aug 2002
Distribution: RedHat / Debian / Ubuntu
Posts: 35

Rep: Reputation: 15
If you don't have GNOME 2 installed, you've got a lot of work to do, I'm afraid. Nautilus 2 is based on GNOME 2, not GNOME 1.4, so merely changing the path that pkg-config is using to find the *.pc files isn't going to work.

For future reference, the following would work:

Assumptions: You have *.pc files installed in /usr/lib/pkgconfig and /usr/local/lib/pkgconfig, and the newer version of pkg-config is installed in /usr/local/bin/pkg-config

Either:

$ PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig PKG_CONFIG=/usr/local/bin/pkg-config ./configure

Which sets the environment variables only on the ./configure process and its children, or:

$ export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig
$ export PKG_CONFIG=/usr/local/bin/pkg-config
$ ./configure
$ make
$ make install

Which sets the environment variables on the current shell and all its children.

But this is just likely to throw up more errors in your case, since you probably don't have all the GNOME2 libraries which nautilus needs anyway.
 
Old 03-07-2003, 10:11 AM   #5
Curryed
LQ Newbie
 
Registered: Mar 2003
Posts: 3

Rep: Reputation: 0
similar problem

I've been trying to install glib-2.2.0 and gtk+-2.2.0 and I get this error:

"checking for pkg-config... /usr/bin/pkg-config
configure: error: *** pkg-config too old; version 0.14 or better required."

I've installed pkgconfig-0.15.0 (folder is in /usr), but I still get the same error message when I try to configure glib.

How do I update the /usr/bin/pkg-config?

Thanks, Ed.

by the way I'm using redhat 8.0 and gnome 2.0

 
Old 03-07-2003, 10:55 AM   #6
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
When you install pkg-config from source you must tell it to install into the /usr/bin directory by doing:

./configure --prefix=/usr/bin
make
make install
 
Old 03-07-2003, 11:10 AM   #7
Curryed
LQ Newbie
 
Registered: Mar 2003
Posts: 3

Rep: Reputation: 0
Thanks, but I tried that already and got this:

"/usr/bin/install -c pkg-config /usr/bin/bin/pkg-config
make install-man1
make[3]: Entering directory `/usr/pkgconfig-0.15.0'
/bin/sh ./mkinstalldirs /usr/bin/man/man1
mkdir /usr/bin/man
mkdir: `/usr/bin/man' exists but is not a directory
mkdir /usr/bin/man/man1
mkdir: cannot create directory `/usr/bin/man/man1': Not a directory
make[3]: *** [install-man1] Error 1
make[3]: Leaving directory `/usr/pkgconfig-0.15.0'
make[2]: *** [install-man] Error 2
make[2]: Leaving directory `/usr/pkgconfig-0.15.0'
make[1]: *** [install-am] Error 2
make[1]: Leaving directory `/usr/pkgconfig-0.15.0'
make: *** [install-recursive] Error 1"

Should I get rid of the existing ~/man file and replace it with a directory?

- Ed.
 
Old 03-07-2003, 11:51 AM   #8
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
No don't do that! That is your man command.

What options do:

./configure --help

give you?
 
Old 03-07-2003, 01:39 PM   #9
Curryed
LQ Newbie
 
Registered: Mar 2003
Posts: 3

Rep: Reputation: 0
list of options is:

"onfiguration:
--cache-file=FILE cache test results in FILE
--help print this message
--no-create do not create output files
--quiet, --silent do not print `checking...' messages
--version print the version of autoconf that created configure
Directory and file names:
--prefix=PREFIX install architecture-independent files in PREFIX
[/usr/local]
--exec-prefix=EPREFIX install architecture-dependent files in EPREFIX
[same as prefix]
--bindir=DIR user executables in DIR [EPREFIX/bin]
--sbindir=DIR system admin executables in DIR [EPREFIX/sbin]
--libexecdir=DIR program executables in DIR [EPREFIX/libexec]
--datadir=DIR read-only architecture-independent data in DIR
[PREFIX/share]
--sysconfdir=DIR read-only single-machine data in DIR [PREFIX/etc]
--sharedstatedir=DIR modifiable architecture-independent data in DIR
[PREFIX/com]
--localstatedir=DIR modifiable single-machine data in DIR [PREFIX/var]
--libdir=DIR object code libraries in DIR [EPREFIX/lib]
--includedir=DIR C header files in DIR [PREFIX/include]
--oldincludedir=DIR C header files for non-gcc in DIR [/usr/include]
--infodir=DIR info documentation in DIR [PREFIX/info]
--mandir=DIR man documentation in DIR [PREFIX/man]
--srcdir=DIR find the sources in DIR [configure dir or ..]
--program-prefix=PREFIX prepend PREFIX to installed program names
--program-suffix=SUFFIX append SUFFIX to installed program names
--program-transform-name=PROGRAM
run sed PROGRAM on installed program names
Host type:
--build=BUILD configure for building on BUILD [BUILD=HOST]
--host=HOST configure for HOST [guessed]
--target=TARGET configure for TARGET [TARGET=HOST]
Features and packages:
--disable-FEATURE do not include FEATURE (same as --enable-FEATURE=no)
--enable-FEATURE[=ARG] include FEATURE [ARG=yes]
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
--without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
--x-includes=DIR X include files are in DIR
--x-libraries=DIR X library files are in DIR
--enable and --with options recognized:
--enable-maintainer-mode enable make rules and dependencies not useful
(and sometimes confusing) to the casual installer
--enable-shared[=PKGS] build shared libraries [default=yes]
--enable-static[=PKGS] build static libraries [default=yes]
--enable-fast-install[=PKGS] optimize for fast installation [default=yes]
--with-gnu-ld assume the C compiler uses GNU ld [default=no]
--disable-libtool-lock avoid locking (might break parallel builds)
--with-pic try to use only PIC/non-PIC objects [default=use both]
"

Don't really know what to choose though!

Thanks, Ed

(just when I think I'm getting the hang of this thing it goes and has more problems )
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PKG config problem ? fatum Linux - Software 2 10-03-2004 06:52 PM
pkg config problem fatum Linux - General 0 10-01-2004 02:22 PM
pkg-config problem pasalacqua128 Linux - Software 1 06-02-2004 07:31 AM
pkg-config problem melinda_sayang Slackware 2 02-28-2004 08:56 AM
ardour pkg-config problem AUM_HA Linux - Software 1 08-07-2003 03:57 PM


All times are GMT -5. The time now is 01:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration