LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-26-2014, 06:18 AM   #1
Yarok
LQ Newbie
 
Registered: Jan 2014
Posts: 7

Rep: Reputation: Disabled
Pinging only one dirction


Hello,

I'm running 2 machines:

1. Red Hat 6 Linux with 10.10.10.168/24 IP addres
2. Red Hat 6 Linux on a VM worstation 8 with 192.168.202.134/24. The VM is running on 10.10.10.213/24 Microsoft PC.
Both iptables firewall are OFF.

The problem:
I can ping/ssh/ftp from the 192.168.202.134 machine to the 10.10.10.168 machine but not the other way.

From the 10.10.10.168 I can ping to the 10.10.10.213 microsoft HOST and to the internet as well.

Can some one help me with this?

Thanks,
 
Old 01-26-2014, 07:19 AM   #2
here2serve
Member
 
Registered: Sep 2005
Location: Hinesville
Distribution: Debian, Mandriva, Ubuntu, Fedora
Posts: 104

Rep: Reputation: 15
Sounds like the virtual switch needs a route statement on the 10.10 net. A traceroute from the 192.168.. would give you some info on what to look for. Or windows firewall is dropping icmp
 
Old 01-26-2014, 07:34 AM   #3
freakTux
LQ Newbie
 
Registered: Jan 2014
Distribution: Slackware64-current
Posts: 26

Rep: Reputation: Disabled
Quote:
Originally Posted by Yarok View Post
Hello,

I'm running 2 machines:

1. Red Hat 6 Linux with 10.10.10.168/24 IP addres
2. Red Hat 6 Linux on a VM worstation 8 with 192.168.202.134/24. The VM is running on 10.10.10.213/24 Microsoft PC.
Both iptables firewall are OFF.

The problem:
I can ping/ssh/ftp from the 192.168.202.134 machine to the 10.10.10.168 machine but not the other way.

From the 10.10.10.168 I can ping to the 10.10.10.213 microsoft HOST and to the internet as well.

Can some one help me with this?

Thanks,
Maybe it is something related to the virtual switch...You can try to change something in the Configuration of VMWare

Last edited by freakTux; 01-26-2014 at 07:36 AM.
 
Old 01-26-2014, 10:49 AM   #4
Yarok
LQ Newbie
 
Registered: Jan 2014
Posts: 7

Original Poster
Rep: Reputation: Disabled
OK, I solved it!

# service NetworkManager stop
# vi /etc/sysconfig/network-scripts/ifcfg-eth0 (main params)

DEVICE="eth0"
BOOTPROTO="no"
IPADDR=10.10.10.171
PREFIX=24
GATEWAY=10.10.10.1
DNS1=8.8.8.8
NM_CONTRROLED="no"

# service network restart

I configured the VM Network Adapter to be bridged by edit the setting in the "Virtual Machine Setting"

IPTABLES is turned OFF for both the machines.
PC Microsoft Firewall is on.

Ping, ssh, http, ftp are working both directions .
 
Old 01-26-2014, 11:44 AM   #5
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hi,

it is clear that a machine in the 10.10.10.0/24 network cannot ping the VM in a (natted) 192.168.x0/24 network, it's a route missing. In order to achieve this you would have to create a static route on the 10.10.10.168 computer which tells it, that the VM is reachable over the IP-adress of the VM-host.

When you configure for "bridged" you put the VM into the same network as the other machines which of course is also a solution.

Markus
 
Old 01-27-2014, 05:42 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,668

Rep: Reputation: 2259Reputation: 2259Reputation: 2259Reputation: 2259Reputation: 2259Reputation: 2259Reputation: 2259Reputation: 2259Reputation: 2259Reputation: 2259Reputation: 2259
Ping is a two way test by the way. You knew it was OK from the first test.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pinging ubuntunewby Linux - Newbie 3 07-09-2011 03:06 PM
Pinging by Name? SlowCoder Linux - Networking 2 05-06-2009 03:45 PM
pinging delos Linux - Networking 6 07-02-2004 10:14 AM
Pinging?? Sherpa Linux - General 3 05-13-2004 08:23 AM
Network not pinging any more. duffboygrim Linux - Networking 2 03-30-2004 06:05 PM


All times are GMT -5. The time now is 09:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration