LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-09-2012, 03:13 AM   #16
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221

I don't see this parameter in your named.conf file

Code:
allow-query     { localhost; any; };
Make sure your clients are getting authenticated from your DNS server
IS your DNS server configured properly?

You have mentioned that Internet is working fine but you are not able to ping google.com...Is that so on the client machine??
 
Old 10-09-2012, 05:32 AM   #17
sandeepc04
Member
 
Registered: Jun 2012
Location: India
Posts: 66

Original Poster
Rep: Reputation: Disabled
Thanks for your reply,

vi named.conf
options{
allow-query { localhost; any; };
};
zone "xyz.com" {
type master;
file "xyz.com.zone";
allow-transfer {192.168.4.254;};
};
zone "4.168.192.in-addr.arpa" {
type master;
file "4.168.192.in-addr.arpa.zone";
};

I have added your line and restarted..but its getting failed,

service named restart
Stopping named: [ OK ]
Starting named:
Error in named configuration:
/etc/named.conf:4: unknown option 'allow-query'
[FAILED]

Yes internet is working fine in client machine, even internal mail server is working fine...

Where i am doing mistake i am not getting,

Below files..

1. Hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6
192.168.4.1 xyz.com xyz
ISP STATIC IP xyz.com xyz

2. resolve.conf
search sigmablru.com
nameserver ISP DNS
nameserver ISP DNS
nameserver 192.168.4.1
nameserver 127.0.0.1

3. forword zone
cat xyz.com.zone
$TTL 86400
@ SOA xyz.com. root (
42 ; serial (d. adams)
3H ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
NS www ; Inet Address of nameserver
xyz.com. MX 10 mail ; primary mail exchanger

localhost A 127.0.0.1
xyz.com A 192.168.4.1
mail A 192.168.4.1
ns1 CNAME xyz
www CNAME xyz
xyz.com A ISP STATIC IP
mail A ISP STATIC IP

4. Reverse Zone
cat 4.168.192.in-addr.arpa.zone
; Filename:reversezone
; zone file for 1923168.4.x

$TTL 86400
@ SOA xyz.com root.xyz.com. (
1997022700 ; Serial
28800 ; Refresh
14400 ; Retry
3600000 ; Expire
86400 ) ; Minimum
IN NS xyz.com
1 IN PTR xyz.com.


5. Named already pasted

Is there any mistake i have did?

Regards,
Sandeep CC
 
Old 10-09-2012, 08:47 AM   #18
henrycoffin
Member
 
Registered: Dec 2006
Distribution: RHEL Debian
Posts: 42

Rep: Reputation: 15
netstat will not tell you if iptables is allowing ports!!!!

# iptables -L

will list your iptables rules
 
Old 10-09-2012, 11:40 PM   #19
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
You said after entering Google DNS also you were not able to ping on the client machine?

Check the client machine with some static IP rather than DHCP. I believe the network is in mesh and needs to be checked properly by your network admin
 
Old 10-12-2012, 01:51 AM   #20
sandeepc04
Member
 
Registered: Jun 2012
Location: India
Posts: 66

Original Poster
Rep: Reputation: Disabled
Hi deep27ak,

Sorry For late reply, Finally I have done something in iptables, and it got work for their office... Exactly what i did i am not understanding because after doing so many thing i have got result,

Now raised one more question at my office, As you said i had put google DNS 8.8.8.8 and checked in client machine for pinging, so it started to ping so for that i had put MY ISP provided 2 DNS IP's in dhcpd.conf file so it was working very good, but now what happened means, after giving DNS in dhcpd.conf that dns's are assigning to all clients and clients are able to ping but squid is not effecting now,

I have done some blockage from squid...created two files and i had put all unwanted websites + unwanted extensions so no one can access unwanted websites + unwanted extensions...But after putting that ISP DNS in dhcpd.conf file everyone are able to access the all kind of extesion + websites...

Not getting how its happening...

Today only came to know this issue... sorry for disturbing you...


Regards,
Sandeep CC
 
Old 10-12-2012, 04:56 AM   #21
deep27ak
Senior Member
 
Registered: Aug 2011
Location: Bangalore, India
Distribution: rhel 5x,6.0,6.2, centOS 5x,6.0,6.2
Posts: 1,194
Blog Entries: 4

Rep: Reputation: 221Reputation: 221Reputation: 221
How do you authenticate users by squid?
By changing browser settings?

It seems that the DNS and the squid server both are same machine so this is the reason when you changed the DNS the clients are not getting authenticated.

In that case check the firewall settings of your DNS server as you were having problem authenticating the clients
 
Old 10-03-2013, 07:57 AM   #22
sandeepc04
Member
 
Registered: Jun 2012
Location: India
Posts: 66

Original Poster
Rep: Reputation: Disabled
Sorry for late reply,

Finally got solution for this question, I am making mistake ... I have corrected my self, I have installed bind service and made zone files correctly then its started to ping any website by name

Regards,
Sandeep CC
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How to check if a server is up / down if pinging to that machine is not allowed Vi_rod Linux - Newbie 5 09-03-2012 01:06 PM
REDHAT Virtual machine not pinging to default gateway royalredhat Linux - Virtualization and Cloud 2 06-22-2010 01:50 AM
windows machine not pinging to linux sunils1973 Linux - Networking 3 07-21-2009 01:38 AM
Gust machine is not pinging(vmware workstation 6.5) lincoln.runwal Linux - Newbie 1 03-19-2009 08:10 PM
eth0 is up but not pinging to any machine devilzgaze Linux - Networking 1 03-09-2005 06:48 AM


All times are GMT -5. The time now is 10:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration