LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-23-2007, 08:20 PM   #1
dfw123
Member
 
Registered: Apr 2007
Posts: 45

Rep: Reputation: 15
phpmyadmin server error #2002


Hello!

I setup phpmyadmin on fedora6 and mysql 5.0 and use either ip or localhost, after I put username and password it had error:

#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

I change the port to 3306 in config.inc.php, still not work. How do I fix it? Thanks.
 
Old 04-24-2007, 03:15 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,962

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Make sure that the mysqld daemon is running:
Code:
ps -ef|grep mysqld
 
Old 04-24-2007, 03:39 AM   #3
dfw123
Member
 
Registered: Apr 2007
Posts: 45

Original Poster
Rep: Reputation: 15
yes, it is running and port 3306 is listening.

any suggestion?
 
Old 04-24-2007, 04:21 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,962

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
If you use port 3306 to connect to mysql server then you must put
Code:
$cfg['Servers'][$i]['connect_type'] = 'tcp';
in your config.inc.php
 
Old 04-24-2007, 02:00 PM   #5
dfw123
Member
 
Registered: Apr 2007
Posts: 45

Original Poster
Rep: Reputation: 15
yes, it is tcp.
 
Old 04-25-2007, 02:59 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,962

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Replace localhost with 127.0.0.1 to see if it fixes the problem.
 
Old 04-26-2007, 02:07 AM   #7
dfw123
Member
 
Registered: Apr 2007
Posts: 45

Original Poster
Rep: Reputation: 15
tried it even can not find server. I found mysql can be started by "#mysqld_safe --user=mysql" but can not started by "service mysqld start". error : timeout occured when trying mysqld

It can be stopped by "service mysqld stop"
In the error log :
InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name ./ibdata1
InnoDB: File operation call: 'open'.
InnoDB: Cannot continue operation.
mysqld ended

any suggestion?
 
Old 04-26-2007, 02:51 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,962

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Make sure that the databases directory is owned by user/group mysql. Also since you use Fedora you should check SELinux settings as it often causes various problems regarding permissions.
 
Old 04-26-2007, 03:51 PM   #9
dfw123
Member
 
Registered: Apr 2007
Posts: 45

Original Poster
Rep: Reputation: 15
I checked /var/lib/mysql and /var/lib/mysql/ibdata1 both are mysql user and group.

any suggestion?
 
Old 04-27-2007, 03:31 AM   #10
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,962

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Another suggestion is to take a look at mysql error logfile (located in the databases directory with a .err suffix). Also make sure that it's not a SELinux issue.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. NoviceW Linux - Networking 17 09-17-2014 03:13 PM
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysq mimique Linux - Software 23 08-14-2012 07:14 AM
ERROR 2002: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql. suziecorbett Linux - Software 8 10-09-2008 02:52 AM
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.so amee_stars Linux - Newbie 2 01-22-2007 03:48 AM
phpmyadmin #2002 error curos Slackware 5 07-18-2005 03:33 AM


All times are GMT -5. The time now is 03:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration