LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-04-2014, 10:20 AM   #1
Corovus
LQ Newbie
 
Registered: Dec 2014
Posts: 1

Rep: Reputation: Disabled
PHPmyAdmin login not working (but command line does)


Hello guys,

I have this issue since yesterday and itīs giving me headache because I canīt figure out how to solve it.
First of all, I am a total Linux Newbie, so I try to describe the situation as best as I can to avoid confusion.

Iīd like to create a new website for our company so my boss setup a CentOS 6.5 server for me.
The goal is to use Joomla 3.3 as CMS for this purpose.

I managed to install LAMP without any problems and the Apache Server is running just fine.
At his point I could login to PHPmyAdmin without any problems and created a database for Joomla.
But when I tried to install Joomla I realized that I need PHP 5.3.10 + but CentOS 6.5 only supports 5.3.3.

So I found THIS tutorial which uses “SCL repo” to get PHP 5.4 running.
It seems like it worked all fine and the new PHP Version is visible when opening php.info.

But when I tried to login to PHPmyAdmin again, it won’t let me. I don’t get any error message but when i type the password it just gets reset and after 3 or 4 times I get the message “Wrong Username/Password. Access denied.”
With Putty and the command “mysql –h localhost -u root –p” I can login to the mysql database, using the same username and pw I did for PHPmyAdmin.

Also, the first time I setup the Webserver (with the old PHP version) I installed a lot of PHP-Mods, like APC. But when I open php.info I canīt see them anymore (I could before installing PHP 5.4).

So my guess here is that are some dependencies or something like that is missing, because I have 2 PHP versions running on the Webserver. But with my minor understanding of how Linux, PHP and MySQL work together it’s impossible for me to fix this problem.

Please help me!!!

Last edited by Corovus; 12-04-2014 at 10:50 AM.
 
Old 12-05-2014, 07:00 AM   #2
j-ray
Senior Member
 
Registered: Jan 2002
Location: germany
Distribution: ubuntu
Posts: 1,532

Rep: Reputation: 132Reputation: 132
You better uninstall the old PHP version. You have to install all modules/extensions you need for the new version. The old versions will probably not work with a newer PHP version.

Probably less work would be to install a fresh CentOS or other distribution. As you are not familiar with Linux it will be rather difficult to compile in the extensions/modules...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
unable login via GUI but can login via Putty (command line) linuxandtsm Linux - Newbie 10 06-09-2011 03:08 PM
phpmyadmin error #1045, but command line works judebert Linux - Server 6 12-25-2006 04:05 PM
slackware login command line isnt working bob jones15 Linux - Newbie 14 03-27-2006 12:42 AM
slackware login command line isnt working bob jones15 Slackware 2 03-21-2006 01:52 PM
Changin Graphical Login to command line login 3DLirio Linux - Newbie 2 10-16-2003 10:43 PM


All times are GMT -5. The time now is 05:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration