LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-10-2012, 11:01 AM   #1
roopakl
Member
 
Registered: Sep 2011
Posts: 92

Rep: Reputation: Disabled
PHP version mismatch


Hi..All,
we have a server(RHEL 4, PHP version 4.3) in which we are running http, https, ftp and mail server.
We got new php files from web disigners and also tested locally with ubuntu 10.10 and Cent 5.5 with php 5.* version and found everything is working fine including search engine. So we uploaded the same files in to our web server and found everything is working fine apart from search engine. But in old php files the search engine also was working fine.
As we can see with these new php files, search engine is working only with above php 5 version. But our web server is having php version 4.3. So we need some expert help to update the php version from 4.3 to 5.*/above,
Or it would be much better if you assist in creating bash/perl script to enable the search engine in php 4.3 version.
Thanks in advance for your kind help.
 
Old 04-10-2012, 12:53 PM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
We'll certainly assist you with your scripts. Just post what you have written and let us know exactly what it's supposed to do and where you are having problems, and we'll help you work through them.
 
1 members found this post helpful.
Old 04-10-2012, 02:01 PM   #3
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Palm Island
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,415

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
roopakl,

You mentioned in your post that you want to upgrade php, currently you're running 4.3 version on RHEL 4. Well you can just download the latest version of php i.e., 5.4.0 which is stable with support. Just remove the older version which you've installed and install the newer version and configure according to your need.
 
1 members found this post helpful.
Old 04-10-2012, 06:02 PM   #4
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,604

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Upgrade PHP! You will also need to run a mysqlupgrade to upgrade your mysql tables to be compatible with php5 but php4 is antedated and has many security flaws.
 
1 members found this post helpful.
Old 04-10-2012, 10:28 PM   #5
roopakl
Member
 
Registered: Sep 2011
Posts: 92

Original Poster
Rep: Reputation: Disabled
David Guru,
Thanks for your kind reply. Since I don't know anything about php code, I am unable to write a script. Because I don't know that how search engine works with php. So need your guidance that what/where to look in php files for search engine or it would be appreciated if you could post a small bash script to enable the search engine according to php files. So I can get some idea about php and bash
Thanks for your kind help.

Last edited by roopakl; 04-10-2012 at 10:46 PM.
 
Old 04-10-2012, 10:40 PM   #6
roopakl
Member
 
Registered: Sep 2011
Posts: 92

Original Poster
Rep: Reputation: Disabled
Thanks for your kind reply Satyaveer Arya and Kustom42,
Could you please give some url links by which I can safely upgrade php and mysql without affecting to our current control panel settings.
If I need upgrade also mysql, then should I take SQL database backup before updating mysql?
Thanks for your kind help.
 
Old 04-11-2012, 12:30 PM   #7
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Palm Island
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,415

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
Quote:
Could you please give some url links by which I can safely upgrade php and mysql without affecting to our current control panel settings.
I hope you're paying redhat and availing their services. Then you must try from their network.

Code:
# yum install php php-gd php-mysql
You can try this. And search on google you'll find lots of links for downloading various rpms or tarballs for installing the package. Did you try anything on Google?
Good Luck!
 
Old 04-11-2012, 12:32 PM   #8
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Palm Island
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,415

Rep: Reputation: 305Reputation: 305Reputation: 305Reputation: 305
Or you can try this link on command line-

Code:
# wget http://www.cyberciti.biz/files/lighttpd/rhel4-php5-fastcgi/php-5.1.4-1.esp1.src.rpm
 
1 members found this post helpful.
Old 04-11-2012, 12:44 PM   #9
Kustom42
Senior Member
 
Registered: Mar 2012
Distribution: Red Hat
Posts: 1,604

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I would not use either of Satyaveers examples at this point as you did mention you are running a control panel on the server. Which control panel are you running? cPanel has an EasyApache function that will do this for you and Plesk Panel should get its upgrades from the atomic repo.
 
1 members found this post helpful.
Old 04-16-2012, 09:47 PM   #10
roopakl
Member
 
Registered: Sep 2011
Posts: 92

Original Poster
Rep: Reputation: Disabled
Sorry for the late reply.
Thank you both, problem solved!!!

Last edited by roopakl; 04-16-2012 at 09:49 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
svn: Version mismatch in ... acanthus Linux - Software 3 02-12-2015 06:22 AM
ABI version mismatch with server version rjpilla Ubuntu 1 10-03-2006 11:03 PM
help, gcc version and kernel version mismatch akanitkar Linux - Newbie 1 05-06-2006 08:02 AM
Kernel version Source Version mismatch after recompile chuckleberry Linux - Software 1 06-20-2005 07:37 PM
Libpng version mismatch narc Linux - Software 0 08-19-2004 09:48 AM


All times are GMT -5. The time now is 10:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration