LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-24-2007, 08:57 PM   #1
JEBBEDIAH C
LQ Newbie
 
Registered: Jan 2005
Posts: 9

Rep: Reputation: 0
Permissions troubles


I'm having loads of trouble managing permissions in my kubuntu distro. Pretty much every file I care about has been set up as owner-root, group-root with permissions as follows: rwxr-xr-x. I have tried every conceivable way I know of, and have read about, to change the permissions so that the group has rwx privileges. Nor can I figure out a way to change the group to the one I want. Something is fundamentally wrong, but I can't figure it out.

For example, trying to modify a jpg file I've typed (in the terminal):

sudo chmod -v g+w img_0164.jpg

And this is what I'll get:

mode of 'img_0164.jpg' changed to 0775 (rwxrwxr-x)

So, you'd think I'd be all set. However, when I do:

ls -l img_0164.jpg

This is what I get:

-rwxr-xr-x 1 root root .....bla bla

As you can see, group still doesn't have write permissions. This is very frustrating. I'd appreciate your help!

By the way, these files are all on a FAT32 disk. I don't have dual boot, but I needed to keep FAT32 to keep all my files in tact from the transition from Windows.

Last edited by JEBBEDIAH C; 06-24-2007 at 09:09 PM.
 
Old 06-25-2007, 02:57 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,085

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
FAT32 is a windows filesystem. It has absolutely no concept of lunux's owner:group or permissions, so the attributes of individual files on a FAT32 disk cannot be changed with chmod.

The default permissions for all the files on that FAT32 disk are determined by how it was mounted on your linux filesystem. So, how was it mounted? Either you did it yourself (what command did you use?) or the system mounted it for you at boot time (take a look in /etc/fstab and look at the line that refers to your FAT32 disk. man fstab and man mount will tell you the available options).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Permissions Troubles Darth Cupcake Ubuntu 5 05-28-2007 06:48 PM
dark side convert with permissions troubles... Jim Yadon Linux - Newbie 5 08-21-2006 09:12 PM
troubles with SATA, troubles with NVIDIA aevangelica Linux - Hardware 6 10-17-2005 03:39 AM
file permissions OK, but command permissions? stabu Linux - General 2 10-05-2005 01:00 PM
Troubles with Nvidia permissions crud Slackware 4 05-26-2005 03:16 PM


All times are GMT -5. The time now is 11:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration