LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-18-2008, 12:33 PM   #1
Catapult
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
Permissions to mounted device


Hi all,

I have a Lacie remote disk drive that I have mounted on our linux box. The problem I have is that only Root can write to the disk drive. I really need for our backup user to be able to write to the drive too.

I have configured fstab with the following entry:

//192.168.25.44/LinuxServer /mnt/backupdisk smbfs rw 0 0

I have tried mounting the drive with different options e.g. defaults, but I still have the same problem.

When the drive isn't mounted to the /mnt/backupdisk directory my backup user has full permissions to the directory. As soon as the drive is mounted only root user and root group have permissions.

I have tried chmoding the directory once it is mounted but this doesn't seem to do anything.

Does anyone have any light they can shed on this for me? I'd be very grateful :O)
 
Old 12-18-2008, 12:43 PM   #2
openSauce
Member
 
Registered: Oct 2007
Distribution: Fedora, openSUSE
Posts: 252

Rep: Reputation: 39
What file system is on the drive? If it's a system that doesn't support unix-like permissions (e.g. FAT or NTFS), you need to set the permissions/ownership for the whole drive at mount time.

Try setting the options field in fstab to
Code:
defaults,uid=####,gid=####
where #### is your numeric user id (can be found in /etc/passwd). This will work for local FAT/NTFS drives, not sure about smbfs.

You might also want to set the dmask and fmask values in fstab - check out man mount to see what they do.
 
Old 12-18-2008, 04:52 PM   #3
bdox
Member
 
Registered: Feb 2005
Location: SoL iii
Distribution: Mandriva 2007
Posts: 110

Rep: Reputation: 15
Hi there!
try this out:
//192.168.25.44/LinuxServer /mnt/backupdisk smbfs umask=0,users,rw 0 0


umask=0 should give the wr permissions you want. 'users' just in case (see #man mount for mor detail
 
Old 12-19-2008, 06:07 AM   #4
Catapult
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks guys

I tried your way first bdox but it didn't work ;o(

But your's worked great openSauce!

Thanks for the help. I'm sure you'll see me back here again some time )
 
Old 12-19-2008, 08:29 AM   #5
openSauce
Member
 
Registered: Oct 2007
Distribution: Fedora, openSUSE
Posts: 252

Rep: Reputation: 39
Glad you got it working. I would also have expected bdox's suggestion to work: the uid and gid options set the ownership of files on the drive, whereas umask sets the permission bits (it does it in an inverted way for some reason, so umask=0 sets the permissions to 777, umask=777 would set them to 000, 022 would be 755, etc), or you can use dmask and fmask to separately set the perms for directories and regular files.

If you can do what you want to do now, you can leave things be I guess, but it might be worth looking at if you want to set the permissions rather than the ownership. Feel free to come back if you've got more questions
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mounted device: permissions error the1sephiroth Linux - General 7 12-27-2005 12:12 AM
Permissions on mounted disk simanyay Linux - Software 2 03-30-2004 11:23 AM
mounted vfat permissions n3tw0rk Linux - General 3 12-05-2003 05:41 PM
permissions on mounted smbfs-- elsakka Linux - Newbie 0 07-08-2003 03:29 AM
Mounted NFS permissions dlsw Linux - Networking 2 03-22-2001 01:46 PM


All times are GMT -5. The time now is 08:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration