LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-15-2004, 07:44 PM   #1
CarnageBox
Member
 
Registered: Nov 2004
Location: Worcester, MA
Distribution: Fedora Core 3
Posts: 47

Rep: Reputation: 15
Permissions on Windows Mounts


//hulk.pentatonicrecords.com/egrimes /mnt/hulk smbfs credentials=/et
//hulk.pentatonicrecords.com/shiat /mnt/shiat smbfs credentials=/et
/dev/hda1 /mnt/xppro ntfs ro,umask=0222 0 0
/dev/hdb1 /mnt/xppro2 ntfs ro,umask=0222 0 0
/dev/hdd5 /mnt/backup1 ntfs ro,umask=0222 0 0
/dev/hdd6 /mnt/backup2 ntfs ro,umask=0222 0 0

I have that in my /etc/fstab for mounting my windows partitions, obviously the first two are network shares. The only problem is if I try and copy anything to and from I have to do it as root because my user doesn't get access to the files. It wouldn't be so bad if my user could use the copied files. I copied some songs over to my linux partition as root and I couldn't play them because it said I didn't have the proper permissions. Is there anyway to change it so I can grant my user read/write access of all the volumes? Thanks.
 
Old 12-16-2004, 09:00 AM   #2
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
i have " ro,users,umask=0022 " in my fstab for ntfs fs.
once i tried 0222 for umask ( wich sounds logic as it's read-only ) and got throubles. ( don't understand ??? )

also adding the option "users" might help.

egag
 
Old 12-16-2004, 10:53 AM   #3
CarnageBox
Member
 
Registered: Nov 2004
Location: Worcester, MA
Distribution: Fedora Core 3
Posts: 47

Original Poster
Rep: Reputation: 15
Hmm...that didn't seem to do anything. What's this users option you're talking about?
 
Old 12-16-2004, 12:08 PM   #4
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
-----------from man mount
users Allow every user to mount and unmount the file system. This option implies the options noexec, nosuid, and nodev (unless overridden by subsequent options, as in the option line users,exec,dev,suid).
-----------

read " man mount" .

but ... do you try to write to ntfs from linux ?

egag
 
Old 12-16-2004, 12:52 PM   #5
CarnageBox
Member
 
Registered: Nov 2004
Location: Worcester, MA
Distribution: Fedora Core 3
Posts: 47

Original Poster
Rep: Reputation: 15
Yea, I have some backup drives that are formatted in NTFS for my windows back up and I put songs on there from Linux and various other files. I'm not dealing with mount i'm dealing with /etc/fstab so it's auto mounting when I boot but apparently only my root user gets access to r/w. I'm sure there is some simple thing I'm missing but I can't figure it out.
 
Old 12-16-2004, 01:08 PM   #6
bhardwaj
LQ Newbie
 
Registered: Dec 2004
Location: india
Distribution: fedora
Posts: 2

Rep: Reputation: 0
try to use
dev/hdb1 /mnt/xppro2 ntfs ro,uid=username,umask=0222 0 0
etc.
may be it can do something.
but i am using vfat partition so i am not 100% sure that it may work
 
Old 12-16-2004, 01:08 PM   #7
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well...i would not use ntfs-write ( it's experimental... )
and all of your drives are "ro" in fstab....? ( that's read-only ).
furthermore when you edit fstab-lines your dealing with the "mount " command.

egag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Permissions and smbfs mounts kitanokikori Linux - Networking 2 11-11-2004 10:01 AM
How do I set up proper drive permissions (fstab reamins static despite all mounts) Lechium Linux - Hardware 9 07-03-2004 10:33 AM
Windows Permissions through SAMBA joshnya Linux - Security 1 12-16-2003 11:48 PM
Windows Permissions msamd Linux - Networking 0 12-02-2003 08:44 AM
Permissions on a windows drive Vlackmar Linux - General 3 03-06-2002 09:38 AM


All times are GMT -5. The time now is 11:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration