LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-03-2005, 08:20 AM   #1
devilsaltarboy
LQ Newbie
 
Registered: Jun 2005
Distribution: mandrake
Posts: 4

Rep: Reputation: 0
Permissions on second hdd


Hi All
After having a look at a lot of the questions listed here this question seems quite silly so please be gentle.
I managed to get mandrake 10.1 installed without a problem and managed to get it to detect my second hard drive. My problem lies in the permissions to use that second harddrive.

I have two Fat32 partitions for my storage of my files and they are mounted in the /home/backupdr1 and /home/backupdr2 respectively. In my fstab I have put the lines
/dev/hdb5 /home/backupdr1 vfat defaults 1 1
/dev/hdb6 /home/backupdr1 vfat defaults 1 1

I can access the hard drives but only under root.
I have tried to change the ownership of the /home/backupdr1 whilst the device is mounted and it wont let me do so. I have tried to change the ownership of the directory whilst not mounted and it simply changes it back to root when it mounts. It also changes the timestamp on the directory to Jan 1 1970 (dont know if relevant).

after reading around i changed it to the following
/dev/hdb5 /home/harddrive170M vfat auto,user,exec,rw 0 0
and still the same problem occurred, i can get in root but not any other user.
Can anyone help me get it so I can change this.
Cheers
Peter

Last edited by devilsaltarboy; 06-03-2005 at 10:13 AM.
 
Old 06-03-2005, 10:11 AM   #2
Andrew Benton
Senior Member
 
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
/dev/hdb5 /home/backupdr1 vfat umask=0 1 1
/dev/hdb6 /home/backupdr1 vfat umask=0 1 1
 
Old 06-03-2005, 10:35 AM   #3
JunctaJuvant
Member
 
Registered: May 2003
Location: Wageningen, the Netherlands
Distribution: OS X & FreeBSD
Posts: 488

Rep: Reputation: Disabled
The default permission is 755, to change this use the "umask" option.
You could try something like this:
Code:
/dev/hdb5 /home/harddrive170M vfat defaults,umask=000 0 0
See also "man mount". For a more secure setup, check this out or this.
Hope that helps.

Last edited by JunctaJuvant; 06-03-2005 at 10:38 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to add a third hard drive (hdd) and get Unable to open /dev/hdd MikeyCarter Linux - Hardware 4 12-26-2005 11:27 PM
Mounting external Firewire NTFS HDD & Permissions Ganza Linux - Newbie 9 11-06-2005 08:39 AM
permissions to use my hdd jappstam12345 Mandriva 2 03-26-2005 04:30 AM
Samba + hdd permissions paidhitman Linux - Newbie 2 05-27-2004 03:53 AM
How to format & mount 2nd hdd after FedCor1 has been installed on 1st hdd? clay394 Fedora 1 05-18-2004 02:50 PM


All times are GMT -5. The time now is 06:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration