LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-12-2003, 05:31 AM   #1
Hdata
LQ Newbie
 
Registered: Dec 2002
Location: Europe, Sweden, Värmland, Kil
Distribution: Internet :)
Posts: 9

Rep: Reputation: 0
Question Permissions on FAT32 mounted disks in RH 8


After mounting my windows FAT32 partitions under Linux RedHat 8 I have some problems with permissions.

Standard settings for my mount point is File Owner: root
and File group: root

Since Im running a Webserver from this directory I want to be able to make som chmod changes to files in it..

This is however not possible since I lack permission to do so, even though Im logged in as root

Now tell me what is it I need to do to change permissions on my folders I use as mountpoints?

For example I want the one of the mounted partititions to be File Owner and File group set as apache ...

Please help

 
Old 04-12-2003, 05:38 AM   #2
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You would normally add those to the options section in fstab OR to the mount command. The fstab might be:
/dev/hdx /mnt/fat vfat users,uid=0,gid=0,umask=007 0 0

However, if you want a specific group to own this mount point, you can change gid= to the number corresponding to the group (in /etc/group) to take ownership, such as 'users' or 'apache' for an apache server partition.



Cool
 
Old 04-12-2003, 08:12 AM   #3
pablob
Member
 
Registered: Apr 2003
Location: Madrid
Distribution: RHAS, Kubuntu, Solaris, TRU64
Posts: 381

Rep: Reputation: 31
maybe you are mounting it read-only ?

Check for 'rw' inside /etc/mtab & /etc/fstab
 
Old 04-12-2003, 03:44 PM   #4
justwally
LQ Newbie
 
Registered: Apr 2003
Location: Seattle, WA, US
Distribution: Mandrake, RH8.0, FC2, Xandros2.x, SuSE 9.x
Posts: 5

Rep: Reputation: 0
FAT32 rw problems

I've run into this very same problem with my recent look at RH8 (never had this problem with Mandrake or Suse). Root can mount it rw and can then rw, but trying to chmod (or, even chown) anything about the FAT32 partition is impossible as root.

Regular users can mount it (my fstab even specified rw) but not write to it. I just found a couple recommendations that might help (I'm going to try them today when I can make the time):

/dev/hdaX /mnt/windows1 vfat rw,umask=0007 0 0

- or -

/dev/hdaX /mnt/windows1 vfat user,exec,conv=binary,rw,umask=000 0 0

Last edited by justwally; 04-12-2003 at 03:56 PM.
 
Old 04-12-2003, 04:17 PM   #5
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Rep: Reputation: 30
Change your fstab entry to this:
/dev/hdax /mnt/windows1 vfat auto,defaults,umask=000

Seriously, this works.
 
Old 04-12-2003, 11:25 PM   #6
justwally
LQ Newbie
 
Registered: Apr 2003
Location: Seattle, WA, US
Distribution: Mandrake, RH8.0, FC2, Xandros2.x, SuSE 9.x
Posts: 5

Rep: Reputation: 0
What Bax posted works, as does the following:


/dev/hdaX /mnt/windows1 vfat user,exec,conv=binary,rw,umask=000 0 0

Works flawlessly.

Good luck.
 
Old 04-13-2003, 01:21 AM   #7
bax
Member
 
Registered: Dec 2001
Location: NoVA
Distribution: Ubuntu, Solaris, OpenBSD
Posts: 492

Rep: Reputation: 30
Mine's much more simple
 
Old 04-13-2003, 03:36 AM   #8
justwally
LQ Newbie
 
Registered: Apr 2003
Location: Seattle, WA, US
Distribution: Mandrake, RH8.0, FC2, Xandros2.x, SuSE 9.x
Posts: 5

Rep: Reputation: 0
Thumbs up

Yours is much more simple. :-)
 
Old 04-21-2003, 02:46 PM   #9
Hdata
LQ Newbie
 
Registered: Dec 2002
Location: Europe, Sweden, Värmland, Kil
Distribution: Internet :)
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by MasterC
You would normally add those to the options section in fstab OR to the mount command. The fstab might be:
/dev/hdx /mnt/fat vfat users,uid=0,gid=0,umask=007 0 0

However, if you want a specific group to own this mount point, you can change gid= to the number corresponding to the group (in /etc/group) to take ownership, such as 'users' or 'apache' for an apache server partition.



Cool


Perfect... This did the trick. At least it seems like it The folder is set to user apache and group apache.
I am now able to use the chmod command too without trouble. And Im able to broswe directories from the web. Percect and many thanks to you all!!!
 
Old 04-21-2003, 02:50 PM   #10
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You're Welcome

Cool
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Adjust permissions for a mounted windows fat32 filesystem greengrocer Linux - Newbie 2 08-28-2005 02:21 AM
FAT32 fs can't be mounted correctly ben0429 Linux - Hardware 1 03-20-2005 09:17 PM
Automount - releases disks but drives stay mounted JohnKFT Slackware 8 04-19-2004 06:07 PM
mounted fat32 problems curos Linux - Newbie 2 08-04-2003 01:31 PM
permissions and mounted fat32 partition ianunderwood Linux - Newbie 8 06-25-2003 06:17 AM


All times are GMT -5. The time now is 03:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration