LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-29-2004, 01:04 PM   #1
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Rep: Reputation: 30
permissions dialog in kde


Hi,
I'm in the process of setting up an old hp latop with linux for someone with zero linux knowledge and I'm trying to do it in a way that doesn't scare them away back to windows.
It's now got Slackware 9.1 installed and is running KDE for it's desktop environment. I have successfully adding an icon for a floppy drive and can easily mount, unmount read and write files to a DOS disk from the desktop. The problem is that I keep getting this annoying dialog box that reads: unable to change file permissions every time I drag a file to the floppy's directory. This message seems innocuous since the files can be moved back and forth, and a windows machine doesn't care about permissions and ownership. I've tried tweaking the /etc/fstab file but that doesn't see to work. Here's the relevant line:

/dev/fd0 /mnt/floppy auto noauto,quiet,rw,users,umask=0000,gid=users 0 0

Since I am always flapping about how much better Linux is than Windows since it doesn't do all of the annoying crap all the time that we all love to hate about Windows, I want to get this system running as smoothly as possible. Any ideas?

-geomatt
 
Old 07-29-2004, 01:37 PM   #2
win32sux
Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
try removing the umask=0000 and/or the quiet and try again...

i have the feeling it's one of those... i'm not sure though...


Last edited by win32sux; 07-29-2004 at 01:42 PM.
 
Old 07-29-2004, 02:16 PM   #3
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
Code:
     
/dev/fd0 /mnt/floppy auto noauto,owner,users,rw 0 0
easiest way is to do it like this!!
 
Old 07-29-2004, 05:24 PM   #4
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Original Poster
Rep: Reputation: 30
Hey thanks for the responses!
I tried both of your suggestions, rebooting after each change, and neither worked. I did come up with another clue, though.....
When I create the icon on the KDE desktop for the floopy device initially it is assigned ownership by root. But then once it has been mounted KDE changes its ownership to the user who is currently logged in. Mounting the drive from inside a terminal as root doesn't seem to do that.

-geomatt
 
Old 07-30-2004, 11:04 AM   #5
geomatt
Member
 
Registered: Mar 2004
Location: PA
Distribution: Slackware 12.0
Posts: 315

Original Poster
Rep: Reputation: 30
Fixed it!
After having added mount points and fstab entries for a usb key and a digital camera, both of which use vfat as their file system type, I thought I'd try changing the floppy's type from auto to vfat. That did the trick. Now the trap for another hapless MS user has been baited with a smoothly running Linux system - assuming I can get the modem up and runing at the victim's house.... hehehe

Cheers,
geomatt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE save/open dialog for Firefox a thing Linux - Software 4 04-25-2006 01:13 AM
KDE login dialog (3 questions) KlaymenDK *BSD 5 11-06-2005 01:58 PM
KDE system halt dialog corbis_demon Linux - Software 1 08-06-2004 01:00 AM
Dragon on logout dialog in KDE... craigs1987 Linux - Software 2 07-06-2004 05:25 PM
KDE - Turn off previews in open dialog Wynd Linux - Software 5 09-10-2003 11:15 AM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration