LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-23-2003, 07:43 PM   #1
ianunderwood
Member
 
Registered: Apr 2003
Location: Edinburgh, Scotland, UK
Distribution: SuSE 9.2, VectorLinux 3.2
Posts: 68

Rep: Reputation: 15
permissions and mounted fat32 partition


Hi all

I just installed rh9 on a friend's PC as a single drive dual-boot. He began with two 15GB NTFS partitions, so I removed the second one, gave about 4.5GB to / and then filled up the remaining space with a new fat32 partition (because ntfs isn't supported under linux, right?, and I wanted him to be able to share his data between the two OSs). I created the fat32 partition with something called Paragon Partition Manager under XP.

I've modified fstab so that the fat32 partition is mounted to /fat32 at start-up. It's working OK except that the permissions for /fat32 (when mounted) allow only u (i.e. root) to write files. I can neither change the owner of /fat32 when mounted, or alter the permissions (and if I log in as root and make the changes in graphical mode, they simply don't get registered). This renders the partition pretty useless unless he's prepared to log in as root or do everything from the terminal. How can I make the partition writable for other users?? I never had this problem before, so I just can't work out what's going on. Furthermore, because my own computer is a few hundred miles away, I can't check it out for comparison.

Best, Ian
 
Old 06-23-2003, 07:52 PM   #2
green_dragon37
Member
 
Registered: Oct 2002
Location: Lower Alabama
Distribution: Slackware, OpenBSD 3.9
Posts: 344

Rep: Reputation: 31
What does the fstab entry for the part. look like? My guess is that you would have to make the files owned by the user or group of users that you want to be able to write to the partition with the gid and.or uid options.

Ian
 
Old 06-23-2003, 09:47 PM   #3
warheros
Member
 
Registered: Jun 2003
Location: mason, mi, usa
Distribution: rh9
Posts: 87

Rep: Reputation: 15
did you try chmod? or like green_dragon37 said, chown?

chmod 775 /thepartition <-- this makes the root and user have read/write/executable rights with other having only read/executable.

chown useryouwanttoownpartition /thepartition
 
Old 06-24-2003, 08:12 AM   #4
ianunderwood
Member
 
Registered: Apr 2003
Location: Edinburgh, Scotland, UK
Distribution: SuSE 9.2, VectorLinux 3.2
Posts: 68

Original Poster
Rep: Reputation: 15
Hi, and cheers for the replies

fstab looks like:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/hda6 /fat32 vfat defaults 1 1
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

chmod doesn't work once the partition is mounted. Here's the error I get:

[root@e-stc004 root]# chmod a+w /fat32
chmod: changing permissions of `/fat32' (requested: 0777, actual: 0755): Operation not permitted

I get the same effect if I umount and then mount manually with:

[root@e-stc004 root]# mount -t vfat /dev/hda6 /fat32

Cheers

Ian
 
Old 06-24-2003, 08:29 AM   #5
eltongeoff
Member
 
Registered: Mar 2003
Posts: 76

Rep: Reputation: 15
in /etc/fstab under options, for the mounted drive set umask=002
 
Old 06-24-2003, 08:31 AM   #6
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Change this line:
/dev/hda6 /fat32 vfat defaults 1 1
to
/dev/hda6 /fat32 vfat users,auto,umask=002,rw 0 0
Or for the more technical geeks:
/dev/hda6 /fat32 vfat users,uid=0,gid=0,umask=002,auto,noexec,rw 0 0



Cool
 
Old 06-25-2003, 04:33 AM   #7
ianunderwood
Member
 
Registered: Apr 2003
Location: Edinburgh, Scotland, UK
Distribution: SuSE 9.2, VectorLinux 3.2
Posts: 68

Original Poster
Rep: Reputation: 15
cheers for all the help

In the end I used uid=500,gid=500 because using 0 (i.e. root) left me with exactly the same problems.

All best, Ian
 
Old 06-25-2003, 05:10 AM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
And I should be slapped with a mighty wet noodle, that should have been my numbers in my example, not root's uid

Cool
 
Old 06-25-2003, 06:17 AM   #9
ianunderwood
Member
 
Registered: Apr 2003
Location: Edinburgh, Scotland, UK
Distribution: SuSE 9.2, VectorLinux 3.2
Posts: 68

Original Poster
Rep: Reputation: 15
No problem. At least it made me think about what the values meant!!

Many thanks

Ian
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Adjust permissions for a mounted windows fat32 filesystem greengrocer Linux - Newbie 2 08-28-2005 02:21 AM
FAT32 partition ro...but not mounted ro SaurianOverlord Linux - Newbie 15 04-12-2005 11:32 PM
NTFS partition cannot be mounted after converting from FAT32 aweir14150 Mandriva 5 01-27-2005 04:11 PM
Making mounted FAT32 partition writable by all jrittvo Fedora 14 06-07-2004 03:39 AM
Permissions on FAT32 mounted disks in RH 8 Hdata Linux - Newbie 9 04-21-2003 02:50 PM


All times are GMT -5. The time now is 02:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration