LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-30-2011, 05:32 PM   #1
yaximik
Member
 
Registered: Nov 2010
Posts: 87

Rep: Reputation: 0
permissions


Hi everyone,

Tried searching but could not find answer, so asking for help. I am using RHEL55 and work in a user mode following advice of one textbooks, reserving my root account for maintenance purposes only. Working as a user, I often need to save my work on external transportable drive, for which I use 750GB USB drive that was formatted in Windows XP a while ago. The drive mounts and I can read files, but no modifications or write access for me as a user. To write to it, I have to log out and log in as root, then dragging files works just fine.
The problem is that I cannot change permissions to the drive, even as a root (in the Properties window). SELINUX mode is "Permissive". Whenever I try to change, it always defaults back to root ownership. I changed disk permissions on Windows, giving the full access to every item under the Security tab in disk Properties (even to Everyone), but the disk still shows root ownership under RHEL with no write permissions in the user mode.
Following one advice there, I added myself to the disk group, still no avail.

Here is output of mount:

[yaximik@G5NNJN1 ~]$ mount
/dev/mapper/VolGroup00-LogVol00 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/sda3 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
/dev/mapper/VolGroup00-LogVol02 on /usr type ext3 (rw)
/dev/mapper/VolGroup00-LogVol03 on /tmp type ext3 (rw)
/dev/mapper/VolGroup00-LogVol04 on /var type ext3 (rw)
/dev/mapper/VolGroup00-LogVol05 on /home type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
/dev/sdb1 on /media/Passport type fuseblk (rw,noexec,nosuid,nodev,allow_other,blksize=4096,default_permissions)

Thanks for help.
 
Old 09-30-2011, 06:01 PM   #2
ButterflyMelissa
Senior Member
 
Registered: Nov 2007
Location: Somewhere on my hard drive...
Distribution: Manjaro
Posts: 2,686
Blog Entries: 23

Rep: Reputation: 398Reputation: 398Reputation: 398Reputation: 398
How about (just a hint) giving the user all permission while you're root. Or, if that's okan ownership?
 
Old 09-30-2011, 07:38 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
Quote:
SELINUX mode is "Permissive"
it should be set to ENFORCING by default
the permissive is for DEBUGGING problems only

that usb ( and GUESSING ONLY ntfs format) drive dose not appear to be listed

please post the output of
Code:
su -
fdisk -l
----
lsusb
unless it IS "/dev/sdb1" and is NTFS and you DID NOT install the ntfs support
and HOW are you mounting it ?
with fstab ?
if so please post that line of the file


the DEFAULT behavior for a windows ntfs drive is
for root ONLY to have r/w and for the normal users to have ONLY read access

seeing as this IS RHEL 5.5 - you ARE paying for the support and updates
do a search of the red hat knoladge base
-- your red hat network ( RHN) username and password WILL be required --
https://www.redhat.com/support/
https://access.redhat.com/knowledge/search

Last edited by John VV; 09-30-2011 at 07:42 PM.
 
Old 10-01-2011, 03:15 AM   #4
tommyttt
Member
 
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Rep: Reputation: 34
Hi yaximik;

One way to solve your problem would be to back up the files on the external drive, reformat it for linux (ext 3 or 4), ans set all its permissions to 'rw'. Then you would be able to read and write to it.

OR, you could add the following line (after modifying for drive info) to /etc/fstab (as root).
Code:
/dev/disk/by-id/ata-WDC_WD15EADS-00P8B0_WD-WMAVU0273914-part1 /Windows7   ntfs-3g   users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
Tom

Last edited by tommyttt; 10-01-2011 at 03:17 AM.
 
Old 10-01-2011, 07:44 PM   #5
yaximik
Member
 
Registered: Nov 2010
Posts: 87

Original Poster
Rep: Reputation: 0
Thanks for responses and suggestions.

< How about (just a hint) giving the user all permission while you're root. Or, if that's okan ownership? >

As I mentioned already, in the root mode (when I can write to the drive) I cannot change any of disk properties, such as ownership, folder and file access permissions. Every field immediately turns back to what is already assigned (owner: root, etc.). The only field I was able to change is SELINUX content, which I changed to user_data, which did not make any difference.

< that usb ( and GUESSING ONLY ntfs format) drive dose not appear to be listed >

It is listed as /dev/sdb1 on /media/Passport. Here is fdisk output:

[root@G5NNJN1 yaximik]# /sbin/fdisk -l

Disk /dev/sda: 1498.6 GB, 1498675150848 bytes
255 heads, 63 sectors/track, 182203 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 10 80293+ de Dell Utility
/dev/sda2 11 663 5245222+ 8e Linux LVM
/dev/sda3 * 688 719 257040 83 Linux
/dev/sda4 720 182203 1457770230 5 Extended
/dev/sda5 728 4644 31463302+ 8e Linux LVM
/dev/sda6 4645 182203 1426242636 8e Linux LVM

Disk /dev/sdb: 749.4 GB, 749452918784 bytes
255 heads, 63 sectors/track, 91115 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 1 91116 731887584 7 HPFS/NTFS

Here is lsusb output:

[root@G5NNJN1 yaximik]# /sbin/fdisk -l

Disk /dev/sda: 1498.6 GB, 1498675150848 bytes
255 heads, 63 sectors/track, 182203 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 1 10 80293+ de Dell Utility
/dev/sda2 11 663 5245222+ 8e Linux LVM
/dev/sda3 * 688 719 257040 83 Linux
/dev/sda4 720 182203 1457770230 5 Extended
/dev/sda5 728 4644 31463302+ 8e Linux LVM
/dev/sda6 4645 182203 1426242636 8e Linux LVM

Disk /dev/sdb: 749.4 GB, 749452918784 bytes
255 heads, 63 sectors/track, 91115 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 1 91116 731887584 7 HPFS/NTFS


< unless it IS "/dev/sdb1" and is NTFS and you DID NOT install the ntfs support >
< and HOW are you mounting it ? >
< with fstab ? >
< if so please post that line of the file >


I just plug it in a front usb port and it is mounted both in user and in root modes.

< seeing as this IS RHEL 5.5 - you ARE paying for the support and updates >
< do a search of the red hat knoladge base >


I got my RHEL55 box from Dell, and Red Hat sends me back to Dell with all questions. But the box works just fine, so Dell is not of much help.

In regard to reformatting drive in Linux, that would be the last resort if there is no better way. I am using this drive with Windows and Mac too.

< OR, you could add the following line (after modifying for drive info) to /etc/fstab (as root).>
< Code:
< /dev/disk/by-id/ata-WDC_WD15EADS-00P8B0_WD-WMAVU0273914-part1 /Windows7 ntfs-3g < users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0


What this line of code means, briefly? I could certainly try that.

Thanks,
 
Old 10-01-2011, 07:54 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
then it is NTFS and seeing as RHEL BY DEFAULT has only read ONLY for ntfs
the ntfs-3g software is NOT installed by default you need to install it for read/write support

please contact your PAID for support rep
https://www.redhat.com/support/

if you search the knowledge base ( your paid for username/password IS required) for "ntfs " a how to is listed
https://access.redhat.com/knowledge/search

https://access.redhat.com/knowledge/...en&cid=2448949
"How to enable NTFS support on Red Hat Enterprise Linux ?"
https://access.redhat.com/kb/docs/DOC-35964
 
Old 10-02-2011, 02:22 PM   #7
yaximik
Member
 
Registered: Nov 2010
Posts: 87

Original Poster
Rep: Reputation: 0
Thumbs up <solved> permissions

Thanks. I actually thought ntfs-3g was installed, and when I checked with "Add/Remove Software" a few checked boxes were for fuse-ntfs-3g items, but I suspected something was missing. Then I uninstalled everything and simply followed the advice using yum install ntfs-3g. I got the latest version (2011.4.12-5), and after installation the disk became writable in the user mode as well.

[QUOTE=John VV;4487555]then it is NTFS and seeing as RHEL BY DEFAULT has only read ONLY for ntfs
the ntfs-3g software is NOT installed by default you need to install it for read/write support


A few questions for closure, if it is not minded:

1.If it was only in default read only, why the disk was writable by root? Did I miss something?

2.By default both i386 and x86_64 were installed - do I need both for my 64-bit box or I can safely uninstall i386?

3. Search in Add/Remove Software revealed presence of ntfs-3g-progs-2011.4.12.1.el5.pp.x86_64, whoch is some utilities for manipulating NTFS partitions. However, when I tried to install it (presuming that a newer version 2011.4.12-5 is backward compatible, I got message:

Missing Dependency: ntfs-3g = 2011.4.12-1.el5.pp is needed by package ntfs-3g-progs-2011.4.12-1.el5.pp.x86_64 (pp-contrib)

I could not find ntfs-3g = 2011.4.12-1.el5.pp on the net, though. I guess I have to wait until a compatible version of the tools becomes available.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
relation between programs permissions and permissions of the files they use rblampain Linux - Security 1 07-10-2011 09:40 PM
[SOLVED] filesystem permissions question - making so user can't change permissions? c0pe Linux - Security 4 07-12-2010 10:06 AM
[SOLVED] Lack basic understanding of permissions(apache permissions problem) cK` Linux - Newbie 7 04-09-2010 12:49 AM
File permissions v. directory permissions Completely Clueless Linux - Newbie 7 07-09-2009 09:33 AM
file permissions OK, but command permissions? stabu Linux - General 2 10-05-2005 01:00 PM


All times are GMT -5. The time now is 10:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration