LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-28-2004, 01:37 PM   #1
Steve1445
LQ Newbie
 
Registered: Jan 2004
Location: Charleston, SC
Distribution: Redhat 9.0
Posts: 15

Rep: Reputation: 0
Permissions


Using Samba, RH9.0 all users belong to one group (users) and one person (Admin), yet when users access their files the file flips over to read only. Permission level is set to 777 and a chmod will set straight but how do I prevent this from happening?
 
Old 01-28-2004, 01:53 PM   #2
skel
Member
 
Registered: Jan 2004
Distribution: Slackware 10 ; Gentoo ; OpenBSD 3.6
Posts: 101

Rep: Reputation: 15
are you exporting a smb share from linux? if so, make sure that it is exporting as RW.
 
Old 01-28-2004, 01:56 PM   #3
Steve1445
LQ Newbie
 
Registered: Jan 2004
Location: Charleston, SC
Distribution: Redhat 9.0
Posts: 15

Original Poster
Rep: Reputation: 0
Not sure I follow the "exporting" the share is available on the linux box, how do I make sure its RW?
 
Old 01-28-2004, 04:01 PM   #4
skel
Member
 
Registered: Jan 2004
Distribution: Slackware 10 ; Gentoo ; OpenBSD 3.6
Posts: 101

Rep: Reputation: 15
what I mean by exporting is: do you make your linux filesystem available to remote machines using smb?

so are you trying to use windows to connect to a linux filesystem? i believe that samba assigns its own permissions, so if you chmod a file the settings won't be necessarily be reflected in samba (i could be wrong tho).

I think what you have to do is modify your current config. either through the samba web-based config or by hand.

check out the howto at:
http://www.tldp.org/HOWTO/SMB-HOWTO.html

it is fairly old but probably still relevant.

Or if you are trying to access a windows filesystem from linux, then check the settings on the windows box and make sure you are mounting the filesystem with an appropriate user, ie:
mount -t smbfs -o username=yourusername ....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
file permissions OK, but command permissions? stabu Linux - General 2 10-05-2005 01:00 PM
permission ... permissions .... permissions alaios Linux - General 1 05-31-2005 05:16 AM
Permissions jymmi Linux - Newbie 3 04-15-2005 12:43 AM
Permissions help reddog64 Linux - Newbie 1 04-22-2004 06:23 PM
getting a directory's permissions and creating a new one with the same permissions newbie1000101 Programming 1 04-10-2004 01:52 PM


All times are GMT -5. The time now is 02:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration