LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-05-2005, 01:19 PM   #1
Vodius
LQ Newbie
 
Registered: Mar 2005
Posts: 27

Rep: Reputation: 15
Permission troubles.


Ok, serius problem here (I guess). I managed to succesfully mount my Windows partition but now I can access it unless I am on root in the console O_o. It says itś locked. I looked and looked (and probably overlooked) and cannot find anything on how to ¨unlock¨ it. Thanks in Advanced.
 
Old 03-05-2005, 01:27 PM   #2
Brain Drop
Member
 
Registered: Feb 2003
Location: just outside reality
Distribution: balanced
Posts: 752

Rep: Reputation: 35
Try this as root:
Code:
chmod 666 /mnt/windowspartition
with whatever your real mount point is called.

This will allow any user to read, and write to the windows partition.

For more info type man chmod
 
Old 03-05-2005, 01:32 PM   #3
Vodius
LQ Newbie
 
Registered: Mar 2005
Posts: 27

Original Poster
Rep: Reputation: 15
Oh... Well that didn´t work itś still ¨locked¨ but... should I h ave mounted it to /mnt/(whatever) because I mounted it to ¨/windows¨ THanks in advanced.
 
Old 03-05-2005, 02:20 PM   #4
Vodius
LQ Newbie
 
Registered: Mar 2005
Posts: 27

Original Poster
Rep: Reputation: 15
update : I tried setting the acess to it to let others do everything O_O... with ¨chmod +o+r+w+x /mnt /windows (remounted as well)¨ and it still says I do not have enough permissions to access this location. I am thinking its like a system file thing? Thanks in Advanced
 
Old 03-05-2005, 03:17 PM   #5
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
hi there,

first of all you have to set the permissions of the mount point when there's nothing mounted.
so...

#umount /windows
#chmod 770 /windows

then put a line like this in /etc/fstab :

/dev/hd?? /windows vfat defaults,users,umask=002 1 0

for vfat , or :

/dev/hd?? /windows ntfs ro,user,umask=022 1 0

for ntfs.
( fill in the ??.... )
if you have that :

#mount /windows

and that's it.

egag
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 04:50 AM
troubles with SATA, troubles with NVIDIA aevangelica Linux - Hardware 6 10-17-2005 02:39 AM
g++ troubles GlassEyeSlim Linux - Newbie 6 02-15-2005 10:51 AM
Some troubles harken Debian 25 01-30-2005 01:36 AM
Troubles tryinglinux Linux - Newbie 6 05-06-2003 10:19 AM


All times are GMT -5. The time now is 06:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration