LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-05-2008, 03:46 PM   #1
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Rep: Reputation: 0
"Permission denied" when trying to copy files into mounted windows with all rights


Again a problem.

Since I can't boot linux at all now and my computer looks to fuck up completely shortly I'm trying to copy the files from linux onto windows using the rescue system.

I mounted windows, have given it all rights (chmod 777), which it also displayes.
Still I can't create any folders, copy and files into there etc.

I'm really clueless atm, seems to me like I'm missing some small stupid thing.

Help would be very appreciated.
 
Old 05-05-2008, 03:51 PM   #2
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
Which filesystem is your Windows partition formatted as: FAT or NTFS?
 
Old 05-05-2008, 03:55 PM   #3
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by indienick View Post
Which filesystem is your Windows partition formatted as: FAT or NTFS?
It's NTFS.
 
Old 05-05-2008, 04:12 PM   #4
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
Make sure you have the ntfs-3g kernel module loaded. Which distribution are you running?
 
Old 05-05-2008, 04:19 PM   #5
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by indienick View Post
Make sure you have the ntfs-3g kernel module loaded. Which distribution are you running?
Oh yes, I forgot to mention - am running SuSE 10.

How do I check if I have ntfs-3g loaded?
When I'm trying to mount windows using
"mount -t ntfs-3g /dev/hdc1 /mnt/windows"
it tells me
"mount: unknown filesystem type 'ntfs-3g'"

Maybe I'm doing something wrong with the syntax but I rechecked like 100 times.

So I mounted windows just using

"mount /dev/hdc1 /mnt/windows"
 
Old 05-05-2008, 04:23 PM   #6
SlowCoder
Member
 
Registered: Oct 2004
Location: Southeast, U.S.A.
Distribution: Fedora (Desktop), CentOS (Server), Knoppix (Diags)
Posts: 934

Rep: Reputation: 38
We need to know a few particulars:
- How are you mounting to Windows? Through CIFS/Samba (network), or from a local drive?
- What do you mean by "rescue system"? Are you using a LiveCD like Knoppix?
 
Old 05-05-2008, 04:25 PM   #7
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
To see if the module is loaded, in a terminal, type:
Code:
$ lsmod | grep ntfs
If it returns nothing, then the module isn't loaded. Assuming you have an Internet connection (and you know how to use OpenSuSE's package manager), try installing the ntfs-3g package.
 
Old 05-05-2008, 04:27 PM   #8
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by SlowCoder View Post
We need to know a few particulars:
- How are you mounting to Windows? Through CIFS/Samba (network), or from a local drive?
- What do you mean by "rescue system"? Are you using a LiveCD like Knoppix?
-I'm mounting it from a local drive - just from a diffrent partition.
-Yes I'm using a live-CD; this feature: http://www.novell.com/documentation/...l/ch12s05.html
 
Old 05-05-2008, 04:30 PM   #9
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by indienick View Post
To see if the module is loaded, in a terminal, type:
Code:
$ lsmod | grep ntfs
If it returns nothing, then the module isn't loaded. Assuming you have an Internet connection (and you know how to use OpenSuSE's package manager), try installing the ntfs-3g package.
It returns:
"ntfs 182288 1"

Again to clarify a thing: I can only access linux using the rescue system, can't boot it anymore. So I don't have an internet connection etc.
 
Old 05-05-2008, 06:58 PM   #10
davedave1
LQ Newbie
 
Registered: Jun 2007
Location: Canberra
Distribution: Gentoo, Ubuntu 7, Ubuntu 5
Posts: 17

Rep: Reputation: 0
For the sort of operation you are doing I agree that you use Knoppix - it just makes everything easier.

However if you don't have access to a knoppix download then...
If the windows partition is listed in etc/fstab make sure that it is mounted as user,rw in the options column. If it isn't there don't worry, you seem to be able to mount it anyway.

Seeing as you are command line only at this point try running the copy command(s) with root privileges either with sudo [command] or log on as root for the purpose.

Should work.
 
Old 05-06-2008, 12:05 PM   #11
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Yep I only have the commandline to work with.

I'll copy what i see if I type "mount": (the relevant part)

/dev/hdd4 on /mnt/linux type reiserfs (rw)
/dev/hdc5 on /mnt/windows type ntfs (rw)

It tells both are read/write, I also am root by default if I use the rescue system, so there shouldnt have been problems with that anyway I believe.

I don't seem to get it fixed, maybe anyone has another idea how I could get those files from my harddrive? (I thought I might somehow copy them to a CD but failed badly so far)

Thanks for all the help so far.
 
Old 05-06-2008, 12:43 PM   #12
indienick
Senior Member
 
Registered: Dec 2005
Location: London, ON, Canada
Distribution: Arch, Ubuntu, Slackware, OpenBSD, FreeBSD
Posts: 1,853

Rep: Reputation: 65
If possible, buy an external drive chassis (they cost about $30 CAD), and just do it all from there.

What's your current situation with computers? How many do you have, how many hard drives do you have....etc.
 
Old 05-06-2008, 03:38 PM   #13
twist3r
LQ Newbie
 
Registered: Apr 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Red face

Thanks, I followed you suggestion and after it didnt recognize my external harddrive and 2 usb-sticks it finally decided to accept the crappiest on with 1GB storage place.

My next problem now is: I have one folder with loads of small files, about 1000 of them, each 1-10mb big. A cut command would help but I couldnt find one on google (seems like cutting in linux is something completely diffrent then in windows)

If anyone could give me a hint here I believe I'd finally be ready with this D!:

edit: it is "move" thanks for helping

twist3r

Last edited by twist3r; 05-06-2008 at 04:41 PM.
 
Old 05-06-2008, 06:21 PM   #14
vadkutya
Member
 
Registered: Apr 2008
Distribution: slackware 10.2
Posts: 117

Rep: Reputation: 16
i don't know what you mean with cutting. for copying do:

# cp -rf /mnt/windows /<YourUSBStick>

i don't know what device your usb stick is. probably /dev/sda1. if the usb is mounted automatically then look in /etc/fstab and you will see where it is mounted. then replace <YourUSBStick> with it. if it is /dev/sda1 the command should then look like this:

# cp -rf /mnt/windows /dev/sda1

your usb stick should also be mounted read-write of course.

good luck, vadkutya
 
Old 05-06-2008, 06:30 PM   #15
viron
Member
 
Registered: Dec 2005
Location: McKinney, Texas
Distribution: Slackware
Posts: 40

Rep: Reputation: 15
Alright...to write to an NTFS filesystem in Linux you need to do the following:

1) make sure FUSE is either compiled into the kernel, or built/loaded as a module

2) install the ntfs-3g utils.

3) mount -t ntfs-3g /dev/windrive /mnt/win

replace windrive with the actual dev. simple =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 05:50 AM
"Permission Denied" while accessing ntfs partition in user mode funkymunky Linux - General 3 01-31-2009 09:03 PM
Need ACCESS to change files! Every time I try to change a setting,"Permission Denied" Balarabay1 Suse/Novell 2 03-06-2006 10:54 AM
Keep getting "Permission Denied" when trying to write files dunnd40 Debian 2 02-01-2004 11:29 AM
Can't access mounted NFS directory: "permission denied" SparceMatrix Linux - General 6 03-08-2003 02:36 PM


All times are GMT -5. The time now is 06:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration