LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-10-2008, 03:07 PM   #1
mconstant
LQ Newbie
 
Registered: May 2005
Location: Boulder, CO
Distribution: Fedora
Posts: 12

Rep: Reputation: 0
permission denied when running compiled app. I'm using root!


Hi, I compiled linuxsampler for PureDyne, and it gave me no errors. I have fulfilled all its dependencies, and when I try to run it, it says, "permission denied: llinuxsampler".

I've noticed that all the files I built are owned by the group "mail". I can't change their groups using chgrp, because everything is on a vfat partition. Does it matter that the group is "mail" for all the built files? Is that why I'm having my problem? Can't root open up files owned by the mail group? If not, is there any workaround for changing groups on a fat partition? Maybe there's a way to copy all the files and change there group at the same time...

Thanks!

Last edited by mconstant; 04-10-2008 at 03:08 PM. Reason: disabled smilies
 
Old 04-10-2008, 04:14 PM   #2
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 70
Quote:
Originally Posted by mconstant View Post
everything is on a vfat partition
Is the partition mounted as noexec?
 
Old 04-10-2008, 04:18 PM   #3
mconstant
LQ Newbie
 
Registered: May 2005
Location: Boulder, CO
Distribution: Fedora
Posts: 12

Original Poster
Rep: Reputation: 0
No, it isn't.
 
Old 04-10-2008, 04:41 PM   #4
rjmx
LQ Newbie
 
Registered: Oct 2007
Location: Brockton, Massachusetts
Distribution: Debian
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by mconstant View Post
Hi, I compiled linuxsampler for PureDyne, and it gave me no errors. I have fulfilled all its dependencies, and when I try to run it, it says, "permission denied: llinuxsampler".
Not wishing to state the obvious, but the executable does have the execute bit(s) set, doesn't it? (try 'chmod 755 linuxsampler').
 
Old 04-10-2008, 04:45 PM   #5
mconstant
LQ Newbie
 
Registered: May 2005
Location: Boulder, CO
Distribution: Fedora
Posts: 12

Original Poster
Rep: Reputation: 0
Yeah, I chmod 777'd it. I'm pretty convinced now that it has to do with the group. I'm copying it over to a USB thumb drive with EXT3 as the filesystem. I noticed that when I do so it changes the group for me! Unfortunately, this process is going very slowly, since the laptop I'm using only has USB 1.0
 
Old 04-10-2008, 05:54 PM   #6
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 70
Quote:
Originally Posted by mconstant View Post
No, it isn't.
Are you sure? Sometimes noexec is enabled by other options (such as user). To be sure, try forcing the exec option (as root)
Code:
mount -t vfat -o remount,exec /dev/device /mountpoint
As for actual ownership of files, root should be able to read and/or write any such files regardless of owner (as long as they have appropriate modes).
 
Old 04-10-2008, 06:01 PM   #7
mconstant
LQ Newbie
 
Registered: May 2005
Location: Boulder, CO
Distribution: Fedora
Posts: 12

Original Poster
Rep: Reputation: 0
I somehow doubt it is a noexec problem. It is mounted just like all the other modules on the system.

on typing mount:
"/mnt/hd1/2/dyne/modules/sampler.dyne on /opt/sampler type squashfs (ro,loop=/dev/loop10)"
 
Old 04-10-2008, 06:10 PM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,034

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
You may have trouble if you use a windows filesystem to store data for a linux application, if that application is concerned with the users and groups who own, or are allowed to access, the files. The reason is that win filesystems have no knowledge of the concepts of "Owner" "Group" "Other".

The (linux) mail program is likely to be concerned about this as mail is generally considered to be "private" data. If it is unsure that you have permissions to read the data, it will not allow you to do it. Hence, perhaps, "Permission Denied".

Quote:
If not, is there any workaround for changing groups on a fat partition?
Maybe. If you chown / chgrp (maybe with the -R option) the mountpoint of your filesystem, while the filesystem is mounted, it might be happy. You'll need to make this change to owner / group as the root user.

I don't have this problem as I now have only linux at home. I just need to ensure that whenever I create a new account on a new PC that the new distro/PC has the same UID numbers associated with usernames as all the others. Failing to ensure this led to several reinstalls until I understood the concept. Now, it's almost intuitive, and I can appreciate that it is a sensible policy.

Let us know how you get on with the ext3 filesystem.
These things are sent to annoy us, but with permissions, there's always a "workaround", so persevere
 
Old 04-11-2008, 11:33 AM   #9
mconstant
LQ Newbie
 
Registered: May 2005
Location: Boulder, CO
Distribution: Fedora
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the reply and inspiration.

I'm not quite sure that I understand, though. If I recursively change the owner or group from the root mount point (/ ?) wouldn't I be changing the permissions on all files in my system in one fell swoop? To me this sounds like a bad idea.

I'm beginning to think this is only one stumbling block before I can get this module working (I'm also having linking problems with .so files).

If I actually finished, it would be nice to get away from the computer, but for me, a lot of the fun is hacking around and learning. Linux is very flexible, and I'm increasingly surprised by how the usability and quality of Open Source and FLOSS software is improving!
 
Old 04-11-2008, 01:36 PM   #10
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,034

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
To me this sounds like a bad idea
I would indeed be a very bad idea. What I meant was chown the mountpoint of your mounted vfat partition, or chgrp the mountpoint of your mounted vfat partition. NOT your root filesystem!
I should have made that clearer, sorry.
 
Old 04-11-2008, 06:05 PM   #11
osor
HCL Maintainer
 
Registered: Jan 2006
Distribution: (H)LFS, Gentoo
Posts: 2,450

Rep: Reputation: 70
Quote:
Originally Posted by mconstant View Post
I'm also having linking problems with .so files
This could also be the source of a “Permission denied” error. Is the executable in your native format (e.g., if you are on x86 is it an x86 ELF)? Is the dynamic linker/loader (ld.so) correctly set up? Are all the shared object files mentioned in the dynamic section of the executable (find these with “ldd linuxsampler”) readable by ld.so, and also in the same ELF format (check each one with the file command)?
 
Old 04-11-2008, 06:17 PM   #12
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 59
Quote:
(I'm also having linking problems with .so files)
What I usually do is type the name of that .so file in it's entirety into the search field of RPM Search Advanced and select the OS type. Then yum install what package the search engine matches up against your query.
Usually solves that issue, not sure about linking to compiled apps though.

Last edited by Junior Hacker; 04-11-2008 at 06:19 PM.
 
Old 04-12-2008, 06:34 PM   #13
mconstant
LQ Newbie
 
Registered: May 2005
Location: Boulder, CO
Distribution: Fedora
Posts: 12

Original Poster
Rep: Reputation: 0
Cool problems solved

All of the problems were caused by permissions on a vfat filesystem. I repartitioned and used ext2. Now everything works fine, including the symbolic links. Yaaay!
 
Old 04-13-2008, 06:20 AM   #14
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,034

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Quote:
I repartitioned and used ext2. Now everything works fine, including the symbolic links. Yaaay!
Excellent
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL4: Permission denied as root when running trying to write to /usr/sbin willmatthews Red Hat 1 10-26-2007 03:31 AM
permission denied for root!!?? a1ora0 Slackware - Installation 1 09-29-2007 04:50 AM
Permission denied as root Cadmium Mandriva 6 10-07-2005 01:00 PM
Permission denied as root Cynric Linux - General 4 08-15-2004 12:47 PM
Permission denied as Root! Thewyzewun Linux - Newbie 3 03-13-2004 12:51 PM


All times are GMT -5. The time now is 01:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration