LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Closed Thread
  Search this Thread
Old 05-05-2012, 02:12 AM   #1
mr.cracker
Member
 
Registered: May 2012
Posts: 58

Rep: Reputation: Disabled
permission denied


when i use some code in terminal,the result is permission denied like below,,

bash: ./offsetbruteforce.sh: Permission denied

why this cause?

how can i overcome or avoid this.
 
Old 05-05-2012, 02:24 AM   #2
S. Chapelin
Member
 
Registered: Jan 2010
Location: Quebec
Posts: 137

Rep: Reputation: 5
Depending on your os, maybe you need to use:
sudo ./offsetbruteforce.sh
(password)
 
Old 05-05-2012, 02:31 AM   #3
fukawi1
Member
 
Registered: Apr 2009
Location: Melbourne
Distribution: Fedora & CentOS
Posts: 854

Rep: Reputation: 190Reputation: 190
To put it simply. If you do not know what the problem is, you shouldn't be doing anything with brute forcing.
 
Old 05-05-2012, 03:57 AM   #4
yars
Member
 
Registered: Apr 2012
Location: Russia
Distribution: Slackware64-current
Posts: 241

Rep: Reputation: 24
A script must be have the permissoins is "rwx-rwx-r", and you must be a owner. It's so obvious.
 
Old 05-05-2012, 04:12 AM   #5
vahid_01
LQ Newbie
 
Registered: May 2012
Location: iran
Posts: 3

Rep: Reputation: Disabled
if you creat this file you can run by " bash offsetbruteforce.sh" or you can change the permission by "chmod" command by root account.
for example "chmod 777 filename".
 
1 members found this post helpful.
Old 05-05-2012, 07:49 AM   #6
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,396
Blog Entries: 7

Rep: Reputation: 166Reputation: 166
Quote:
Originally Posted by vahid_01 View Post
if you creat this file you can run by " bash offsetbruteforce.sh" or you can change the permission by "chmod" command by root account.
for example "chmod 777 filename".
This is not a good practice. You should not go about recommending people change permissions to 777. Noobs who don't understand permissions yet are likely to blindly follow that advice and will then be thrilled when it works, but it is not a good solution. a better permission is probably 72-
 
1 members found this post helpful.
Old 05-05-2012, 11:55 AM   #7
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
If you want to allow all users on the system to run the script, 755 is probably the best choice, otherwise why not just make it 700 so it's only readable by the owner?
 
Old 05-05-2012, 12:00 PM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,133
Blog Entries: 2

Rep: Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836Reputation: 4836
Quote:
Originally Posted by Knightron View Post
This is not a good practice. You should not go about recommending people change permissions to 777. Noobs who don't understand permissions yet are likely to blindly follow that advice and will then be thrilled when it works, but it is not a good solution. a better permission is probably 72-
There are no better or worse permissions. There are only permissions that are suitable for the intended use. For example, the only suitable permission for the /root-directory is 700, and the only suitable permission for programs in /usr/bin is 755.
Nonetheless, I agree with you that giving a solution without proper explanation is not the best way to answer to a thread.
 
Old 05-05-2012, 12:19 PM   #9
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Distribution: AntiX.
Posts: 1,826

Rep: Reputation: Disabled
Possibly you just need to run :-

chmod +x offsetbruteforce.sh

to make it executable, & then run it :-

sh offsetbruteforce.sh
 
Old 05-05-2012, 04:40 PM   #10
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
And with all that said: I can't see a legitimate reason
to RUN that script. Closed.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 04:50 AM
'permission denied" inspite of right permission flags on network drive anirudhvij Linux - Enterprise 8 05-22-2007 05:57 AM
su: permission denied Tumunzahar Linux - General 3 02-01-2005 02:04 PM
su : permission denied sai49 Linux - General 14 07-13-2004 05:00 AM
ls/cp ... : permission denied Roadrunner Linux - Newbie 5 09-09-2003 06:00 AM


All times are GMT -5. The time now is 08:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration