LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-17-2004, 05:35 PM   #1
DB03
Member
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 48

Rep: Reputation: 15
Permission Denied


I'm sorry if this is a stupid question but it's bothering me:

I just downloaded apache web server

i extracted it using tar just fine, put it into a folder called apache_1.3.27

i go into terminal, go into that folder using cd

then i do a "su" then i put my password in (and get the #)

then i try to run INSTALL by typing "./INSTALL"

bash: ./INSTALL: Permission denied

how do i become the supreme leader of all folders?

thanks

PS this also happens with any other files in there like this:

bash: ./LICENSE: Permission denied
bash: ./README: Permission denied

etc.
 
Old 04-17-2004, 05:42 PM   #2
|2ainman
Member
 
Registered: Mar 2004
Distribution: Slackware current, DSL 0.9.2
Posts: 133

Rep: Reputation: 15
permission denied does not mean that the user permissions are wrong necessarily, but it may mean instead that the file permissions are wrong.
Also .. i dont think you can run a readme from just ./README.
The ./ prefix is to execute an executable in the current working directory b/c the directory you are in is not included in the path
If you wanted to look at a README you would type:
Code:
cat README | more
For your ./install or whatever .. which i dont even know if thats the right thing .. (it sounds like another readme which details the install process)
You need to run
./configure
make
make install

That will configure, compile, and install apache.
Make sure that your configure script is executable .. it should already be
ls -l configure
rwx------
or
rwxr-x---
something like that
if the first three arent rwx then do chmod +x configure
P.S. If your unfamiliar with the install process, you should read up on these forums first before installing anything, or posting.
 
Old 04-17-2004, 06:30 PM   #3
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
INSTALL is a text file, not a program. It contains the installation instructions for the program you want to install. To read it either use the method suggested above, or open it in a text editor such as pico or vi:
Code:
vim INSTALL
 
Old 04-17-2004, 10:51 PM   #4
DB03
Member
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 48

Original Poster
Rep: Reputation: 15
ok thanks i got it installed and running and now i'm (trying) to delete some files in the htdocs folder (the default "If you're seeing this, the webmaster hasn't copied any content to it" blah blah blah message) but i get an error that i don't have proper permissions to acess the parent folder. I went to the parent folder of the "parent folder" and right clicked for properities. It say's i'm not the owner so i can't change the permissions. How do i change the permissions so i can edit the stuff?

thanks
 
Old 04-18-2004, 01:29 PM   #5
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Quote:
Originally posted by DB03
ok thanks i got it installed and running and now i'm (trying) to delete some files in the htdocs folder (the default "If you're seeing this, the webmaster hasn't copied any content to it" blah blah blah message) but i get an error that i don't have proper permissions to acess the parent folder. I went to the parent folder of the "parent folder" and right clicked for properities. It say's i'm not the owner so i can't change the permissions. How do i change the permissions so i can edit the stuff?

thanks
Be root to make the permission changes.
Open a console window (kterm, gnome-terminal, xterm etc) and type su
then enter the root password.
Change to the parent directory of the htdocs folder (cd <directory> changes directory cd .. goes back a directory) and then type:
Code:
chmod -R a+w htdocs
That will alter htdocs and all the files in it so that you have write permission (and can therefore delete them).
 
Old 04-18-2004, 01:38 PM   #6
DB03
Member
 
Registered: Mar 2004
Distribution: Fedora Core 1
Posts: 48

Original Poster
Rep: Reputation: 15
thanks
 
Old 04-18-2004, 01:45 PM   #7
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,487

Rep: Reputation: 88
Hi

You cannot run INSTALL - it is a text file, not a script (I think).

To setup apache, go to its directory, do ./configure

make

make install

to set it up.

BTW if you want all powerful access to a directory, log in as superuser and do

chmod a=rwx /dirname

Cheers
 
Old 04-18-2004, 02:07 PM   #8
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Quote:
Originally posted by rylan76
Hi

You cannot run INSTALL - it is a text file, not a script (I think).

To setup apache, go to its directory, do ./configure

make

make install

to set it up.

BTW if you want all powerful access to a directory, log in as superuser and do

chmod a=rwx /dirname

Cheers
If you bothered to read the thread you'd see that we've already given this answer.

number 3 on my list of forum hates: people who reply without reading the thread.
 
Old 04-19-2004, 06:20 AM   #9
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 47
The a in chmod -R a+w stands for all. So you are setting your entire htdocs directory to world write.

If you only want to give user write access use:
chmod -R +w
or
chmod -R u+w

To give user and group write access you would use:
chmod -R ug+w

A better approach would be to add yourself to the apache group. You could do this by editing the file /etc/group.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
can't execute c++ binaries, "permission denied"... even though permission is 777 SerfurJ Programming 14 02-20-2009 05:50 AM
Permission Denied jamesvenning1 Linux - Newbie 4 06-05-2005 12:32 PM
Permission denied jagman026 Fedora 3 01-01-2005 04:45 PM
Permission Denied ptreves Linux - Newbie 7 12-16-2004 03:14 PM
Permission denied? jbhoo Linux From Scratch 1 04-27-2002 10:12 PM


All times are GMT -5. The time now is 04:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration