LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-17-2004, 01:18 PM   #1
redhatbeatswin
LQ Newbie
 
Registered: Jul 2004
Posts: 15

Rep: Reputation: 0
PERL not working - CGI?


Hello,

Apache is working fine right now, and I have a test PHP site up.

I want to run a PERL script, however when i use the POST method in an html file, all that is returned is the formmail.pl script in TEXT form on the next page.

I've tried chmod 755 formmail.pl ; not the answer

I dont have a cgi-bin folder either-- Whats up with that?

I've tried installing CPAN using perl -eshell -CPAN

then Bundle::CPAN

it looks like it installed ok.

I'm lost and dont know whats up.

Thanks!

Mike
 
Old 07-17-2004, 01:22 PM   #2
redhatbeatswin
LQ Newbie
 
Registered: Jul 2004
Posts: 15

Original Poster
Rep: Reputation: 0
by the way im on rh 9

by the way im on rh 9
 
Old 07-17-2004, 01:41 PM   #3
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Create a cgi-bin (are you sure it's not parallel to the current directory? i.e. another sub directory of the parent directory?) and drop the file in there.
 
Old 07-17-2004, 05:17 PM   #4
redhatbeatswin
LQ Newbie
 
Registered: Jul 2004
Posts: 15

Original Poster
Rep: Reputation: 0
fixed

turns out my httpd.conf file was pointing to a different directory.

i created a cgi-bin folder and pointed the conf file there.

thanks!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Perl CGI:Can't locate CGI.pm supermyself Programming 13 09-10-2007 06:22 AM
installing cgi perl to get lynx working hypnotiks Linux - Newbie 1 12-19-2004 02:06 PM
perl cgi neil Programming 3 07-07-2004 04:52 AM
cgi perl : I cant get perl to append my html file... the_y_man Programming 3 03-22-2004 05:07 AM
cgi+perl barbanero General 0 04-07-2002 12:48 PM


All times are GMT -5. The time now is 04:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration