LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-23-2003, 09:42 AM   #1
mghere
LQ Newbie
 
Registered: Oct 2003
Posts: 11

Rep: Reputation: 0
performer+inventor files on linux


hi
I am not a Performer or Inventor developer, and don't know a better place to post this question as I don't know Linux very well...

That is, this is a linux question only perhaps, as on an irix system i don't have the same problems using the same applications and models.

On IRIX I can get an inventor (.iv) 2.1 model (made in SGI Cosmo Worlds) to show up in SGI Performer, but using the linux system, tho i believe i have installed rh and Performer well, I get a segmentation fault. when i try to see the .iv file in perfly.

The system includes rh7.3 and Performer 2.5.2-5 rpms (all the dependencies listed for Performer were included in rh7..3) -- perfly seems to work well, except when viewing these .ivs (which, as mentioned, can be seen in an IRIX install of Performer 2.5.x...)

I don't remember what can typically cause a segmentation fault -- can it be some library is missing?

Thanks for any info...

 
Old 12-23-2003, 10:32 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,994
Blog Entries: 54

Rep: Reputation: 2745Reputation: 2745Reputation: 2745Reputation: 2745Reputation: 2745Reputation: 2745Reputation: 2745Reputation: 2745Reputation: 2745Reputation: 2745Reputation: 2745
I am not a Performer or Inventor developer
Me neither :-]

Without specific error messages and more details I think troubleshooting is very hard. Did you check out the SGI's Linux Performer FAQ?: http://www.sgi.com/software/performer/linux-faq.html IMHO the stuff there should make a good start troubleshooting this from the ground up, starting at verifying installed rpm contents are OK, then check library versions and locations, then work towards the GL/GLX/X11 related/driver stuff. If you tested and verified ALL parts are in working order, then I would suggest you should strace perfly and post the output here (or email to SGI). That might help us help you.
 
Old 12-23-2003, 09:51 PM   #3
mghere
LQ Newbie
 
Registered: Oct 2003
Posts: 11

Original Poster
Rep: Reputation: 0
performer + inventor files on linux

Thanks for your reply

I did the check of libs and Performer rpms when i installed them a while back...
hmmm. could try again but,

per the strace you mentioned
-- unfortunately it will take me a bit to figure out how to extend the number of lines a xterm window will scroll in order to get all the output -- in meantime, what i did get is too long to post here, yes...don't know how to get it to you or sgi (I hope i am not being too negative about the chances at sgi, but it is not a developer question, and have had no luck contacting info@performer.sgi list in the past -- hardworking, interested people, but have to draw line somewhere i guess :] ).

am gonna try to cull the backside polygons of the .iv files before exporting from Cosmo World, I did forget to try that option -- had done that in past -- maybe need to do that before the more tempermental (?) linux Performer will work????

Thanks for the encouragement
(mebbe will post again after trying the culling, if it doesn't work -- and mebbe some part of the strace could be culled and pasted here?)

 
Old 12-27-2003, 06:57 PM   #4
mghere
LQ Newbie
 
Registered: Oct 2003
Posts: 11

Original Poster
Rep: Reputation: 0
performer+inventor on linux

Hi again

I tried posting to the info-performer list and attaching the strace perfly results as suggested. I actually got a response email and a copy of my posting this time (yay!), and emails from other post-ers, but when i looked at the performer list i saw all the postings listed but mine. Dun know for sure just what that means...

anyway, haven't been able to make a .iv model from the sgi product Cosmo World that will work in perfly yet so am really stuck. The strace of perfly is too long to post, but if anyone can tell anything from the little bit of performer output, it is included befow

thanks

[@localhost yg]$ perfly data/testDir/counter5.iv
PF ================================================
PF = OpenGL Performer 2.5.2 =
PF = DEMO EDITION =
PF ================================================
PF = For information about purchasing the full =
PF = OpenGL Performer product, visit =
PF = http://www.sgi.com/software/performer/ =
PF ================================================
PF Info(22): All 2 processors available on this machine.
PF Info: DRAW process(20156) forked
PF Info: ----------- Performer Process State --------
PF Proc: APP pid:20155
PF Proc: ISECT pid:20155
PF Proc: DBASE pid:20155
PF Proc: CLOCK pid:0
PF Proc: COMPUTE pid:20155
PF Proc: SYNC pid:0
PF Pipe Proc: CULL Pipes:1
PF Proc: CULL Pipe:0 pid:0
PF Pipe Proc: DRAW Pipes:1
PF Proc: DRAW Pipe:0 pid:20156
PF Pipe Proc: LPOINT Pipes:1
PF Proc: LPOINT Pipe:0 pid:0
PF -------------------------------------------
PF Notice: pfdLoadFile_iv: data/testDir/counter5.iv
PF Status:
PF Initializing OpenInventor
PF Opening file "data/testDir/counter5.iv"
PF Loading file into OpenInventor
Segmentation fault
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Something like Digital Performer? microsoft/linux Linux - Software 3 09-12-2005 09:56 PM
.sit files and .bin files in Linux pierre24 Linux - Newbie 2 02-02-2005 07:55 AM
c header files in linux in place of header files in windows? harun_acs Programming 1 03-17-2004 02:24 AM
how to share linux files on LAN btwn other linux boxes shakeeb Linux - Networking 9 02-04-2004 02:10 PM
win2k sees linux files... linux won't see win2k files.. please help.. what will i do? kublador Linux - Networking 1 03-24-2003 07:31 AM


All times are GMT -5. The time now is 09:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration