LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-12-2002, 12:05 AM   #1
makai_wi
Member
 
Registered: Nov 2002
Location: Thiensville, WI, USA
Distribution: RedHat Linux 9
Posts: 85

Rep: Reputation: 15
Unhappy PATH problem?


Okay, I get this when trying to compile xine-ui-0.9.13... I just did an install of xine-lib-0.9.13 that worked with out a hitch...

checking for XINE-LIB version >= 0.9.10... no
*** Could not run XINE test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding XINE or finding the wrong
*** version of XINE. If it is not finding XINE, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
***
configure: error: *** You should install xine-lib first ***

----

Now I also get this when trying to install LimeWire... I installed j2re1.4.1_01 via the rpm install file and it went fine with out any errors as well...


Configuring the installer for this system's environment...
No Java virtual machine could be found from your PATH
environment variable. You must install a VM prior to
running this program.

----

So, what's the deal here? Am I missing something, do I have to register all of this manually after compiling or something? I am running RedHat 8.0, let me know if you need to know any more.
 
Old 11-12-2002, 12:14 AM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
you must run ldconfig


it will rebuild the library cache file


occasionally a program will put libs in some non standard location and then you will be required to add the path to /etc/ld.so.conf and then run ldconfig

running ldconfig will correct the problem as long as your /etc/ld.so.conf has the path to the libs you installed

one common location that you should add to ld.so.conf is /usr/local/lib

It's pretty common to see it missing

also this assumes you have a folder there
 
Old 11-12-2002, 12:37 AM   #3
makai_wi
Member
 
Registered: Nov 2002
Location: Thiensville, WI, USA
Distribution: RedHat Linux 9
Posts: 85

Original Poster
Rep: Reputation: 15
Exclamation bash: ldconfig: command not found

I can't run ldconfig, bash tells me command not found. Although I can do a 'man ldconfig'.
 
Old 11-12-2002, 12:46 AM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
you must be root in roots environment for it to be in your path, and for you to have permission to use it
 
Old 11-12-2002, 12:47 AM   #5
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
su

/sbin/ldconfig

or

su -

ldconfig
 
Old 11-12-2002, 12:48 AM   #6
makai_wi
Member
 
Registered: Nov 2002
Location: Thiensville, WI, USA
Distribution: RedHat Linux 9
Posts: 85

Original Poster
Rep: Reputation: 15
I logged in via su on my console... do I have to be in a specific directory or something?
 
Old 11-12-2002, 01:02 AM   #7
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
did you login as root or just su to root

su
or
su root

makes you root but your environment never changes so your path is not the same as roots path

su -
or
su - root

changes you to root and also moves you into roots environment

it is good to use

su -


if you are root run this

echo $PATH


make sure you have /sbin in your path
 
Old 11-12-2002, 01:06 AM   #8
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
[david@Firedragon david]$ whoami
david
[david@Firedragon david]$ echo $PATH
/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/david/bin
[david@Firedragon david]$ su
Password:
[root@Firedragon david]# whoami
root
[root@Firedragon david]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/home/david/bin
[root@Firedragon david]# su -
[root@Firedragon root]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin:/usr/bin/X11:/usr/X11R6/bin:/root/bin
[root@Firedragon root]#
 
Old 11-12-2002, 01:24 AM   #9
makai_wi
Member
 
Registered: Nov 2002
Location: Thiensville, WI, USA
Distribution: RedHat Linux 9
Posts: 85

Original Poster
Rep: Reputation: 15
ldconfig now works, thank you! What did all of that do?

Last edited by makai_wi; 11-12-2002 at 01:30 AM.
 
Old 11-12-2002, 01:35 AM   #10
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Your welcome




if you mean ldconfig

it reads /etc/ld.so.conf
it writes /etc/ld.so.cache

if you mean my last post

it got you to login as root



Last edited by DavidPhillips; 11-12-2002 at 01:36 AM.
 
Old 11-12-2002, 02:09 AM   #11
makai_wi
Member
 
Registered: Nov 2002
Location: Thiensville, WI, USA
Distribution: RedHat Linux 9
Posts: 85

Original Poster
Rep: Reputation: 15
ugg

Okay, now it's giving me the same error but this time for AALIB... I have no idea where this got put in the xine-lib install... Any ideas on where I can find a list of where all of the files got put? Or is it any bodies guess?

checking for AALIB version >= 1.2... no
*** The aalib-config|aainfo program installed by AALIB could not be found
*** If AALIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or use --with-aalib-prefix to set the prefix
*** where AALIB is installed.
checking for pkg-config... /usr/bin/pkg-config
checking for DirectFB... *** All of DIRECTFB dependent parts will be disabled ***
checking for png_read_info in -lpng... no
configure: error: *** libpng is needed (PNG library not found) - try to use --with-png-prefix option ***
 
Old 11-12-2002, 07:54 AM   #12
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 56
well there is more than aalib (it allows you to see graphics on console, it is pretty cool, but if you ain't need it you ain't need to install it. You must have libpng installed, I can see your future - you are browsing http://www.rpmfind.net to get the libs.
 
Old 11-12-2002, 10:56 AM   #13
makai_wi
Member
 
Registered: Nov 2002
Location: Thiensville, WI, USA
Distribution: RedHat Linux 9
Posts: 85

Original Poster
Rep: Reputation: 15
I installed png via RPM with no luck, I did an ldconfig just to be sure and still I am getting that same error. Did it install the library on to a non-standard path or something?
 
Old 11-12-2002, 10:59 AM   #14
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
if you need to find something use

locate something

to updated locates database use

updatedb
 
Old 11-12-2002, 11:02 AM   #15
makai_wi
Member
 
Registered: Nov 2002
Location: Thiensville, WI, USA
Distribution: RedHat Linux 9
Posts: 85

Original Poster
Rep: Reputation: 15
I tried updatedb and it didn't work, I seem to now have two versions of pnglib, and they are not in the $PATH directories... Going to try and fix that, I will get back to you... What did updatedb do?

Last edited by makai_wi; 11-12-2002 at 11:07 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
qt path problem wmeler Linux - Software 0 05-13-2004 10:20 PM
How to Chnage Python's module search path (sys.path)? lramos85 Linux - Software 1 05-02-2004 06:10 PM
$PATH problem (probably) dave bean Slackware 9 02-17-2004 06:43 PM
PATH problem jhansman Linux - Newbie 18 08-24-2003 01:15 AM
$PATH problem charlie123 Linux - Newbie 3 01-15-2003 04:50 PM


All times are GMT -5. The time now is 03:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration