LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-11-2005, 12:02 PM   #1
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Rep: Reputation: 15
Patching KDE ?!? :O


Hello everyone

I Have just downloaded post-3.4.2-kdebase-kcheckpass.diff

And i want to apply it to my KDE 3.4.2 [i haven't got the source of KDE 3.4.2 ONLY the binary install package - the tgz-s ]

How you suggest to apply the patch? By downloading the src of 3.4.2/ i don't see another solution

***BUT i have downloaded the packages FOR Slackware 10.1

Last edited by MTT1k; 09-11-2005 at 12:03 PM.
 
Old 09-11-2005, 12:47 PM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
In order to patch the source, you'll need the source.
 
Old 09-11-2005, 05:06 PM   #3
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Original Poster
Rep: Reputation: 15
BUT :)

But these packages are compiled especially for slackware. Could something go wrong if i patch it and then compile it ?
 
Old 09-11-2005, 05:11 PM   #4
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
I suppose it's possible, but unlikely. The worst case is having two copies of the same thing installed in two different places. Why do you need that patch? If it fixes a bug, is there no official package that fixes it as well?
 
Old 09-11-2005, 06:26 PM   #5
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Original Poster
Rep: Reputation: 15
Talking yeah :)

You are right Thank you very much

Although which version of KDE do you suggest and which QT?

I've downloaded the src of qt-x11-free-3.3.5.tar.gz


Thans
 
Old 09-11-2005, 07:04 PM   #6
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
I honestly don't use KDE, but I'd just go with the latest stable version.
 
Old 09-11-2005, 07:31 PM   #7
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Original Poster
Rep: Reputation: 15
:)

ok i wil install it
 
Old 09-12-2005, 02:16 PM   #8
mgmax
Member
 
Registered: Jul 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 16
But I think you'll have to uninstall your slackware KDE package and install a dummy one (that the dependencies are fullfilled). Dont know exactly, but thats the way it works on debian.

mgmax
 
Old 09-13-2005, 12:00 AM   #9
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 52
Can't you download the source of the slackware KDE package and patch that instead?
 
Old 09-13-2005, 06:24 AM   #10
mgmax
Member
 
Registered: Jul 2005
Distribution: Debian
Posts: 82

Rep: Reputation: 16
why dont you use a up-to-date slackware package??? I dont know about slackware but in Debian there are so-called unstable versions which are REALLY new.

mgmax
 
Old 09-13-2005, 03:27 PM   #11
MTT1k
Member
 
Registered: Jul 2005
Location: Bulgaria [Sofia city], bukston city[neighbourhood]
Distribution: Linux Slackware 10.2 [k 2.6.12.6]
Posts: 41

Original Poster
Rep: Reputation: 15
Talking :)

Of course, here is almost the same I'll just update them Thnx for the great ideas
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Patching 2.6 Biotachyonic Linux - Laptop and Netbook 2 08-24-2005 10:04 PM
Trouble Patching Kwin Dropshadow on KDE 3.3.1 bbslackuser Linux - Software 5 12-14-2004 08:32 AM
Patching Straterra Slackware 18 03-17-2004 12:58 PM
browser freezes post kde patching yocompia Slackware 0 07-31-2003 11:49 AM
patching janu Linux - Software 1 01-06-2003 05:17 PM


All times are GMT -5. The time now is 06:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration