LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-20-2004, 08:36 PM   #1
behmjose
Member
 
Registered: Dec 2003
Posts: 55

Rep: Reputation: 15
pango-1.0.5 can't find libX11.so.6, but it is on my system


hi

I have been trying to install pango so i can install gtk+, but i have a problem. Pango complains during the build that libX11.so.6 doesn't exist, but it does, and i ran a find to locate it, and the result was /usr/X11R6/libX11.so.6, which i thought was standard. do i have to give a argument to configure? i am perplexed please give me some help.

thanks,
behmjose
 
Old 02-21-2004, 03:17 PM   #2
behmjose
Member
 
Registered: Dec 2003
Posts: 55

Original Poster
Rep: Reputation: 15
hi

well i tried
./configure --x-libraries=/usr/X11R6/lib
make
everything is alright no errors all good
make install
Bam error same one i figure this must be a bug in the program or something of that nature, anyone heard of any patches? maybe some other fix pango is making me agry errr.

thanks,
behmjose
 
Old 02-21-2004, 10:13 PM   #3
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Did you try adding the /etc/X11R6/lib to your /etc/ld.so.conf file, then running ldconfig to update your shared links lib's in order for it to look in that location when installling?
 
Old 02-21-2004, 10:15 PM   #4
trickykid
Guru
 
Registered: Jan 2001
Posts: 24,133

Rep: Reputation: 197Reputation: 197
Moved: Not LFS specific so being moved. Regards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error in the creation of `etc/pango/pango.modules` okeyla Linux - Newbie 3 07-02-2011 08:06 PM
Pango wants Xft - Can't find it rjcarlson49 Linux - Software 6 04-24-2007 03:03 PM
I *just installed* glib but pango can't find it Avatar Linux - Software 5 09-14-2005 01:07 PM
Compiled en installed new Glib but Pango won't find it Haiyadragon Linux - Newbie 1 04-03-2004 08:08 AM
Cannot start X window system since installing Pango jdruin Red Hat 0 12-03-2003 02:22 PM


All times are GMT -5. The time now is 01:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration