LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-02-2013, 05:51 AM   #1
AN28
Member
 
Registered: Apr 2013
Posts: 93

Rep: Reputation: 0
Package requirement configuration error


Hi,

So I have got stuck with a really really weird error and don't know what to do!

I have successfully installed Enlightenment 17 on to my system and want to install Entrance the Enlightenment Display Manager.

But, when trying to so I come across the error attached herewith.

I HAVE installed Eina-1.7.8 and still get the error!

What can I do to overcome this?

Please Help!

Attached Thumbnails
Click image for larger version

Name:	entrance_err.png
Views:	20
Size:	112.6 KB
ID:	13330  
 
Old 09-02-2013, 10:21 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
Your package manager doesn't seem to think you have installed version 1.7.8 of Eina. You can try reinstalling Eina 1.7.8 and see if that solves the problem.
jdk
 
Old 09-02-2013, 11:50 PM   #3
AN28
Member
 
Registered: Apr 2013
Posts: 93

Original Poster
Rep: Reputation: 0
well im using LFS and don't have a package manager but I did try re installing eina 3 times over but still did not have any luck :/

Last edited by AN28; 09-02-2013 at 11:51 PM.
 
Old 09-03-2013, 01:35 AM   #4
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
@AN28: Looking at the attachment I see that eina 1.7.7 is found. Have you installed that version at any point? If so I would recommend removing it.

I just had a look at the eina 1.7.8 source and the eina.pc file is present and correct. Try finding out where the eina.pc file is located after installing version 1.7.8. Maybe it is in a location that is not looked at by the enlightenment config step.

pkgconfig looks in specific places (have a look at the PKG_CONFIG_PATH variable) to find xyz.pc files. Do make sure that the correct eina.pc file can be found.
 
1 members found this post helpful.
Old 09-03-2013, 02:02 AM   #5
AN28
Member
 
Registered: Apr 2013
Posts: 93

Original Poster
Rep: Reputation: 0
Yup I did sometime back and then once the versions were updated I had to install 1.7.8 as a dependency for another package.

Is there a mechanism to remove all related files to eina 1.7.7 or do I have to go to each possible folder where files were created and then delete??

Sorry to ask such noobish questions but how can I view the PKG_CONFIG_PATH variable?? Isn't that part of a package manager?
 
Old 09-03-2013, 06:34 AM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Quote:
Originally Posted by AN28 View Post
Is there a mechanism to remove all related files to eina 1.7.7 or do I have to go to each possible folder where files were created and then delete??
Did you install this from source? You might have used a PREFIX=???? Have a look there first, otherwise look at the README/INSTALL file to see what the defaults are.

Quote:
Sorry to ask such noobish questions but how can I view the PKG_CONFIG_PATH variable?? Isn't that part of a package manager?
Code:
echo $PKG_CONFIG_PATH
Also have a look at the installed bash files (see BLFS chapter 4). If I remember correctly there is a script that sets PATHs (which includes pkg_config.
 
Old 09-04-2013, 05:39 AM   #7
AN28
Member
 
Registered: Apr 2013
Posts: 93

Original Poster
Rep: Reputation: 0
Thank You I managed to install it... but then I am not too sure how to enable it..

The README files for the package states that I could enable grub2 reboot feature by making changes to a file in /etc/defaults/grub or admin can make a script to open session in /etc/X11/xinit/xinitrc.

I tried adding
Quote:
systemctl enable entrance
in .xinitrc but that resulted in the system not booting up at all.

What exactly should I do?
 
Old 09-04-2013, 06:26 AM   #8
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Quote:
Originally Posted by AN28 View Post
Thank You I managed to install it... but then I am not too sure how to enable it..

The README files for the package states that I could enable grub2 reboot feature by making changes to a file in /etc/defaults/grub or admin can make a script to open session in /etc/X11/xinit/xinitrc.

I tried adding in .xinitrc but that resulted in the system not booting up at all.

What exactly should I do?
Can you be more specific about "it". I'm assuming this isn't about the original eina problem any more.

Is this about starting Enlightenment? If so, have you looked at this: Starting Enlightenment
 
Old 09-04-2013, 06:45 AM   #9
AN28
Member
 
Registered: Apr 2013
Posts: 93

Original Poster
Rep: Reputation: 0
Eina problem is sorted now. I managed to install Entrance.
And I am having trouble enabling Entrance as the display manager
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] configuration error: Can't find Tcl configuration definition schattkab Linux - Software 3 01-28-2015 12:22 PM
Yum Error: Transaction Check Error package x(which is newer than package y)... godsk Linux - Newbie 0 06-05-2006 08:13 AM
Binutils 2.14 -> Requirement for mplayer -> CC error Laptop2250 Linux - Software 2 11-21-2003 08:14 PM
Configuration error while running atk-1.2.0 package suriyamohan Linux - General 0 04-16-2003 01:49 AM
1 minute login error requirement STREETTEC Linux - Security 1 03-20-2003 11:47 AM


All times are GMT -5. The time now is 10:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration