LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-13-2013, 11:52 PM   #1
Manusia muslim
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Rep: Reputation: Disabled
Package conflicts while trying to upgrade it.


Hi All,

Im a newbie here, im trying to upgrade the GLIBC package to glibc-2.5-42 from glibc-2.3.4-2.41, but im having some error while updating it. all the step done will be prompted "conflict".

is there any Guru here to help me out?

#rpm -qa glibc
glibc-2.3.4-2.41
glibc-2.3.4-2.41


# rpm -ivh --replacepkgs glibc-common-2.5-42.i386.rpm
warning: glibc-common-2.5-42.i386.rpm: V3 DSA signature: NOKEY, key ID 1d1e034b
error: Failed dependencies:
glibc < 2.5 conflicts with glibc-common-2.5-42.i386

# rpm -ivh --replacefiles glibc-common-2.5-42.i386.rpm
warning: glibc-common-2.5-42.i386.rpm: V3 DSA signature: NOKEY, key ID 1d1e034b
error: Failed dependencies:
glibc < 2.5 conflicts with glibc-common-2.5-42.i386

# rpm -Uvh glibc-common-2.5-42.i386.rpm
warning: glibc-common-2.5-42.i386.rpm: V3 DSA signature: NOKEY, key ID 1d1e034b
error: Failed dependencies:
glibc < 2.5 conflicts with glibc-common-2.5-42.i386

# rpm -Uvh --replacepkgs glibc-common-2.5-42.i386.rpm
warning: glibc-common-2.5-42.i386.rpm: V3 DSA signature: NOKEY, key ID 1d1e034b
error: Failed dependencies:
glibc < 2.5 conflicts with glibc-common-2.5-42.i386

# rpm -Uvh --replacefiles glibc-common-2.5-42.i386.rpm
warning: glibc-common-2.5-42.i386.rpm: V3 DSA signature: NOKEY, key ID 1d1e034b
error: Failed dependencies:
glibc < 2.5 conflicts with glibc-common-2.5-42.i386
 
Old 03-14-2013, 02:50 AM   #2
Manusia muslim
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
can help me to solve this problem?
have anyone facing the same issue?
 
Old 03-14-2013, 05:04 AM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,819

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
first glibc is basically most of the operating system
if you change it you will need to rebuild about 99% of the operating system before it will start to run ever again

second
without knowing what operating system this is -- we can not help
from the use of " rpm"
it is likely in the redhat family or suse family

for red hat based OS's you use yum
for the suse group of OS's you use zypper

and you use what IS IN THE update repo

for RHEL 5,6 ,and fedora
Code:
su -
yum update
will install the latest that distro version

for suse
Code:
zypper update
will install the latest for this distro version

but if you are intent on killing your operating system to the point it will never run ever again
Warning:
!!! do not do this !!!
rpm --force -i glibc-common-2.5-42.i386.rpm

Last edited by John VV; 03-14-2013 at 05:08 AM.
 
2 members found this post helpful.
Old 03-14-2013, 08:11 AM   #4
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Linux Mint, Ubuntu
Posts: 1,504

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Use
Code:
rpm -Uvh <package name>
Using
Code:
rpm -ivh <package name>
where <package name> already exists will try to install the new version along side the old version. It works for the kernel, and possibly a few other packages. I've never attempted it with glibc; looks lioke it won't work.
 
Old 03-14-2013, 11:20 PM   #5
Manusia muslim
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Dear John VV & Rock Doctor,

Thanks for reply my question,
Sorry i never mention what type of Linux i run.

Below are the details :
x86_64 x86_64 x86_64 GNU/Linux
redhat-release
Enterprise Linux Enterprise Linux AS release 4

We still experiencing the problem & still trying to solve it.

Yesterday, we tried to update all the package together and get the different error.

Below are the step:

rpm -Uvh glibc-common-2.5-42.i386.rpm glibc-common-2.5-42.x86_64.rpm glibc-2.5-42.x86_64.rpm glibc-2.5-42.i386.rpm glibc-headers-2.5-42.x86_64.rpm glibc-headers-2.5-42.i386.rpm glibc-devel-2.5-42.i386.rpm glibc-devel-2.5-42.x86_64.rpm


And the error is :

error: Failed dependencies:
binutils < 2.15.94.0.2-1 conflicts with glibc-devel-2.5-42.i386
binutils < 2.15.94.0.2-1 conflicts with glibc-devel-2.5-42.x86_64


its pointed to the binutils package.

Kindly need your advice again.


By the way, we dont have the repo thing as we still new in Linux.
We just download manually the required filesets and try to install it using rpm.

Last edited by Manusia muslim; 03-14-2013 at 11:27 PM.
 
Old 03-14-2013, 11:29 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,819

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
RHEL4.9 ( guessing it is the last in the 4 series )
4.0,4.1,-- to 4.9

is mostly unsupported
unless you are paying red hat for the EXTRA extended life support
RHEL4 also used "up2date" , but "yum" was added later sometime around rhel4.5

to install programs on rhel4 you DO have to pay red hat for that extra life support

If you do have a current support contract for the extra support

you might want to contact red hat support , you are paying for it
and paying a lot

see:
Code:
su -
up2date --help 
---- and the man page ---
man up2date

Last edited by John VV; 03-14-2013 at 11:30 PM.
 
Old 03-14-2013, 11:35 PM   #7
Manusia muslim
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
so do you mean release 4 is not supporting glibc-2.5-42?
 
Old 03-14-2013, 11:54 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,819

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
the centos4.9 64 bit "vault" has
http://vault.centos.org/4.9/updates/x86_64/RPMS/
glibc-2.3.4-2.57.x86_64.rpm


you can migrate to Centos 4.9
but it is unsupported

http://vault.centos.org/4.9/

if "yum" is installed on this old rhel4 install
the update repo should point here
http://vault.centos.org/4.9/updates/x86_64/
but what is there is the last update


the migration guide is only for rhel5 and 6 to centos 5 and 6
http://wiki.centos.org/HowTos/Migrat...=%28migrate%29

but a old centos4 forum post
http://www.centos.org/modules/newbb/...?topic_id=3310

you can also port this 2009 blog post ( rhel 4.7)
http://idolinux.blogspot.com/2009/07...-centos-4.html

but your BEST bet is buy the red hat extra support license for the server
http://www.redhat.com/products/enterprise-linux/server/
https://www.redhat.com/wapps/store/catalog.html
 
Old 03-15-2013, 12:13 AM   #9
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.8, Centos 5.10
Posts: 17,240

Rep: Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324Reputation: 2324
You really need an up to date supported release; see https://access.redhat.com/support/po...pdates/errata/.
V4 is effectively dead unless you pay extra for extended support, whoch won't last much longer.
If you want (ie NEED) to use up to date tool sets, go with RHEL (or Centos) v6.4.

Be aware that you cannot update across major versions in-place; it'll require a fresh install.
https://access.redhat.com/knowledge/...ted_Notes.html
 
Old 03-15-2013, 02:30 AM   #10
Manusia muslim
LQ Newbie
 
Registered: Mar 2013
Posts: 5

Original Poster
Rep: Reputation: Disabled
Thanks John VV & Chris,

Really appreciate that, we will working to upgrade first.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Advice on package conflicts? auryx Linux - Newbie 1 10-29-2005 05:17 PM
apt-rpm, SuSE 8.2 upgrade, and package conflicts bigrigdriver Linux - Software 2 05-28-2005 04:23 PM
Package Conflicts RodimusProblem Linux - Newbie 3 01-10-2005 09:11 PM
Package Conflicts with KDE JohnRChick Linux - Software 1 08-24-2004 03:10 AM
Cdrecord Package Conflicts harley51 Fedora 2 06-19-2004 12:58 PM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration