LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-01-2016, 09:09 AM   #1
TuxYAB
LQ Newbie
 
Registered: Apr 2016
Posts: 2

Rep: Reputation: Disabled
Lightbulb Ouverture IMAP avec MUTT


Bonjour,

en lançant MUTT, je reçois une invitation à créer un compte imaps://imap.laposte.net:993

MUTT m'indique ensuite le premier de 3 certificats SSL en chaîne ( de Symantec......à Laposte)

Si j'accepte, le "CERTIFICAT NE PEUT ÊTRE SAUVE" et la connexion échoue!!.

"Zimbra serveur terminating".....dans le texte.

Merci pour les suggestions (francophones en particulier :O>)
 
Old 05-01-2016, 11:07 AM   #2
Michael Uplawski
Member
 
Registered: Dec 2015
Location: Normandy, France
Distribution: Debian stretch/sid
Posts: 398
Blog Entries: 14

Rep: Reputation: 241Reputation: 241Reputation: 241
English version of my response below.

Quote:
Originally Posted by TuxYAB View Post
Bonjour,
en lançant MUTT, je reçois une invitation à créer un compte imaps://imap.laposte.net:993
MUTT m'indique ensuite le premier de 3 certificats SSL en chaîne ( de Symantec......à Laposte)
Si j'accepte, le "CERTIFICAT NE PEUT ÊTRE SAUVE" et la connexion échoue!!.
Bonjour.

Si tu a un compte à laposte.net, est-ce que tu l'as configuré dans /home/[utilisateur]/.muttrc ?
Je demande, parce que ce type d'erreur « ... ne peut être sauvé » etc. normalement indique un problème avec les droits d'écriture et/ou d'ouverture de répertoires. Je vais étudier un peu ce que mutt devrait faire avec les certificats. Moi-même, j'utilise mutt avec pop3s et ssl/tls et ne connais pas ce phénomène.

Vérifie d'abord si, dans ta configuration, quelque chose demande d'utilser des dossiers où tu n'as pas le droit d'écrire. Je reviens...

Edit: J'ai trouvé une discussion du sujet sur superuser.com.
Principalement, il y a trois pistes à suivre, dont deux alternativement:
1.) Crée un dossier /home/[utilisateur]/.mutt. Ignore le reste, si ça suffit pour solutioner le problème.
2.) Vérifie, que le serveur que tu as configuré est le même qui est indiqué dans le certificat SSL. Si non, change ta configuration.
3.) Alternativement, désactive la vérification des certificats moyennant un “Account-Hook”, c'est à dire, pour ce serveur précisement, insiste sur la valeur 'no' pour ces deux variables set ssl_verify_host et set ssl_verify_dates.

J'espère que ça t'aide.

P.S.: Tu peux demander ce type de question aussi sur Framagora (Framasoft). J'ignore s'il y a beaucoup de personnes qui utilisent Mutt, mais ça vaut certainement la peine de l'essayer... Moi non plus, je ne suis à priori pas francophone .

---------- English Version Of My Response --------
Howdy.

If you have an account with laposte.net, did you configure it in /home/[user]/.muttrc?
I am asking, because this kind of error “ ... cannot be saved” etc. normally indicates a problem with your rights to write to and/or open directories. I will myself look around a little for information on how mutt should handle the certificates. Myself, I use mutt with pop3s and SSL/TLS and do not encounter the same phenomenon.

First verify if, in your configuration, something demands to use directories where you do not have the right to write. I'll be back ...

Edit: I have found a discussion of your subject on superuser.com.
In principal, there are three options, two are to be considered alternatives:
1.) Create a directory /home/[utser]/.mutt. Ignore the remainder of this message if that is enough to solve your problem.
2.) Verify that the server that you have configured is the same as indicated in the SSL-certificate. If not, adapt your configuration.
3.) Alternatively, deactivate the verification of certificats by means of an “Account-Hook”, i.e. for this one server specifically insist on a value “no” for the two variables set ssl_verify_host and set ssl_verify_dates.

I hope, this helps.

P.S.: You can ask this kind of question also in Framagora (Framasoft). I do not know if there are many people using mutt, but it cannot hurt to try. Me neither, I am not really francophone...




Last edited by Michael Uplawski; 05-03-2016 at 10:46 AM. Reason: solutions from superuser.com
 
1 members found this post helpful.
Old 05-03-2016, 03:36 AM   #3
TuxYAB
LQ Newbie
 
Registered: Apr 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
Bonjour et merci pour l'effort francophone.

J'ai crée les dossiers ~/mail/.....qui vont bien et revu l'écriture de mon ./muttrc parasité par des " " et des erreurs de newbie (.....pour manifester mon anglophilie ;o>)

MUTT est lançé et je vais peaufiner ses réglages.

N'y a-t-il pas de risques à désactiver la vérification des certificats (Host? dates? )

Je vais voir si je peux traduire "Account hook " en français...et surtout en informatique.

Thank's again.
 
Old 05-03-2016, 08:14 AM   #4
Michael Uplawski
Member
 
Registered: Dec 2015
Location: Normandy, France
Distribution: Debian stretch/sid
Posts: 398
Blog Entries: 14

Rep: Reputation: 241Reputation: 241Reputation: 241
English version of my response below.

Quote:
Originally Posted by TuxYAB View Post
N'y a-t-il pas de risques à désactiver la vérification des certificats (Host? dates? )
La difficulté est ici, que personne ne le sait.
En fait, la désactivation des certificats ou de leur vérification pour « résoudre » des problèmes avec ces certificats est toujours le dernier recours. Et si quelqu'un a le nerf de appeler « solution », c'est certainement la plus conne qui existe. Mais, de l'autre côté, le “account hook” (« crochet d'un compte ») va assurer que l'exception sera fait que pour un seul service mail (laposte.net), et si tu en utilises d'autres, ils ne seront pas concernés et leurs certificats vont continuer d'être vérifiés chaque fois.

------------- English version of my response ----------
The difficulty here is that nobody knows.
Actually, deactivating certificates or their verification in order to “solve” problems with the certificates is always the last resort. And if someone has the nerve to call this a “solution”, it is certainly the dumbest one that exists. But on the other hand, the “account hook” will ensure that the exception will be made only for a single mail-service (laposte.net) and if you use others, too, they will not be concerned and their certificates will still be verified each time.

Last edited by Michael Uplawski; 05-07-2016 at 04:46 AM. Reason: better.
 
Old 05-03-2016, 09:02 AM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,916

Rep: Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689
Please, both of you read the LQ Rules. ALL content here needs to be in English. Please edit your posts and translate them into English, so that folks can benefit from the questions/answers.
 
Old 05-03-2016, 10:32 AM   #6
Michael Uplawski
Member
 
Registered: Dec 2015
Location: Normandy, France
Distribution: Debian stretch/sid
Posts: 398
Blog Entries: 14

Rep: Reputation: 241Reputation: 241Reputation: 241
Quote:
Originally Posted by TB0ne View Post
Please, both of you read the LQ Rules. ALL content here needs to be in English. Please edit your posts and translate them into English, so that folks can benefit from the questions/answers.
I try that and will edit my posts, above.
Be informed though, that I have referred the OP to a specific french-speaking forum for his kind of problem. I imagine that the reputation of LQ has lured him into posting here, in the first place. But all can be rectified.
 
Old 05-08-2016, 03:06 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,568

Rep: Reputation: 164Reputation: 164
Dear TuxYAB,
LinuxQuestion is English speaking forum. Please use English for all posts. Thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mutt and IMAP $folder_format dive Linux - Software 0 02-05-2013 12:44 PM
[SOLVED] Mutt does not change the "unread" flag on the IMAP server and other Mutt questions TobiSGD Linux - Software 1 10-09-2012 09:44 AM
Mutt, IMAP and auto'refresh' markraves Linux - Desktop 1 10-25-2010 05:56 PM
Mutt: Only one of the two IMAP accounts opening. saivin Linux - Newbie 0 05-22-2009 12:50 PM
How to use mutt and imap accounts donbellioni Linux - Software 1 08-09-2004 01:55 PM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration