LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-13-2008, 08:24 PM   #76
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122

Have a look in the conf subdirectory on the unpacked postfix tarball - there should be a clean version there. If no, I can email you one.
 
Old 11-13-2008, 08:28 PM   #77
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
Thanks buddy. I found it in my unpacked directory.
 
Old 11-13-2008, 08:31 PM   #78
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
Should I add all the entries in my old master.cf ?

or

Is there only some specific entries that should be updated ?
 
Old 11-13-2008, 08:41 PM   #79
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
Ok buddies . . . . .

Now here comes the current condition.

I copied the new, fresh master.conf from the unpacked directory. Without any modifications in that, I am trying to send mail. The error has not changed . . . .

From Outlook:
Quote:
The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'bimal@MYDOMAIN.com'. Subject 'test', Account: 'mail.MYDOMAIN.com', Server: 'mail.MYDOMAIN.com', Protocol: SMTP, Server Response: '554 5.5.2 <user>: Helo command rejected: need fully-qualified hostname', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79
 
Old 11-13-2008, 08:42 PM   #80
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Did you read the rest of my previous post on this (#74) and follow the link I gave you?
 
Old 11-13-2008, 09:07 PM   #81
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 61
Configure your Windows systems that are using Outlook / Outlook Express clients to use fully qualified host names. Right click My Computer, select Properties, and then select the Computer Name tab. Click the Change button, and then the More button. Add your domain name as the Primary DNS suffix (of this computer). Restart Windows and your mail will be accepted by Postfix.

Alternatively, you can bypass the reject_non_fqdn_helo_hostname restriction on your own networks if you want, by placing the restriction after permit_my_networks or permit_sasl_authenticated.
 
Old 11-13-2008, 09:11 PM   #82
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
billymayday: I read the document, but not yet completed. I ll update you more of what I understood by reading it . . . .

Something I got from that :

Quote:
telnet mail.mydomain.com 25
220 ******2*******************************
ehlo mail.mydomain.com
502 5.5.2 Error: Command not recognized

Last edited by bittus; 11-13-2008 at 09:13 PM.
 
Old 11-13-2008, 09:14 PM   #83
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Quote:
Originally Posted by Mr. C. View Post
Configure your Windows systems that are using Outlook / Outlook Express clients to use fully qualified host names. Right click My Computer, select Properties, and then select the Computer Name tab. Click the Change button, and then the More button. Add your domain name as the Primary DNS suffix (of this computer). Restart Windows and your mail will be accepted by Postfix.

Alternatively, you can bypass the reject_non_fqdn_helo_hostname restriction on your own networks if you want, by placing the restriction after permit_my_networks or permit_sasl_authenticated.
Long time no see. Welcome back
 
Old 11-13-2008, 09:22 PM   #84
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
Meanwhile let me try Mr.C's suggestion.
 
Old 11-13-2008, 09:33 PM   #85
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Quote:
Originally Posted by bittus View Post
Meanwhile let me try Mr.C's suggestion.
Yes, I would.
 
Old 11-13-2008, 09:35 PM   #86
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
but still i dont understand y the server dint accecpt the "ehlo" command on telnet
 
Old 11-13-2008, 10:00 PM   #87
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 61
Quote:
Originally Posted by billymayday View Post
Long time no see. Welcome back
Thanks! Been fairly swamped of late...

Quote:
Originally Posted by bittus
but still i dont understand y the server dint accecpt the "ehlo" command on telnet
Code:
smtpd_helo_restrictions = permit_mynetworks, reject_invalid_hostname, reject_non_fqdn_hostname

$ man 5 postconf
...
       reject_non_fqdn_helo_hostname      (with      Postfix      <       2.3:
       reject_non_fqdn_hostname)
              Reject the request when the HELO or  EHLO  hostname  is  not  in
              fully-qualified domain form, as required by the RFC.
              The  non_fqdn_reject_code  parameter specifies the response code
              to rejected requests (default: 504).
 
Old 11-19-2008, 07:02 AM   #88
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
hi buddies, I am back.

Sorry that I could not update you the status of my experiments.

In fact, I was stuck up in another problem as you can see in my thread : http://www.linuxquestions.org/questi...d.php?t=684284

I tried changing the primary DNS name of windows. But still it didn't go thru. It was giving me the same message.

Now I removed the entries "reject_non_fqdn_recipient, reject_non_fqdn_sender" from
smtpd_recipient_restrictions.

Now it reads :
smtpd_recipient_restrictions = reject_unlisted_recipient, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_rbl_client zen.spamhaus.org=127.0.0.10, reject_rbl_client zen.spamhaus.org=127.0.0.1, reject_rbl_client zen.spamhaus.org


I tried sending a mail from an outside network and ended up in a different message :

554 5.7.1 Service unavailable; Client host [aaa.bbb.cc.ddd] blocked using zen.spamhaus.org; http://www.spamhaus.org/query/bl?ip=aaa.bbb.cc.ddd

 
Old 11-19-2008, 07:14 AM   #89
billymayday
LQ Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Why do you have

reject_rbl_client zen.spamhaus.org=127.0.0.10

?

You have "reject_rbl_client zen.spamhaus.org" 3 times, and I don't get the "= 127.0.0.1" on two of them
 
Old 11-19-2008, 08:45 AM   #90
bittus
Member
 
Registered: Aug 2006
Posts: 153

Original Poster
Rep: Reputation: 15
Sorry, That was a copy error. (I copied it from the backup copy of main.cf)

My actual entries are :

smtpd_recipient_restrictions = reject_unlisted_recipient, permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination, reject_unknown_sender_domain, reject_unknown_recipient_domain, reject_rbl_client zen.spamhaus.org.


But why do I get the error "blocked by spamhaus", even when the permit_sasl_authenticated comes before reject_rbl_client
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Trap all outgoing mail of all user of my mail server singh_chitranjan Linux - Server 1 07-09-2008 07:15 AM
Outgoing Only mail server using Postfix opnsrc Linux - Networking 0 06-15-2006 11:37 AM
Server-wide outgoing mail filter mccomber Linux - Networking 1 11-02-2005 09:04 PM
Timeout response from RH/SM mail server from mail client Mordanthanus Linux - Networking 0 05-09-2005 12:16 PM
Can i copy outgoing mail on the server? Dman33 Linux - Software 1 07-09-2004 12:45 PM


All times are GMT -5. The time now is 08:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration