LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 02-27-2008, 06:45 AM   #1
time_trapper
LQ Newbie
 
Registered: Feb 2008
Posts: 15

Rep: Reputation: 0
Question Outbound e-mails not getting off server


I have a dedicated server running Linux with Plesk. We're able to get incoming mail just fine, but any outbound e-mail that originates from the server will not make it off the server (either via Horde webmail or from with Plesk itself sending e-mails to an off-server e-mail account). I'm really at a loss for what to check. Can someone point me in the right direction?

I should say that if I use Horde webmail to send a test message to an email address on that domain/server, then it will arrive, but with a "softdnserror" in the message details.


The last file that I edited on the server was a config file so that I could bring FTP access back online.

Here's the contents of my "etc/hosts/" file, in case this helps:
Code:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               freshinstall localhost.localdomain localhost
66.235.xxx.xxx          gxxxxxa.com


Thanks,

- Adam
 
Old 02-27-2008, 07:55 AM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
66.235.xxx.xxx gxxxxxa.com

Shouldn't this entry have a host name ?

Code:
66.235.xxx.xxx          hordemail.gxxxxxa.com   hordemail

man hosts
Code:
EXAMPLE
        127.0.0.1       localhost
        192.168.1.10    foo.mydomain.org  foo
        192.168.1.13    bar.mydomain.org  bar
        146.82.138.7    master.debian.org      master
        209.237.226.90  www.opensource.org
 
Old 02-27-2008, 04:14 PM   #3
time_trapper
LQ Newbie
 
Registered: Feb 2008
Posts: 15

Original Poster
Rep: Reputation: 0
I've added the following entries to my "/etc/hosts" file, but they don't seem to have done anything to help my outbound e-mail problem.

Code:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               freshinstall localhost.localdomain localhost
66.xxx.xxx.211          gxxxxxa.com
66.xxx.xxx.211          mail.gxxxxxa.com mail
66.xxx.xxx.211          webmail.gxxxxxa.com webmail
66.xxx.xxx.211          forum.gxxxxxa.com forum
Note: If I turn the "gxxxxxa.com" entry into "www.gxxxxxa.com", then my FTP will stop working.


This is not just a problem getting e-mail to send from Horde, but outbound server e-mail in general. I can't even get my Plesk generated server reports to arrive off-server. Any suggestions?

- Adam

Last edited by time_trapper; 02-27-2008 at 04:15 PM. Reason: minor
 
Old 02-27-2008, 04:54 PM   #4
time_trapper
LQ Newbie
 
Registered: Feb 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Not sure if this helps, but here is what my "maillog" says when I try to send an outbound e-mail to an address off the server.

Code:
Feb 26 19:45:26 gxxxxxa qmail-queue: dwlib[1467]: mail: all addreses are uncheckable - need to skip scanning (by deny mode)
Feb 26 19:45:26 gxxxxxa qmail-queue: dwlib[1467]: scan: the message(drweb.tmp.P4NmK4) sent by adam@gxxxxxa.com to adamxxxxxx@bxxxxx.net should be passed without checks, because contains uncheckable addresses
Feb 26 19:45:26 gxxxxxa qmail: 1204073126.019978 new msg 6177421
Feb 26 19:45:26 gxxxxxa qmail: 1204073126.020075 info msg 6177421: bytes 707 from <adam@gxxxxxa.com> qp 1468 uid 2020
Feb 26 19:45:26 gxxxxxa qmail: 1204073126.038500 starting delivery 13399: msg 6177421 to remote adamxxxxxx@bxxxxx.net
Feb 26 19:45:26 gxxxxxa qmail: 1204073126.038585 status: local 0/10 remote 4/20
Feb 26 19:45:26 gxxxxxa imapd: 1204073126.79359 LOGOUT, user=adam, ip=[127.0.0.1], headers=0, body=0, rcvd=622, sent=637, maildir=/var/qmail/mailnames/gxxxxxa.com/adam/Maildir
Feb 26 19:45:26 gxxxxxa imapd: Connection, ip=[127.0.0.1]
Feb 26 19:45:26 gxxxxxa imapd: LOGIN, user=adam, ip=[127.0.0.1], protocol=IMAP
Feb 26 19:45:26 gxxxxxa imapd: 1204073126.405427 LOGOUT, user=adam, ip=[127.0.0.1], headers=0, body=0, rcvd=86, sent=330, maildir=/var/qmail/mailnames/gxxxxxa.com/adam/Maildir

Here is the results from a server "nslookup":

Code:
[root@gxxxxxa root]# nslookup
> server gxxxxxa.com
Default server: gxxxxxa.com
Address: 66.2xx.xxx.211#53
> set type=mx
> gxxxxxa.com
Server:         gxxxxxa.com
Address:        66.2xx.xxx.211#53

gxxxxxa.com     mail exchanger = 10 mail.gxxxxxa.com.
> exit


And, if it helps, here is the header information form a test message that was sent from adam@gxxxxxa.com to adam@gxxxxxa.com (i.e. same server-side address) via Horde. Note the "softdnserror".

Code:
Return-Path: <adam@gxxxxxa.com>
Delivered-To: 1-adam@gxxxxxa.com
Received: (qmail 13984 invoked from network); 27 Feb 2008 17:49:45 -0500
Received: from softdnserror (HELO localhost) (127.0.0.1)
  by softdnserror with SMTP; 27 Feb 2008 17:49:45 -0500
Received: from 72.xxx.xx.84 ([72.xxx.xx.84]) by webmail.gxxxxxa.com (Horde
	MIME library) with HTTP for <adam@gxxxxxa.com>; Wed, 27 Feb 2008 17:49:05
	-0500
Message-ID: <20080227174905.rr1gxvg3cbkgkwko@webmail.gxxxxxa.com>
Date: Wed, 27 Feb 2008 17:49:05 -0500
From: adam@gxxxxxa.com
To: adam@gxxxxxa.com
Subject: test
MIME-Version: 1.0
Content-Type: text/plain;
	charset=ISO-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: 7bit
User-Agent: Internet Messaging Program (IMP) H3 (4.0.3)

Last edited by time_trapper; 02-27-2008 at 04:56 PM.
 
Old 02-27-2008, 10:32 PM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
What happens when you try and query DNS for a different (destination) email server ? is it resolving properly ? If your server can't resolve DNS it certainly won't be able to send messages..

Code:
default@debianetch:~$ dig MX gmail.com

; <<>> DiG 9.3.4 <<>> MX gmail.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 37413
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 4, ADDITIONAL: 10

;; QUESTION SECTION:
;gmail.com.                     IN      MX

;; ANSWER SECTION:
gmail.com.              1591    IN      MX      5 gmail-smtp-in.l.google.com.
gmail.com.              1591    IN      MX      10 alt1.gmail-smtp-in.l.google.com.
gmail.com.              1591    IN      MX      10 alt2.gmail-smtp-in.l.google.com.
gmail.com.              1591    IN      MX      50 gsmtp163.google.com.
gmail.com.              1591    IN      MX      50 gsmtp183.google.com.

;; AUTHORITY SECTION:
gmail.com.              300119  IN      NS      ns1.google.com.
gmail.com.              300119  IN      NS      ns2.google.com.
gmail.com.              300119  IN      NS      ns3.google.com.
gmail.com.              300119  IN      NS      ns4.google.com.

;; ADDITIONAL SECTION:
alt2.gmail-smtp-in.l.google.com. 277 IN A       72.14.221.114
alt2.gmail-smtp-in.l.google.com. 277 IN A       72.14.221.27
gsmtp163.google.com.    1820    IN      A       64.233.163.27
gsmtp183.google.com.    7192    IN      A       64.233.183.27
gmail-smtp-in.l.google.com. 22  IN      A       64.233.171.27
alt1.gmail-smtp-in.l.google.com. 56 IN  A       72.14.205.27
ns1.google.com.         136582  IN      A       216.239.32.10
ns2.google.com.         308056  IN      A       216.239.34.10
ns3.google.com.         132594  IN      A       216.239.36.10
ns4.google.com.         129785  IN      A       216.239.38.10

;; Query time: 67 msec
;; SERVER: 192.168.2.1#53(192.168.2.1)
;; WHEN: Wed Feb 27 23:29:54 2008
;; MSG SIZE  rcvd: 390
 
Old 02-27-2008, 11:38 PM   #6
time_trapper
LQ Newbie
 
Registered: Feb 2008
Posts: 15

Original Poster
Rep: Reputation: 0
I did a "dig" command like you suggested, but I didn't get any results:

Code:
[root@gomanga root]# dig MX gmail.com

; <<>> DiG 9.2.3 <<>> MX gmail.com
;; global options:  printcmd
;; connection timed out; no servers could be reached

I also did a standard ping and can't ping out either. (I can ping my website's domain, but not google.com.)

Code:
[root@gxxxxxa root]# ping gxxxxxa.com
PING gxxxxxa.com (66.xxx.xxx.211) 56(84) bytes of data.
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=0 ttl=64 time=0.043 ms
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=1 ttl=64 time=0.049 ms
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=2 ttl=64 time=0.039 ms
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=3 ttl=64 time=0.039 ms
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=4 ttl=64 time=0.028 ms
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=5 ttl=64 time=0.031 ms
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=6 ttl=64 time=0.041 ms
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=7 ttl=64 time=0.033 ms
64 bytes from gxxxxxa.com (66.xxx.xxx.211): icmp_seq=8 ttl=64 time=0.032 ms

--- gomanga.com ping statistics ---
9 packets transmitted, 9 received, 0% packet loss, time 7998ms
rtt min/avg/max/mdev = 0.028/0.037/0.049/0.007 ms, pipe 2

[root@gomanga root]# ping google.com
ping: unknown host google.com

Last edited by time_trapper; 02-28-2008 at 01:13 AM.
 
Old 02-28-2008, 04:45 AM   #7
time_trapper
LQ Newbie
 
Registered: Feb 2008
Posts: 15

Original Poster
Rep: Reputation: 0
Okay, here's an update to my previous post.


I decided to edit my "/etc/resolv.conf" file to add in the addresses that Aplus.Net lists on their site (216.55.128.7 and 216.55.144.5) that should be used for dedicated servers (i.e. resolvers). My domain is from Aplus.Net, but my server is with Ipower.

My original file looked like this:
Code:
nameserver 66.235.216.48
^ The nameserver listed is for Ipower, which is where my dedicated server is hosted. But this is not my server's IP address.

This is the revised "/etc/resolv.conf" file:
Code:
nameserver 66.235.216.48
nameserver 216.55.128.7
nameserver 216.55.144.5

Not sure if I was supposed to do this, but I did a nameserver restart:
Code:
[root@gxxxxxxa etc]# /etc/rc.d/init.d/named restart
Stopping named:                                            [  OK  ]
Starting named:                                            [  OK  ]


And then I ran a "dig" for my domain...
Code:
[root@gomanga etc]# dig MX gxxxxxa.com

; <<>> DiG 9.2.3 <<>> MX gxxxxxa.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 40724
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 2

;; QUESTION SECTION:
;gxxxxxa.com.                   IN      MX

;; ANSWER SECTION:
gxxxxxa.com.            86400   IN      MX      10 mail.gxxxxxa.com.

;; AUTHORITY SECTION:
gxxxxxa.com.            86400   IN      NS      ns.gxxxxxa.com.

;; ADDITIONAL SECTION:
mail.gxxxxxa.com.       86400   IN      A       66.2xx.xxx.211
ns.gxxxxxa.com.         86400   IN      A       66.2xx.xxx.211

;; Query time: 2 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Thu Feb 28 05:56:47 2008
;; MSG SIZE  rcvd: 99
I also did a dig for a few other sites like amazon.com, gmail.com, and those were able to access them in around 49 to 191 msec.


Unfortuntely...
My outgoing email problem still isn't solved.
My website, FTP, and incoming mail all still work. But none of my outgoing email is going through yet. Any suggestions? >_>


Should I be adding more or changing my "/etc/hosts" file?
Code:
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1               freshinstall localhost.localdomain localhost
66.2xx.xxx.211          gxxxxxa.com

Or is the problem elsewhere...?

- Adam

Last edited by time_trapper; 02-28-2008 at 05:32 AM.
 
Old 02-28-2008, 05:54 AM   #8
time_trapper
LQ Newbie
 
Registered: Feb 2008
Posts: 15

Original Poster
Rep: Reputation: 0
I just tried something else, and it seems to have done the trick.

I edited "/etc/resolv.conf" once again to include "search mydomain.com":
Code:
search gxxxxx.com
nameserver 66.235.216.48
nameserver 216.55.128.7
nameserver 216.55.144.5
Then I did a "/etc/rc.d/init.d/named restart" again.

And now, test messages that I sent to other off-site emails addresses since Tuesday seem to slowly be coming in. I assume the mail queue is pretty backed up (it's on tuesday right now), but I'm hoping this is the solution I was hoping for. *crosses fingers*
 
Old 02-28-2008, 05:05 PM   #9
time_trapper
LQ Newbie
 
Registered: Feb 2008
Posts: 15

Original Poster
Rep: Reputation: 0
UPDATE: Yes, that does seem to have fixed the issue. *phew*

Still, it's weird how this dedicated server would work fine since August 2005 and suddenly need various configuration files set-up to get things back working. Makes me wonder if IPower did something.

Thanks, Farslayer, for pointing me in the right direction.
 
Old 02-28-2008, 07:52 PM   #10
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
No problem..

You would have loved the mail server issue I ran into at work..

I pointed the mailservers resolv.conf to the DNS servers for fidnet.com (fidelity networks) thinking they were the DNS servers for fidelity access networks (shame on me for not verifying) everything ran great or 2 years, then all of a sudden we could no longer send mail from our server. I did a few dig test from the mail server but the only response I got back from the DNS query was a list of the root servers, never a response for the domain I was digging. I called my Service provider to ask what was up with their DNS, they said everything checked A-OK on their end.. then I verified the IP's and lo-and behold I had the wrong ones..

Whatever DNS server I was mistakenly using at fidnet went insane and once I replaced the nameserver entries on the server I could dig properly again but still couldn't send mail. postfix check pointed out that the nameserver entries in /etc/resolv.conf didn't match the ones in the chrooted postfix environment once I edited the other file in the postfix chroot everything started working perfectly again. Turned me for a loop when it went down though, let me tell you.

Glad you are up and running. Enjoy !!

Last edited by farslayer; 02-28-2008 at 07:56 PM.
 
  


Reply

Tags
dns, email, horde, linux, mail, outbound, qmail, server


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Horde outbound email will not deliver off Linux web server time_trapper Linux - Newbie 0 02-26-2008 09:09 PM
incoming mails only from particular server senthilvael Linux - Server 0 11-21-2007 01:40 PM
Mail server can't receive mails satimis Linux - Server 5 01-19-2007 03:45 AM
getting mails from remote mail server is slow,so need an intermediate server Sleen Linux - Networking 5 09-30-2006 03:09 PM
Problem in relaying outbound mails for specific smtp gurl4sh25 Linux - Server 3 08-31-2006 11:39 PM


All times are GMT -5. The time now is 10:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration