View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-01-2010, 03:48 PM   #1
LQ Newbie
Registered: Apr 2010
Posts: 5

Rep: Reputation: 0
OS cannot be loaded without keyboard because of grub

Hello to everyone!

I was working on a linux server before few weeks. There was a grub/keyboard issue. If no keyboard is attached (ps port) the grub isn't loading the operating system. If the keyboard is attached the grub is loading the operating system by default without any keyboard interaction.

The difference is only that there is a keyboard attached. Thats all.

I was searching on the web and one thing came along: "turn on/off 'stop on errors' feature in your bios.". Maybe its this, but tonight I'm not able to check if its this becuase the server is in a remote location.

However I would like to hear what you think of this problem.

Have a good time!
Old 05-01-2010, 06:50 PM   #2
Registered: Oct 2009
Location: England
Distribution: *buntu, Vector
Posts: 499

Rep: Reputation: 102Reputation: 102
Are you sure you're even reaching grub? As mentioned, many bioses have various options for halt on errors. Halt on "all" means it will stop the POST if there's no keyboard.
Old 05-01-2010, 07:25 PM   #3
Registered: Jan 2009
Location: /dev/ph
Distribution: Fedora, Ubuntu, Redhat, Centos
Posts: 296

Rep: Reputation: 62
Try adding apm=off to the kernel command line in grub.conf.
Old 05-01-2010, 07:35 PM   #4
Senior Member
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,096

Rep: Reputation: 102Reputation: 102
I have to agree I would check to make sure you are even reaching grub. I have never seen this and I run about 24 red hat servers and none of them have a keyboard attached to them. If you are getting this to grub I would do what the other person suggested but use apci=off as I believe apm is older and pretty much no longer used.
Old 05-02-2010, 02:47 AM   #5
LQ Newbie
Registered: Apr 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you all for your responses.

Yes. I'm reaching the grub. My customized grub menu shows and it waits for my choice while waiting few seconds for the default option selected. If there's a keyboard attached the default choice is selected. If no keyboard is attached then nothing happens - grub just doesn't load the default option.

I think I tried this before but I'm not sure. I'll post my grub.conf in this response.

As I said I reach the grub. I'll try these days with the option you provided and the one from fpmurphy. If its working with one of these options I'll immediately report it here. I'm not using redhat but fedora if there's a difference.

Here is my grub.conf file:

password --md5 **********************************

title Server Operating System
root (hd0,0)
kernel /boot/vmlinuz- ro selinux=0 rhgb quiet
initrd /boot/initrd-
Thats all. Have a good day!
Old 05-01-2015, 03:26 PM   #6
Registered: Apr 2013
Posts: 83

Rep: Reputation: Disabled
Hello everyone. I'm hoping to resurrect this thread, since I have been beating my head over the desk trying to figure this issue out myself.

I'm running CentOS. When I boot with the keyboard/mouse plugged in, the unit boots fine and the screen goes straight into the

"Press any key to enter the menu"

Booting CentOS (2.6.18-274.7.1.e15) in 2 seconds...

But when I unplug the keyboard/mouse and boot, the grub screen shows up with a choice of two kernels to boot from:

GNU GRUB version 0.97 (630K lower / 1034440K upper memory)

CentOS (2.6.18-274.7.1.e15)
CentOS ((2.6.18-274.e15)
Both of these screens have the CentOS blue backdrop with white flower pattern.

I've tried the suggestions below in /etc/grub.conf

Still no go. I even removed the titles in /etc/grub.conf, which I figured wouldn't work but I'll try anything at this point. Still having the same issue.

It wouldn't be an issue if the timeout would just work. But as it is now, a user must choose which kernel to boot from when the keyboard/mouse is not plugged in.

If anyone has run into this before, or if you have any suggestions then I would be more than grateful.


Old 05-01-2015, 06:15 PM   #7
Senior Member
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 3,321

Rep: Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819
You might try using the serial console - though that becomes a pain if you try to use a keyboard (it won't work).

Most servers (the ones I used to work with) all had a keyboard/mouse/display connection to a KVM of some kind which is then connected to an administrative net.

Grub legacy has support for a serial console (which is always present as far as I know). If such is defined to be used, it will disable the keyboard/display; but SHOULD allow the timeout to pass directly to boot. Of course, this causes a problem when you DO need to use the keyboard locally.
Old 05-04-2015, 01:14 PM   #8
Registered: Apr 2013
Posts: 83

Rep: Reputation: Disabled
Thank you jpollard for the suggestion. I'm going to give it a try and will get back to you with the results.
Old 05-18-2015, 01:25 PM   #9
Registered: Apr 2013
Posts: 83

Rep: Reputation: Disabled
A solution was found for this issue. Well, I guess it's a trick really.

Assuming you have the unit set up with a static ip...

1) You set the unit to boot to network without having anything available to boot to
2) Have the second boot device to the drive.

Once it finds that there is nothing to boot to, it will try to boot to the secondary boot device (The drive) and when it does this it goes into the default kernel without halting at the duel grub menu.

As long as you have a link on the network interface this will work. If there is no link on the network interface then boot to network will be ignored (PXE) and it will go straight to the drive, where you'll end up at the duel choice grub menu.

In bios enable boot to network, then set it to boot to network as first device (And drive as second), and if there's anything like OPROM LAN, make sure it's set to enable.

I tested this several times and it works like a charm.

NOTE: I would make this as resolved, but I did not start the thread.

Thanks everyone for your help.


freeze, grub, keyboard, linux

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Keyboard not working until Linux is loaded ANO1453 Linux - General 2 05-12-2009 02:50 PM
Loaded Grub, now my slackware boot is messed up Romanus81 Slackware 4 03-13-2008 03:06 PM
GRUB Error 15, Linux already loaded rick_amd Linux - Newbie 7 03-02-2008 03:06 AM
Grub not loaded after 7.10 installation on separate hd trengag Linux - Newbie 1 12-31-2007 05:20 AM
Booting Grub once kernel is loaded. American Psycho Linux - Newbie 2 04-03-2004 12:56 AM

All times are GMT -5. The time now is 11:26 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration