LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   OS cannot be loaded without keyboard because of grub (http://www.linuxquestions.org/questions/linux-newbie-8/os-cannot-be-loaded-without-keyboard-because-of-grub-805350/)

linuxn 05-01-2010 03:48 PM

OS cannot be loaded without keyboard because of grub
 
Hello to everyone!

I was working on a linux server before few weeks. There was a grub/keyboard issue. If no keyboard is attached (ps port) the grub isn't loading the operating system. If the keyboard is attached the grub is loading the operating system by default without any keyboard interaction.

The difference is only that there is a keyboard attached. Thats all.

I was searching on the web and one thing came along: "turn on/off 'stop on errors' feature in your bios.". Maybe its this, but tonight I'm not able to check if its this becuase the server is in a remote location.

However I would like to hear what you think of this problem.

Have a good time!

cantab 05-01-2010 06:50 PM

Are you sure you're even reaching grub? As mentioned, many bioses have various options for halt on errors. Halt on "all" means it will stop the POST if there's no keyboard.

fpmurphy 05-01-2010 07:25 PM

Try adding apm=off to the kernel command line in grub.conf.

jstephens84 05-01-2010 07:35 PM

I have to agree I would check to make sure you are even reaching grub. I have never seen this and I run about 24 red hat servers and none of them have a keyboard attached to them. If you are getting this to grub I would do what the other person suggested but use apci=off as I believe apm is older and pretty much no longer used.

linuxn 05-02-2010 02:47 AM

Thank you all for your responses.

@cantab,
Yes. I'm reaching the grub. My customized grub menu shows and it waits for my choice while waiting few seconds for the default option selected. If there's a keyboard attached the default choice is selected. If no keyboard is attached then nothing happens - grub just doesn't load the default option.

@fpmurphy,
I think I tried this before but I'm not sure. I'll post my grub.conf in this response.

@jstephens84,
As I said I reach the grub. I'll try these days with the option you provided and the one from fpmurphy. If its working with one of these options I'll immediately report it here. I'm not using redhat but fedora if there's a difference.

Here is my grub.conf file:

Quote:

default=0
timeout=1
#splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
password --md5 **********************************

title Server Operating System
root (hd0,0)
kernel /boot/vmlinuz-2.6.33.1.1 ro selinux=0 rhgb quiet
initrd /boot/initrd-2.6.33.1.1.img
Thats all. Have a good day!


All times are GMT -5. The time now is 04:33 AM.