LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-29-2003, 12:09 AM   #1
BiTurboMan
LQ Newbie
 
Registered: Dec 2003
Posts: 20

Rep: Reputation: 0
Oracle 11i apps on RH9 .. libdb.so.3 error


Hello,

I have been trying to install Oracle 11i apps on RH9 and having trouble.

I've followed the install guide from :http://databee.com/apps11i_install.htm

I tried to find the "compat-db-3.3.11-3.i386.rpm" on the net, RPMfind with no luck. I found the ..-2 and ..-4 but not ..-3 ..

I installed the ..-2 and ..-4 RPMs and they did not work. At the end of the install, Apache fails to start and indicates error loading library "libdb.so.3"...

I even tried placing the file libdb.so.3 (downloaded from an ftp site) in "/usr/lib" directory as the guide states... still no luck.

Does anyone know where I can get this "compat-db-3.3.11-3.i386.rpm"?

Or

perhaps a source code for it and some instructions on installing it???

Any help regarding this would be truly appreciated!

Thank you!
 
Old 12-29-2003, 08:50 AM   #2
ugob
Member
 
Registered: Nov 2003
Distribution: RH, Fedora, Debian, Knoppix
Posts: 436

Rep: Reputation: 31
http://www.hklpg.org/RPM/rawhide/1.0...11-3.i386.html
 
Old 12-29-2003, 10:44 AM   #3
BiTurboMan
LQ Newbie
 
Registered: Dec 2003
Posts: 20

Original Poster
Rep: Reputation: 0
I went through this page many times and tried to select almost all the links there. Maybe, I am missing something here but, I can't download anything...

When I click on the main link (big heading on the top), I get page cannot be displayed error....

Anything that I am doing wrong?

Thank you.
 
Old 12-29-2003, 11:15 AM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
http://www.rpmfind.net/linux/rpm2htm...mit=Search+...
 
Old 12-29-2003, 11:30 AM   #5
BiTurboMan
LQ Newbie
 
Registered: Dec 2003
Posts: 20

Original Poster
Rep: Reputation: 0
I've downloaded these previously and installed with no luck. I can only find compat-db-3.3.11-4.src.rpm or compat-db-3.3.11-2.src.rpm but NOT the one I am looking for which is: compat-db-3.3.11-3.src.rpm

Why is this the hardest thing to find on the web? I just don't understand...

If you refer to my original post, it includes a link to "databee.com..." and in that page, it is clearly indicated about apache being stubborn about the version of this library... Unfortunately, it is true...

By now, I've searched numerous ftp sites and installed the ...4 and ...2 rpms with no luck....

Still dead in the water...

Last edited by BiTurboMan; 12-29-2003 at 02:43 PM.
 
Old 12-29-2003, 08:29 PM   #6
ugob
Member
 
Registered: Nov 2003
Distribution: RH, Fedora, Debian, Knoppix
Posts: 436

Rep: Reputation: 31
if you're using redhat 9 or fedora core 1, it (libdb.so.3) is in the package compat-db

[root@host root]# apt-cache search libdb.so.3
compat-db - The Berkeley DB database library for Red Hat Linux 7.x compatibility.


If you don't have it, get apt

http://apt.freshrpms.net

then read
man apt-get
man apt-cache
 
Old 12-29-2003, 11:01 PM   #7
alar
Member
 
Registered: Sep 2003
Location: Canada
Distribution: CentOS 5.5, Ubuntu 10.04, Linux Mint 11 gnome 64 bit
Posts: 336

Rep: Reputation: 36
RPM resource libdb.so.3. Provided by. compat-db-3.3.11-3.i386, The Berkeley DB
database library for Red Hat Linux 7.x compatibility. RawHide 1.0 for i386. ...
www.hklpg.org/RPM/libdb.so.3.html - 8k - Cached - Similar pages

On RH9 I used Synaptic to find:

compat-db-3.3.11-4

The Berkeley Database (Berkeley DB) is a programmatic
toolkit that provides embedded database support for both
traditional and client/server applications. This package
contains various versions of Berkeley DB which were included
in previous releases of Red Hat Linux.

Have fun,
alar
 
Old 12-30-2003, 09:26 PM   #8
BiTurboMan
LQ Newbie
 
Registered: Dec 2003
Posts: 20

Original Poster
Rep: Reputation: 0
Thumbs up

Update on the Issue...resolved

First, I want to Thank everyone of you for your input on this thread. It's
guys like you that really make a difference!
-------------------------------------------------------------------------------------------------------------------------------------------------



Today, after work , I was having one of those "What if" moments and when I tried , it worked!!!

Here is what I did:
=============

1) Downloaded compat-db-3.3.11-4.i386.rpm (again... ;-) )

2) copied that RPM file into /test directory.
>) Make sure to copy and run the next command in a "/test" or a "/tmp" directory. Otherwise, it will extract all the directories right at the "/" or any other directory you are in at time of issuing the command.

3) Issued this command: "rpm2cpio compat-db-3.3.11-4.i386.rpm | cpio -iv -make-directories" {<--This is on RH9. Commands may differ in other versions of linux }

4) Next, copy the lib file to the right directory and rename it.

>)cp /test/lib/libdb2.so.3 /lib/libdb.so.3

>>>Apache needs this to be "libdb.so.3". Renaming the "libdb2.so.3" to "libdb.so.3" works in this case...

Run appropriate scripts in 11i to start apache (adapcctl.sh start)... and things should work!

I hope this helps someone out there. I know that I went through hell and dug so much (being a newbie didn't help -I guess it's all part of ).


And, that's my
-bharat

Last edited by BiTurboMan; 12-30-2003 at 09:45 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PLEASE HELP !! Installing Oracle 11i using FIREWIRE as storage; Redhat 9.0 gmedapuram Red Hat 3 03-03-2005 10:04 PM
Installing Oracle Apps 11i in Redhat 9 - Linux "bad interpreter" error msoares Linux - Newbie 4 07-14-2004 10:45 PM
Installing Oracle 11i using FIREWIRE as storage; Redhat 9.0 gmedapuram Linux - Enterprise 2 07-05-2004 11:14 AM
Oracle Apps 11i installation on redhat linux? Databasedemon Linux - Newbie 0 04-10-2004 03:12 PM
Oracle 11i apps on RH9 .. libdb.so.3 error BiTurboMan Linux - Software 2 12-29-2003 11:21 AM


All times are GMT -5. The time now is 02:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration