LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-12-2004, 07:06 PM   #1
killswitch1968
LQ Newbie
 
Registered: Mar 2004
Posts: 21

Rep: Reputation: 15
Optimal mouse settings?


I've migrated from XP and I have to say that mouse control seemed better there. I tried fiddling with the slider bars in KDE but it's not quite right. XP had this deceleration/acceleration feature, not just mouse speed.
What do you use for optimum mouse control?

Thanks
 
Old 03-12-2004, 07:12 PM   #2
bronko
Member
 
Registered: Dec 2003
Distribution: Debian/unstable
Posts: 30

Rep: Reputation: 15
Yeah... wanna know that, too. And: I'd like to have my mouse-wheel working. Have no idea how.

regards bronko
 
Old 03-12-2004, 07:15 PM   #3
misterflibble
Member
 
Registered: Feb 2004
Distribution: Debian UnStaBle
Posts: 123

Rep: Reputation: 15
You're going to have to give some more info: what distribution are you using? I know that in my kde settings (kde 3.1->3.2) I have an option for mouse acceleration, maybe you have an old version.
 
Old 03-12-2004, 07:24 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Okidoki The first thing you have to do is to tell us what sort of mouse you are using. USB, PS2.

- To configure the mouse speed, edit the file located at /etc/rc.d/rc.gpm.

- There, find a line more or less like this: /usr/sbin/gpm -m /dev/mouse -t ps2

- Add an -r <number> for changing the mouse speed. E.g: /usr/sbin/gpm -m /dev/mouse -t ps2 -r 30

- To change the mouse acceleration, use the flag -a <value> just like in the example above.

- Restart the daemon: /etc/rc.d/rc.gpm restart

Be very careful changing that -r <value>. If you put it too fast, you won't see shit or your mouse won't move ghehe.

Now, about the mouse wheel thing . The file you have to edit is located at /etc/X11/XF86Config. Open that file and add the following lines at the section "Input Device":

Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"

Then look after the line where it stands "Emulate 3 buttons mouse" and set it to "no". Restart X.

Enjoy!
 
Old 03-12-2004, 07:38 PM   #5
killswitch1968
LQ Newbie
 
Registered: Mar 2004
Posts: 21

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Megaman X
Okidoki The first thing you have to do is to tell us what sort of mouse you are using. USB, PS2.

- To configure the mouse speed, edit the file located at /etc/rc.d/rc.gpm.

- There, find a line more or less like this: /usr/sbin/gpm -m /dev/mouse -t ps2

- Add an -r <number> for changing the mouse speed. E.g: /usr/sbin/gpm -m /dev/mouse -t ps2 -r 30

- To change the mouse acceleration, use the flag -a <value> just like in the example above.

- Restart the daemon: /etc/rc.d/rc.gpm restart


Enjoy!
Sure. I have a PS/2 mouse. The sliders are from KDE 3.1.3, I was hoping for the values of these sliders but I can edit files no problem . My scroll wheel works great, just the acceration is a problem.

Okay what -r and -a number do you recommend for nice smooth mouse movements?

Thanks
 
Old 03-12-2004, 07:42 PM   #6
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
I use the defaults . But try some value between 30 and 100. If it does not work as you wished, them switch it back. I really am guessing those number though .
 
Old 03-12-2004, 07:54 PM   #7
bronko
Member
 
Registered: Dec 2003
Distribution: Debian/unstable
Posts: 30

Rep: Reputation: 15
distro: debian sid
mouse: ps2

seems I have two mice in my XF86Config-4. I had a look on my desktop and theres only one :)
With this configuration the wheel still doesn't work:


Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "false"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "SendCoreEvents" "true"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "Emulate3Buttons" "false"
Option "ZAxisMapping" "4 5"
EndSection
 
Old 03-12-2004, 07:59 PM   #8
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
I really have no idea if that would be your problem... but that might be a case sensitve problem. Note the line:

Option "Protocol" "ImPS/2"

that'd be IMPS/2. If that's not the problem... them... maybe you can comment out (put a hash "#" symbol at the beginning of a line) the mouse that you think is wrong/not really connected and try restarting X
 
Old 03-12-2004, 08:39 PM   #9
bronko
Member
 
Registered: Dec 2003
Distribution: Debian/unstable
Posts: 30

Rep: Reputation: 15
thx for your advice... it still doesn't work.

after finding out restarting KDE is _not_ restarting X, I found the first one is our candidate.

XF86Config-4 now looks like this:

Section "InputDevice"
Identifier "Generic Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/psaux"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

...

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Generic Mouse"
EndSection
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Optimal settings for RAID0 unzari Fedora 3 07-21-2005 06:17 PM
Can't configure mouse settings benk Fedora 1 08-08-2004 08:17 AM
Mouse settings dwpondscum Linux - Distributions 1 06-13-2003 07:45 AM
Mouse settings jpc82 Linux - Newbie 1 10-17-2002 02:18 AM
I have change my mouse settings Bheki Linux - General 1 02-05-2002 05:03 PM


All times are GMT -5. The time now is 04:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration