LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-28-2013, 07:39 PM   #1
13stein.j
Member
 
Registered: May 2013
Location: Brooklyn, New York
Distribution: Linux Mint 15/Ubuntu 13.10/Debian 7/SUSE 11.x/openSUSE 12.3/RHEL 6.4/Fedora 18/Slackware, and 5 more
Posts: 111

Rep: Reputation: 6
OpenSuse suddenly stops booting correctly


Out of nowhere, when choosing Slackware from grub, I get opensuse, but it freezes once it hits the GUI, and when choosing opensuse I get the following-- shown in screenshot. After a while of messing around and unplugging and replugging things in and renaming sdf to sdg and visa versa, Slackware got fixed but Opensuse still gives me what is shown in the screenshot, and, when choosing opensuse from grub, it seems to freeze, so I hit the right arrow and I get what you see in the screenshot, and I cant even type to choose yes or no. If the only answer is formatting and then reinstalling, please tell me the possibilities that could have caused this, so I don't do it again.
Attached Thumbnails
Click image for larger version

Name:	Screenshot (130).png
Views:	32
Size:	6.8 KB
ID:	12627  
 
Old 05-28-2013, 10:41 PM   #2
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,390
Blog Entries: 7

Rep: Reputation: 164Reputation: 164
please a little explination on the bootloader.
Grub Legacy, or Grub 2?
Is this chainloading or not?
How did you install grub? Was it while installing Opensuse?
Where is the boot loader installed too; the mbr or the root of a partition?

As a quick guess, (I'm assuming it's grub2, installed with Opensuse) have you tried booting Slackware, mounting and chrooting into Opensuse and running the command,
Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
 
Old 05-28-2013, 10:56 PM   #3
13stein.j
Member
 
Registered: May 2013
Location: Brooklyn, New York
Distribution: Linux Mint 15/Ubuntu 13.10/Debian 7/SUSE 11.x/openSUSE 12.3/RHEL 6.4/Fedora 18/Slackware, and 5 more
Posts: 111

Original Poster
Rep: Reputation: 6
It's grub 2, installed with ubuntu, slackware getting messed up was just a side effect. What do you mean by chainloading, and it is installed to the mbr of the fist disk in my bios. There are other installations as well, and I can list them if needed.
 
Old 05-28-2013, 11:56 PM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,871

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
An example of a chainload entry for Grub2 below, booting sda12 partition:

Quote:
menuentry 'Opensuse' {
insmod ext2
set root=(hd0,12)
chainloader +1
If you have Ubuntu installed and its Grub is in the mbr, have you run update-grub from Ubuntu?
 
Old 05-29-2013, 02:50 AM   #5
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,390
Blog Entries: 7

Rep: Reputation: 164Reputation: 164
Quote:
Originally Posted by yancek View Post
If you have Ubuntu installed and its Grub is in the mbr, have you run update-grub from Ubuntu?
Strange... I replied earlier to this and the reply isn't here. Oh well, what Yancek has said is basically what i suggested too.
Do you even still have Ubuntu installed?

Chainloading is when your bootloader boots up and instead of proceeding to boot up an os, it boots up another bootloader which then boots up the operating system.
It sounds dumb but if you've a lot of operating systems on your computer, it can really help with maintenance.

I chainload. When my laptop boots up, it boots up Grub legacy, which displays a choice of five operating systems. It boots up Debian by default after 3 seconds. Instead of booting up Debian though, it actually boots up Grub2 which is installed onto the root of my Debian partition, which then after 2 seconds, boots up my Debian Wheezy operating system.
If i don't want to boot Debian, and want to boot up my Slackware partition instead: when the computer boots up Grub Legacy, if i select Slackware, it boots up lilo (The bootloader installed by default on Slackware) which then boots Slackware. This setup is convenient because it means i never have to worry about messing up a bootloader on one of my operating systems and not being able to boot; because if that were to ever happen, everything is contained to it's own partition, and the other operating systems aren't dependent on each other. (Sorry about that horribly long sentence)
 
Old 05-29-2013, 06:56 AM   #6
13stein.j
Member
 
Registered: May 2013
Location: Brooklyn, New York
Distribution: Linux Mint 15/Ubuntu 13.10/Debian 7/SUSE 11.x/openSUSE 12.3/RHEL 6.4/Fedora 18/Slackware, and 5 more
Posts: 111

Original Poster
Rep: Reputation: 6
Then, I do not chainload, and I have run sudo update-grub several times, and I have even tried using rescueatux previously, but could I possibly use parted magic to fix this?
 
Old 05-29-2013, 07:45 AM   #7
13stein.j
Member
 
Registered: May 2013
Location: Brooklyn, New York
Distribution: Linux Mint 15/Ubuntu 13.10/Debian 7/SUSE 11.x/openSUSE 12.3/RHEL 6.4/Fedora 18/Slackware, and 5 more
Posts: 111

Original Poster
Rep: Reputation: 6
Can someone tell me how to set up chainloading, as it may help. I have grub2 on the MBR of a hard disk.
 
Old 05-29-2013, 08:13 AM   #8
bloodstreetboy
Member
 
Registered: May 2012
Posts: 198
Blog Entries: 3

Rep: Reputation: 37
If you are talking about chainloading from one grub to another, have a look at this.
http://richardfearn.wordpress.com/20...ub-to-another/
 
Old 05-29-2013, 08:57 AM   #9
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,390
Blog Entries: 7

Rep: Reputation: 164Reputation: 164
Quote:
Originally Posted by 13stein.j View Post
Can someone tell me how to set up chainloading, as it may help. I have grub2 on the MBR of a hard disk.
It's probably best you sought out this issue before you do that.
Just out of curiosity, are you sure that your Opensuse partition isn't full?
 
Old 05-29-2013, 09:33 AM   #10
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,871

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
If you are booting with Grub2 in the mbr, you can just edit the grub.cfg file (that's the one that says do not edit this file at the top) by placing an entry similar to the example I posted above. You will need to change the drive/partition number to fit your specific system bearing in mind that Grub2 counts physical hard drives from zero and partitions from one. After making the change, do not run update-grub but reboot to test it. If it works, you will need to put that entry in the Ubuntu /etc/grub.d/40_custom file. Just copy it there.

If that doesn't work, you should google 'bootinfoscript' and go its site, read the instructions, download and run it and post the output, a results.txt file with a lot of information on drives/partitions, boot files and uuids.
 
Old 05-30-2013, 07:24 PM   #11
13stein.j
Member
 
Registered: May 2013
Location: Brooklyn, New York
Distribution: Linux Mint 15/Ubuntu 13.10/Debian 7/SUSE 11.x/openSUSE 12.3/RHEL 6.4/Fedora 18/Slackware, and 5 more
Posts: 111

Original Poster
Rep: Reputation: 6
Back to my original question, can I fix this?
 
Old 05-30-2013, 10:29 PM   #12
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,390
Blog Entries: 7

Rep: Reputation: 164Reputation: 164
13stein.j, post the whole error message. It says 'trying to manually resume', but we can't tell why it's trying to, and it may be a valuable clue to helping you. Also post these things; your /etc/fstab file from your Opensuse partition and the output of these commands:
(Do these commands from within Ubuntu)
Code:
blkid /dev/sda2
Code:
cat /etc/boot/grub.cfg | grep UUID
And lastly, i asked before if your sure your Opensuse partition has disk space?
 
Old 05-31-2013, 06:02 PM   #13
13stein.j
Member
 
Registered: May 2013
Location: Brooklyn, New York
Distribution: Linux Mint 15/Ubuntu 13.10/Debian 7/SUSE 11.x/openSUSE 12.3/RHEL 6.4/Fedora 18/Slackware, and 5 more
Posts: 111

Original Poster
Rep: Reputation: 6
Quote:
Originally Posted by Knightron View Post
13stein.jthe output of these commands:
(Do these commands from within Ubuntu)
Code:
blkid /dev/sda2
And lastly, i asked before if your sure your Opensuse partition has disk space?
On Ubuntu, the OpenSuse partition is sdf1 and sdf2, so I will use the command on those partitions, and the other commands asap. Again, my opensuse partition has space, 86 GB to be exact.
 
Old 05-31-2013, 07:43 PM   #14
13stein.j
Member
 
Registered: May 2013
Location: Brooklyn, New York
Distribution: Linux Mint 15/Ubuntu 13.10/Debian 7/SUSE 11.x/openSUSE 12.3/RHEL 6.4/Fedora 18/Slackware, and 5 more
Posts: 111

Original Poster
Rep: Reputation: 6
Quote:
Originally Posted by Knightron View Post
your /etc/fstab file from your Opensuse partition
Code:
/dev/sda2            swap                 swap       defaults              0 0
/dev/sda1            /                    ext4       acl,user_xattr        1 1
proc                 /proc                proc       defaults              0 0
sysfs                /sys                 sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
Quote:
Originally Posted by Knightron View Post
and the output of these commands:
(Do these commands from within Ubuntu)
Code:
blkid /dev/sda2(sde1,sde2)
Code:
root@13stein:~# blkid /dev/sde1
/dev/sde1: UUID="2695b5bf-03ac-41b9-b606-942267cb6d2e" TYPE="ext4" 
root@13stein:~# blkid /dev/sde2
/dev/sde2: UUID="52f769d2-d068-4a42-9f3c-b23fb7058d70" TYPE="swap"
Quote:
Originally Posted by Knightron View Post
Code:
cat /etc/boot/grub.cfg(should be cat /boot/grub/grub.cfg) | grep UUID
Code:
	linux	/boot/vmlinuz-3.9.3-030903-generic root=UUID=5c5441f0-8678-4790-969c-d2efbb88573c ro   quiet splash $vt_handoff
		linux	/boot/vmlinuz-3.9.3-030903-generic root=UUID=5c5441f0-8678-4790-969c-d2efbb88573c ro   quiet splash $vt_handoff
		linux	/boot/vmlinuz-3.9.3-030903-generic root=UUID=5c5441f0-8678-4790-969c-d2efbb88573c ro recovery nomodeset 
	linux /boot/vmlinuz-3.2.0-4-amd64 root=UUID=319eeaec-a8b0-4d4f-8718-a9d119a8e1c2 ro quiet
		linux /boot/vmlinuz-3.2.0-4-amd64 root=UUID=319eeaec-a8b0-4d4f-8718-a9d119a8e1c2 ro quiet
	menuentry 'Debian GNU/Linux, with Linux 3.2.0-4-amd64 (recovery mode) (on /dev/sdb1)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-3.2.0-4-amd64-root=UUID=319eeaec-a8b0-4d4f-8718-a9d119a8e1c2 ro single-319eeaec-a8b0-4d4f-8718-a9d119a8e1c2' {
		linux /boot/vmlinuz-3.2.0-4-amd64 root=UUID=319eeaec-a8b0-4d4f-8718-a9d119a8e1c2 ro single
	linux /boot/vmlinuz-3.9.3-030903-generic root=UUID=be7b24bf-21da-41fb-8573-cd23f2ccc69a ro quiet splash $vt_handoff
		linux /boot/vmlinuz-3.9.3-030903-generic root=UUID=be7b24bf-21da-41fb-8573-cd23f2ccc69a ro quiet splash $vt_handoff
	menuentry 'Linux Mint 15 Cinnamon 64-bit, 3.9.3-030903-generic (/dev/sdc1) -- recovery mode (on /dev/sdc1)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-3.9.3-030903-generic-root=UUID=be7b24bf-21da-41fb-8573-cd23f2ccc69a ro recovery nomodeset-be7b24bf-21da-41fb-8573-cd23f2ccc69a' {
		linux /boot/vmlinuz-3.9.3-030903-generic root=UUID=be7b24bf-21da-41fb-8573-cd23f2ccc69a ro recovery nomodeset
		linux /boot/vmlinuz-3.9.3-030903-generic root=UUID=5c5441f0-8678-4790-969c-d2efbb88573c ro quiet splash $vt_handoff
	linux /boot/vmlinuz-2.6.32-71.el6.x86_64 ro root=UUID=248375d4-1e37-46c8-ba3e-41d4e9c7d406 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us nomodeset crashkernel=auto rhgb quiet
		linux /boot/vmlinuz-2.6.32-71.el6.x86_64 ro root=UUID=248375d4-1e37-46c8-ba3e-41d4e9c7d406 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us nomodeset crashkernel=auto rhgb quiet
	linux /boot/vmlinuz-3.9.3-1.g0b5d8f5-desktop root=UUID=2695b5bf-03ac-41b9-b606-942267cb6d2e resume=/dev/sda2 splash=silent quiet showopts
		linux /boot/vmlinuz-3.9.3-1.g0b5d8f5-desktop root=UUID=2695b5bf-03ac-41b9-b606-942267cb6d2e resume=/dev/sda2 splash=silent quiet showopts
		linux /boot/vmlinuz-3.9.3-1.g0b5d8f5-desktop root=UUID=2695b5bf-03ac-41b9-b606-942267cb6d2e resume=/dev/sda2 splash=silent quiet showopts
		linux /boot/vmlinuz-3.9.3-1.g0b5d8f5-desktop root=UUID=2695b5bf-03ac-41b9-b606-942267cb6d2e showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
		linux /boot/vmlinuz-3.7.10-1.1-desktop root=UUID=2695b5bf-03ac-41b9-b606-942267cb6d2e resume=/dev/sda2 splash=silent quiet showopts
		linux /boot/vmlinuz-3.7.10-1.1-desktop root=UUID=2695b5bf-03ac-41b9-b606-942267cb6d2e showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe
	linux /boot/vmlinuz-2.6.32-358.6.2.el6.x86_64 ro root=UUID=fe662e3b-3bb4-4dcb-94f7-be4414816161 rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet crashkernel=auto
		linux /boot/vmlinuz-2.6.32-358.6.2.el6.x86_64 ro root=UUID=fe662e3b-3bb4-4dcb-94f7-be4414816161 rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet crashkernel=auto
		linux /boot/vmlinuz-2.6.32-358.el6.x86_64 ro root=UUID=fe662e3b-3bb4-4dcb-94f7-be4414816161 rd_NO_LUKS rd_NO_LVM LANG=en_US.UTF-8 rd_NO_MD SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet
 
Old 05-31-2013, 11:29 PM   #15
Knightron
Senior Member
 
Registered: Jan 2011
Location: Australia
Distribution: OpenSUSE
Posts: 1,390
Blog Entries: 7

Rep: Reputation: 164Reputation: 164
I forgot that Opensuse uses the /dev/disk/by-id method of identifying partitions, before when i was asking for info, but have just remembered when i checked my Opensuse partitions fstab. Your fstab is set up very basically instead though. I'm not very familiar with the /dev/disk-id method, so try making a new fstab file using UUID instead.

mount your Opensuse partiton and change the name of the fstab file
(assuming it's mounted in mnt);
Code:
sudo mv /mnt/etc/fstab /mnt/etc/fstab.org
Then create a new one by 'sudo nano /mnt/etc/fstab' with with the bellow information copied and pasted into it.

Code:
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=2695b5bf-03ac-41b9-b606-942267cb6d2e /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda2 during installation
UUID=52f769d2-d068-4a42-9f3c-b23fb7058d70 none            swap    sw              0       0
Code:
sudo umount /dev/sda2
reboot and see if you can boot up Opensuse.

Last edited by Knightron; 05-31-2013 at 11:30 PM. Reason: A smiley face had formed due to my improper grammar
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When your computer suddenly stops booting xri Linux - Hardware 31 05-10-2011 01:27 PM
opensuse 11.3 32bit os stops booting and requests to manually run fsck sirius57 SUSE / openSUSE 1 09-05-2010 07:05 AM
DSL suddenly stops Dutch72 Linux - Newbie 11 02-20-2009 03:44 AM
FC7 grub suddenly stops booting Solaris Express CE zillah Linux - Software 23 11-30-2007 05:20 PM
grub suddenly stops booting XP mab_123 Linux - Software 3 03-26-2005 11:08 AM


All times are GMT -5. The time now is 10:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration