LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 03-11-2006, 04:30 PM   #1
Saketh
Member
 
Registered: Jun 2005
Posts: 62

Rep: Reputation: 15
Unhappy OpenSUSE Networking Troubles


I realise that the OpenSUSE wiki says that the Linksys WUSB54G Wireless card works out-of-the-box with YaST2, but other sources tell me that you need the rtx100 drivers. I am trying to get my WUSB54G card to work, but the only time that I ever got it to work was under Ubuntu with ndiswrapper. Will it work without ndiswrapper under OpenSUSE? I already know my configuration information (DNS, Routing, etc.), so that's not a problem.

What information about my network do I need to find before I reboot into OpenSUSE? I already have the IP, Mask, Gateway, DHCP address, and DNS Name servers.
 
Old 03-11-2006, 04:59 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I believe that you need to install the ndiswrapper packages. If you use DHCP, it will assign you an IP ,Mask ,Gateway, etc.
You will also want to install the wireless-tools package and the wpa_supplicant package. If your card is detected, they may be called for.
 
Old 03-11-2006, 05:38 PM   #3
Saketh
Member
 
Registered: Jun 2005
Posts: 62

Original Poster
Rep: Reputation: 15
I will install ndiswrapper, wireless-tools, and wpa_supplicant. But what exactly am I supposed to do, from start to finish, to get the network card configured? I know how to use ndiswrapper, but do I need to configure the DHCP server?
 
Old 03-12-2006, 02:24 AM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
I misunderstood what you meant. I thought that you were going to use a dhcp client, such as from a linksys router or cable modem.

You can set up your interfaces in YaST. If you have a cable modem, or router with a dhcp server, you can opt to use that to set most of the items automatically. Otherwise, you can instead set them manually from in YaST, in the section where you setup the interface.

Before you do that, however, you need to make sure the ndiswrapper is installed, and the driver is loaded. Then check if the module is loaded with "lsmod" as root. There are instructions on using ndiswrapper in this websites wiki. http://wiki.linuxquestions.org/wiki/NDIS_Wrapper
Also read the ndiswrapper README file. There is an option to update the modprobe aliases for example. I'm not sure if the wiki mentions it. For SuSE 10, the version of ndiswrapper may work. For an older distro, you may need to download the source.

Go into YaST, and select Network Devices -> Network Card.
See if your card is detected. It might be. However, I'm not sure because it is a USB device. If it isn't, you will need to click the "Add" button. I believe that you will need to select "Wireless" from the drop-down selector, and check the "USB" box on the bottom of the screen.

If you are going to use a dhcp client, then most of the information on the page will be ghosted, because DHCP will supply it when you boot up. Check on the Routing button however. It can't hurt to supply the gateway address anyway. In the Host Name button, you can enter your hostname.

Under the advanced section is where you will enter things for the wireless interface.
Advanced -> Hardware details: enter "ndiswrapper" under Module Name if it isn't already there. For a usb device, your Hardware Configuration name will probably be different then mine, because I have a built in adapter. The name may seem wierd, but it is used in the scripts, and you don't need to remember it. The Configuration Name at the top will probably say wlan0. This is the name of the interface you would use. For example, to reset the interface, "sudo /sbin/rcnetwork restart wlan0".

Under advanced -> DHCP Client Options, I have the "Request Broadcast Response" box checked.

Under Advanced -> Detailed Network Card Settings:
I think for a USB device, selecting On Hotplug for the device activation may be a good idea. For wireless, you may want to select "Externel Zone" for Firewall zone, and restrict the services in the firewall setup.

Now if you click on "Next" in the bottom right hand corner, you will get to part where you set up the encryption.
For at home, you will probably want to use the "Managed" operating mode. Enter a name for your wireless network in "Network Name (ESSID)". Under Authentication mode, are several options. The particulars may depend on what your card supports. I would recommend using "WPA-PSK".

This is a oneliner that I use to generate a random 64 digit Hexadecimal key:
Code:
dd if=/dev/random  bs=1 count=32 | od -t x1 | sed -e '3d' -e 's/^.\{8\}//' -e 's/ //g' | tr -d '\n'; echo
The same key will be needed in all of your wireless devices if you use WPA_PSK. (PSK=Pre-Shared Key)
If YaST doesn't like it, maybe a case issue for the letters a-d, then you could try editing /etc/sysconfig/network/ifcfg-<interface> (<interface> might be wlan0, or different in your case) manually.
Enter the key in the line:
WIRELESS_WPA_PSK='<insert key here>'

The first time I did this, I had to enter it manually, and the encryption kicked in as soon as I reset the network for wlan0. If you have a linksys router, you can configure it in your browser. By default at 192.168.1.1, with a default password of "admin". This would allow you to also select wpa-psk here, and paste in the same Hexadecimal key.

Last edited by jschiwal; 03-12-2006 at 02:26 AM.
 
Old 03-12-2006, 10:10 AM   #5
Saketh
Member
 
Registered: Jun 2005
Posts: 62

Original Poster
Rep: Reputation: 15
I'm using open WEP encryption, so I already have a key. I entered it all in upper-case; is that correct?

I did the following steps in order to install the wlan0 interface under ndiswrapper:
Quote:
% ndiswrapper -i WUSB54G.inf
% ndiswrapper -l
wusb54g driver present, hardware present
% modprobe ndiswrapper
However, the wlan0 interface is not shown when I use iwconfig.

Last edited by Saketh; 03-12-2006 at 10:12 AM.
 
Old 03-12-2006, 01:45 PM   #6
Saketh
Member
 
Registered: Jun 2005
Posts: 62

Original Poster
Rep: Reputation: 15
Here's the rundown of what I tried:
Quote:
presario:/home/saketh/Desktop/WUSB54Gv1 # ndiswrapper -i WUSB54G.inf
Installing wusb54g
presario:/home/saketh/Desktop/WUSB54Gv1 # ndiswrapper -l
Installed ndis drivers:
wusb54g driver present, hardware present
presario:/home/saketh/Desktop/WUSB54Gv1 # modprobe ndiswrapper
presario:/home/saketh/Desktop/WUSB54Gv1 # iwconfig wlan0 mode Managed

Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; No such device.
presario:/home/saketh/Desktop/WUSB54Gv1 # dmesg
p80211: module not supported by Novell, setting U taint flag.
prism2_usb: module not supported by Novell, setting U taint flag.
prism2usb_init: prism2_usb.o: 0.2.2 Loaded
prism2usb_init: dev_info is: prism2_usb
usbcore: registered new driver prism2_usb
eth0: link down
eth0: no IPv6 routers present
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
usbcore: deregistering driver prism2_usb
prism2_usb.o: 0.2.2 Unloaded
p80211.o: 0.2.2 Unloaded
ndiswrapper: module not supported by Novell, setting U taint flag.
ndiswrapper version 1.2 loaded (preempt=no,smp=yes)
ndiswrapper: driver wusb54g (The Cisco-Linksys, LLC.,01/12/2004, 1.0.8.0) loaded
ndiswrapper (NdisWriteErrorLogEntry:314): log: C000138A, count: 3 (c0000001), return address: f8f97fcb
ndiswrapper (ndiswrapper_add_usb_device:363): Windows driver couldn't initialize the device (C0010006)
ndiswrapper: probe of 5-3:1.0 failed with error -22
usbcore: registered new driver ndiswrapper
usbcore: deregistering driver ndiswrapper
ndiswrapper: module not supported by Novell, setting U taint flag.
ndiswrapper version 1.2 loaded (preempt=no,smp=yes)
ndiswrapper: driver wusb54g (The Cisco-Linksys, LLC.,01/12/2004, 1.0.8.0) loaded
ndiswrapper (NdisWriteErrorLogEntry:314): log: C000138A, count: 3 (c0000001), return address: f8f97fcb
ndiswrapper (ndiswrapper_add_usb_device:363): Windows driver couldn't initialize the device (C0010006)
ndiswrapper: probe of 5-3:1.0 failed with error -22
usbcore: registered new driver ndiswrapper
presario:/home/saketh/Desktop/WUSB54Gv1 # lsusb
Bus 005 Device 002: ID 1915:2234
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
presario:/home/saketh/Desktop/WUSB54Gv1 # cat /etc/sysconfig/network/ifcfg-wlan0
BOOTPROTO='dhcp'
BROADCAST=''
IPADDR=''
MTU=''
NAME='Ethernet Network Card'
NETMASK=''
NETWORK=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
WIRELESS_AP='00:0f:66:71:54:70'
WIRELESS_AUTH_MODE='open'
WIRELESS_BITRATE='auto'
WIRELESS_CA_CERT=''
WIRELESS_CHANNEL=''
WIRELESS_CLIENT_CERT=''
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='avighnamastu'
WIRELESS_FREQUENCY=''
WIRELESS_KEY=''
WIRELESS_KEY_0='3520D8ADB3428FE28404FF7BE7'
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_IDENTITY=''
WIRELESS_WPA_PASSWORD=''
WIRELESS_WPA_PSK=''
_nm_name='static-0'
The problem lies between modprobe ndiswrapper and iwconfig wlan0. For some reason, ndiswrapper is not working, although I'm using drivers that worked on Ubuntu.

Please help - this problem is extremely annoying!
 
Old 03-12-2006, 08:11 PM   #7
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Now that you have posted your WEP key, be sure to replace it. Why are you using WEP? Unless you have a device that doesn't support it, you should use WPA instead. WEP is broken, and there are tools that can crack wep in 30 minutes.

In your ndiswrapper setup you forgot to run "ndiswrapper -m" to save the module alias. You could also run as root "depmod -a" and "ldconfig". Sometimes and installation doesn't go through all of the way for some reason and these aren't run.

Make sure that ndiswrapper shows up in "lsmod". If the ndiswrapper kernel module doesn't load, then iwconfig won't work.

This part from your post looks odd: ndiswrapper version 1.2 loaded (preempt=no,smp=yes)
Do you have a multi-processors? Other errors were indicated as well. Where did you get this ndiswrapper from?

I build mine from source. I cheated a bit. The tarball contains a .spec file. So I copied the ndiswrapper tarball to /usr/src/packages/SOURCES/ and extracted the ndiswrapper.spec file to /usr/src/packages/SPECS/. Then I used "rpmbuild" to make an RPM packages (actually two of them) and used the rpm command to install them.

Also double check that your windows driver is the correct one. For example, a 64 bit version is distinct from the 32 bit version.
 
Old 03-12-2006, 08:40 PM   #8
Saketh
Member
 
Registered: Jun 2005
Posts: 62

Original Poster
Rep: Reputation: 15
I got the ndiswrapper off the SUSE repositories. I probably should compile my own.

I am also disturbed by the strangeness of the errors. That's why I'm asking for help. I have a single processor.

Also, that's not my real WEP key.

Thanks for the assitance!
 
Old 03-17-2006, 09:56 AM   #9
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
From you previous post, you didn't run "ndiswrapper -m". Also, from the error messages, please double check that the windows ndis driver is the correct one.
 
Old 03-17-2006, 03:41 PM   #10
Saketh
Member
 
Registered: Jun 2005
Posts: 62

Original Poster
Rep: Reputation: 15
I ran ndiswrapper -m, but I forgot to copy that and put it in the post above.

The exact same driver worked under Ubuntu 5.04, so it should work under SUSE 10.0 OSS, unless I am horribly mistaken.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Networking Issue with openSUSE 10 and Dell Inspiron 9300 krjhitch Linux - Networking 2 10-25-2005 06:48 AM
Trouble getting X working + networking troubles outwardlymobile Linux - Hardware 2 10-17-2004 11:58 AM
APT-GET troubles - networking? MTU? blietaer Linux - Hardware 1 01-06-2004 12:29 PM
Networking Troubles: Can't ping windows computers phishead Linux - Networking 3 04-05-2003 04:08 PM
Networking troubles... dave_lane Linux - Networking 2 09-08-2001 07:52 PM


All times are GMT -5. The time now is 06:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration