LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-18-2008, 04:38 PM   #16
thecourtenayboy
LQ Newbie
 
Registered: Sep 2008
Location: Hemel Hempstead
Distribution: openSUSE 11
Posts: 13

Original Poster
Rep: Reputation: 0
Question


Would you still recommend running the following command?

dd if=/dev/zero of=/dev/hda bs=446 count=1

Would 'hda' not need changing to 'sda1'?
 
Old 09-18-2008, 06:46 PM   #17
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,115

Rep: Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817
If you are able to run fdisk -l, can you access the /boot/grub/menu.lst file. You should see an entry for windows, is there is none there should be one which states:

title windows
rootnoverify (hd0,0)
chainloader +1

Your fdisk output shows windows on first partition of first drive.
The command in your last post which I suggested earlier is to write over the master boot record. You said your windows CD couldn't do anything and this might help. If you have a windows install/recovery CD to recover your windows mbr the command would be an option. Yes, it would need to be changed to sda, not sda1.

If you can get the above entry into menu.lst, it should work.

Last edited by yancek; 09-18-2008 at 06:48 PM.
 
Old 09-20-2008, 04:59 PM   #18
thecourtenayboy
LQ Newbie
 
Registered: Sep 2008
Location: Hemel Hempstead
Distribution: openSUSE 11
Posts: 13

Original Poster
Rep: Reputation: 0
Right, I played around trying to fix the problem but I ended up taking a slightly different route. As I hadn't used my SUSE installation much I decided that it would be a good idea to wipe the drive clean and install a fresh copy of WinXP on the drive instead. I then used EBCD to copy over all the files I needed from my damaged drive to the drive with the new WinXP installation. After that I put SUSE onto the drive that originally had WinXp on it. Both of these drives are SATA drives, and I also have a 3rd drive for file storage which is IDE.

My latest problem is that the PC won't boot unless I boot from the SUSE installation DVD which lets me boot from HDD, and I am then presented with GRUB, which contains entries for my SUSE and WinXP installation, and they both work fine.

As the IDE drive is the Channel 1 Master, I'm guessing that it needs to contain the boot loader, would this be the case?

When the system fails to boot without the SUSE installation DVD, it simply hangs with the message: Boot from CD...

Rather than go round in circles and do damage to a drive like I did before it would be great to get some advice on what to do next. Should be a much easier problem to fix than before anyway!
 
Old 09-20-2008, 05:13 PM   #19
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,115

Rep: Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817
It would probably be simpler (if you want to use Grub) to install Grub stage1 to the mbr of the SATA drive on which you have Opensuse and set that as first boot device. If you can't do that or, if you want to boot from the IDE that is a data drive only, you will need the stage1 file in the mbr of the IDE drive. If you are not sure how to do this, post the current results of the 'fdisk -l' command as well as the /boot/grub/menu.lst file.

When it stalls with 'boot from CD', I assume you have NO CD in the drive?

When you installed
 
Old 09-20-2008, 05:55 PM   #20
thecourtenayboy
LQ Newbie
 
Registered: Sep 2008
Location: Hemel Hempstead
Distribution: openSUSE 11
Posts: 13

Original Poster
Rep: Reputation: 0
Here are the results of fdisk -l:


Disk /dev/sda: 164.6 GB, 164696555520 bytes
255 heads, 63 sectors/track, 20023 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000e5ab9

Device Boot Start End Blocks Id System
/dev/sda1 1 262 2104483+ 82 Linux swap / Solaris
/dev/sda2 263 2873 20972857+ 83 Linux
/dev/sda3 2874 20023 137757375 83 Linux

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x145eddaf

Device Boot Start End Blocks Id System
/dev/sdb1 1 19456 156280288+ 7 HPFS/NTFS

Disk /dev/sdc: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x8b53e835

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 24321 195358401 7 HPFS/NTFS

--------------------------------------------------


I've tried getting the BIOS to boot the drive with SUSE on it, and the WinXP drive, but neither will boot. GRUB does seem to be installed on the SUSE drive though. Yes, I only get these booting problems when I boot with no CD/DVD. I can access both WinXP & SUSE with the SUSE DVD.

Here's the contents of the menu.lst:


# Modified by YaST2. Last modification on Sat Sep 20 22:14:55 BST 2008
default 0
timeout 8
gfxmenu (hd1,1)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.0 - 2.6.25.16-0.1
root (hd1,1)
kernel /boot/vmlinuz-2.6.25.16-0.1-default root=/dev/disk/by-id/scsi-SATA_HDS722516VLSA80_VNRD3EC4CE8L8M-part2 resume=/dev/sda1 splash=silent showopts vga=0x31a
initrd /boot/initrd-2.6.25.16-0.1-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.0 - 2.6.25.16-0.1
root (hd1,1)
kernel /boot/vmlinuz-2.6.25.16-0.1-default root=/dev/disk/by-id/scsi-SATA_HDS722516VLSA80_VNRD3EC4CE8L8M-part2 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe vga=0x31a
initrd /boot/initrd-2.6.25.16-0.1-default

###Don't change this comment - YaST2 identifier: Original name: linux-2.6.25.5-1.1-pae###
title openSUSE 11.0 - 2.6.25.5-1.1
root (hd1,1)
kernel /boot/vmlinuz-2.6.25.5-1.1-pae root=/dev/disk/by-id/scsi-SATA_HDS722516VLSA80_VNRD3EC4CE8L8M-part2 resume=/dev/sda1 splash=silent showopts vga=0x31a
initrd /boot/initrd-2.6.25.5-1.1-pae

###Don't change this comment - YaST2 identifier: Original name: failsafe-2.6.25.5-1.1-pae###
title Failsafe -- openSUSE 11.0 - 2.6.25.5-1.1
root (hd1,1)
kernel /boot/vmlinuz-2.6.25.5-1.1-pae root=/dev/disk/by-id/scsi-SATA_HDS722516VLSA80_VNRD3EC4CE8L8M-part2 showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe vga=0x31a
initrd /boot/initrd-2.6.25.5-1.1-pae

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
rootnoverify (hd1,1)
chainloader (hd2,0)+1

###Don't change this comment - YaST2 identifier: Original name: windows 2###
title windows 2
rootnoverify (hd1,1)
chainloader (hd0,0)+1
--------------------------------------------------


I was a bit confused as to why there are two entries for SUSE (not including the two failsafe entries). Would I be right in thinking that the extra entry has been added since updates to the system were made online via auto-update? If so, does that mean that openSUSE 11.0 - 2.6.25.16-0.1 is newer than openSUSE 11.0 - 2.6.25.5-1.1?
 
Old 09-21-2008, 08:19 AM   #21
thecourtenayboy
LQ Newbie
 
Registered: Sep 2008
Location: Hemel Hempstead
Distribution: openSUSE 11
Posts: 13

Original Poster
Rep: Reputation: 0
I have just tried using SuperGrub Disk and I'm a bit closer to resolving this issue. However, more queries have come into play!

If I manually select the drive with GRUB on it on each boot then I can get into both WinXP and Linux. However, now when I go into Linux I can't do that much. If I click on the Start icon in the bottom left nothing happens, and when I click the icon in the tray that says that updates are available the window appear in the task bar but never maximises.

Also, the entries in GRUB have changed again, now I've got:

openSUSE 11.0 - 2.6.25.16-0.1 & openSUSE 11.0 - 2.6.25.16-0.1-pae

Both seem to have the same problem, tho I havent tried the failsafe options yet. Why are there two different boot options tho?
 
Old 09-21-2008, 08:57 AM   #22
thecourtenayboy
LQ Newbie
 
Registered: Sep 2008
Location: Hemel Hempstead
Distribution: openSUSE 11
Posts: 13

Original Poster
Rep: Reputation: 0
Have just installed Gnome and now all appears to be fine with regards to SUSE working, and I think I prefer it to KDE4 anyway.

Just the small issue of getting GRUB to auto launch now, rather than having to manually select the right drive to boot each time. Strange, because it should be booting that drive automatically anyway...
 
Old 09-21-2008, 09:45 AM   #23
Unknown_User
Member
 
Registered: Jan 2003
Location: EU (UK)
Distribution: Ubuntu 10.x, Fedora 9, OpenSuSE 11.3, Mythbuntu (Don't know it? Try - it rocks!)
Posts: 225

Rep: Reputation: 30
Excellent.

Great feeling when you crack it eh?
 
Old 09-21-2008, 11:05 AM   #24
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,115

Rep: Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817Reputation: 817
Your post #20 output of fdisk shows two Linux partitions, on sda2 and sda3. Assuming sda2 is the root partition (w//boot/grub) your entry in menu.lst should be root (hd0,1) and your entry is (hd1,1). Your fdisk output for windows shows partitions on sdb1 (not active/bootable) and sdc1 (marked active/bootable). Assume that sdc1 is the windows partition with bootlader, your entry in menu.lst should be rootnoverify (hd2,0). You don't need this before the chainloader entry, just put chainloader +1. It's hard to tell but, it looks like there is no space after chainloader, before +1 which is necessary.

The kernel entries for Opensuse, you can look in the /boot directory and see if you have vmlinuz files with those numbers. Most likely, when you did updates, you had a kernel update and that's why the change. It adds a new kernel (vmlinuz file) and you might need to make a manual change in menu.lst after that.
 
Old 09-24-2008, 07:23 AM   #25
thecourtenayboy
LQ Newbie
 
Registered: Sep 2008
Location: Hemel Hempstead
Distribution: openSUSE 11
Posts: 13

Original Poster
Rep: Reputation: 0
Talking

I got it working in the end guys. Toyed around with GAG bootloader and then discovered what my problem was...very embarrasing...but it turned out to be the boot order in the BIOS. Although, to be fair that wasn't the original problem so I don't feel like a total idiot, and I've learnt a few bits about Linux throughout this whole episode so it's been very worthwhile.

Once I get Photoshop and Newsleecher running in SUSE then I'll be kissing Windows goodbye hopefully! Especially once I get my Linux+ cert. =)
 
  


Reply

Tags
boot, dual, grub, menulst, xp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual Boot WinXP & Mandrake 10 darkjedi8359 Mandriva 7 01-15-2005 08:04 AM
Time issues in dual boot WinXP / Fedora laptop mrmcctt Linux - Software 2 11-01-2004 09:14 AM
FC1 & WinXP (Dual boot) Alkalined Linux - Newbie 3 10-29-2004 09:48 PM
dual boot with redhat9&winXP scarabs Linux - Newbie 6 03-20-2004 04:30 PM
vmware Slack (Host)/WinXP - dual-boot issues gearsmithy Linux - Software 0 01-28-2004 11:42 AM


All times are GMT -5. The time now is 04:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration