LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-14-2004, 11:29 PM   #1
nmoog
Member
 
Registered: Sep 2003
Location: Sydney
Distribution: Debian
Posts: 70

Rep: Reputation: 15
Opening port 80


Ive been searching these forums, and found heaps on closing ports, but not much on opening them.

Im running slackware 9.1 and nmap shows my http port as:
PORT STATE SERVICE
80/tcp filtered http

How can I open it?

THanks!
 
Old 01-14-2004, 11:32 PM   #2
chrisk5527
Member
 
Registered: Oct 2002
Location: Michigan
Distribution: Slackware Linux 10.0
Posts: 289

Rep: Reputation: 30
A firewall could be your problem. This firewall would be running locally on your machine, or your ISP is blocking certain ports. I know that my ISP (Charter) was blocking 21, 25, 80 and maybe other ones. So what I had to do, is go into inetd.conf or the appropriate configuration file and bind the program to a different port. If your using Apache as your web server, you would have to make the appropriate changes in httpd.conf. I changed my FTP port to 24 and my HTTP port to 81. Good Luck.
 
Old 01-17-2004, 08:29 AM   #3
nmoog
Member
 
Registered: Sep 2003
Location: Sydney
Distribution: Debian
Posts: 70

Original Poster
Rep: Reputation: 15
Running the server of a different port works... but I dont know what port 80 wont work. I emailed my ISP and they said they dont block any ports.

I am running slackware 9.1 - my iptables list shows I have no rules at all.... Is there anywhere else that might be influencing open ports?
 
Old 02-01-2004, 05:47 AM   #4
opioid
Member
 
Registered: Jul 2003
Location: Chicago
Distribution: Ubuntu
Posts: 124

Rep: Reputation: 15
Make a hole in your firewall to make your web server visible to others.

#iptables -I INPUT 1 -p tcp --dport 80 -j ACCEPT
#iptables-save > /etc/sysconfig/iptables

Check your ip number:
#/sbin/ifconfig

#mozilla http://localhost/

Voila!
 
Old 02-01-2004, 05:00 PM   #5
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I think its disabled in the services file. It might be tcpwrappers or xinetd do not know what service to load up for port 80.

You should use port 8080 because web browsers default to either 80 or 8080. If you change the port make sure you specify a colon and the port number at the end of the address.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
shorewall -- opening a port netpacket Linux - Security 1 09-18-2005 11:17 PM
Opening Port steve007 Linux - Newbie 5 07-23-2005 02:05 PM
opening a port Robin01 Linux - General 3 11-17-2004 11:40 PM
Opening a Port gpamkenny Linux - Networking 3 11-04-2004 03:51 PM
6881 Port Opening? Bana Linux - Networking 1 02-16-2004 08:34 PM


All times are GMT -5. The time now is 09:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration