LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-14-2005, 10:25 AM   #1
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Rep: Reputation: 30
OpenGL works 3D accelleration doesn't


I have cedega (and point2play), and when i ran the system tests, it said that 3D acceleration failed (and sound, but I am working on that), but It displayed the glxgears like it is supposed to. I was running steam on cedega, and all hl1 games run (without a hitch), but when i tried to start up CSS i didn't get any errors accept (sound being used by another app, cancel to run HL with no sound or retry), so I pressed cancel, then it just sat at a black screen for a few miniutes, it wasnt completly frozen, I could move the mouse, but no CSS start screen. I think it might have something to do with my computer failing the 3D acceleration test (and when i started to download (i.e double click on play menu when i didn't have it yet) CSS it said unknown video card). I am sitting with my XORG config doc open, is there something there I have to change.
 
Old 06-14-2005, 10:38 AM   #2
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Original Poster
Rep: Reputation: 30
oh and only more thing, how do you end all the sound server processes (that will help when I get my sound working).
 
Old 06-14-2005, 10:52 AM   #3
naimslim89
Member
 
Registered: Mar 2005
Location: London, United Kingdom
Distribution: Fedora Core 5
Posts: 83

Rep: Reputation: 15
Quote:
Originally posted by lowpingnoob
oh and only more thing, how do you end all the sound server processes (that will help when I get my sound working).
Under GNOME, do killall esd

Under KDE, do killall arts

That should solve the sound problem, not sure about the other problem though...
 
Old 06-14-2005, 10:52 AM   #4
slackwarebilly
Member
 
Registered: Jun 2005
Distribution: !<:Slackware:>!
Posts: 99

Rep: Reputation: 15
Question what's your video card?

Tell us your video card and window manager (KDE, Gnome, IceWM etc.) Then we can help you. If you installed your drivers from ATI or NVIDIA or whatever properly, you are right about changing your config file. If its xorg you should be able to use the "replace" command in Kwrite or whatever editor your using. (tell us what distro you have too). Vesa is the "generic" video driver in linux. Your card has the proper drivers, but your computer cannot use the accellerration of the card until you modify the config. In the "replace" dialog box (usually in the "edit" menu) type "vesa" and choose to replace it with "nvidia", "ati", or whatever. Do it again, except with caps. "VESA" >replace> "NVIDIA" .

NOTE: do not type the quotes!!! ("") they are there for you to know when to start and stop. If you type the quotes while doing the replace, you may get bad results.

Remember to save the config file. And reboot. It would be a good idea to repost one more time with more info before changing your config.

Best of luck!!! have fun with Cedega!!!!

slackwarebilly
 
Old 06-14-2005, 11:23 AM   #5
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Original Poster
Rep: Reputation: 30
Re: what's your video card?

Quote:
Originally posted by slackwarebilly
Tell us your video card and window manager (KDE, Gnome, IceWM etc.) Then we can help you. If you installed your drivers from ATI or NVIDIA or whatever properly, you are right about changing your config file. If its xorg you should be able to use the "replace" command in Kwrite or whatever editor your using. (tell us what distro you have too). Vesa is the "generic" video driver in linux. Your card has the proper drivers, but your computer cannot use the accellerration of the card until you modify the config. In the "replace" dialog box (usually in the "edit" menu) type "vesa" and choose to replace it with "nvidia", "ati", or whatever. Do it again, except with caps. "VESA" >replace> "NVIDIA" .

NOTE: do not type the quotes!!! ("") they are there for you to know when to start and stop. If you type the quotes while doing the replace, you may get bad results.

Remember to save the config file. And reboot. It would be a good idea to repost one more time with more info before changing your config.

Best of luck!!! have fun with Cedega!!!!

slackwarebilly
Nvidia Geforce MX 400 64 MB Gnome (newest version)
 
Old 06-14-2005, 11:27 AM   #6
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Original Poster
Rep: Reputation: 30
uh, i already replaced nv with nvidia (in the xorg.conf), and that gives me OpenGL (i already had it with Amer. Army and UT2K4 running flawlessly), DOD and such run perfect, the best $15 i ever spent (as soon as I get CSS and HL2 running). What do I need to do to get 3d acceleration running right?
 
Old 06-14-2005, 11:28 AM   #7
slackwarebilly
Member
 
Registered: Jun 2005
Distribution: !<:Slackware:>!
Posts: 99

Rep: Reputation: 15
Thumbs up Sweet!!!

I have the an extremely similar video card. As long as you have gotten the drivers from NVIDIA and installed them properly, you should be able to continue with changing the xorg conf. If you need help getting the drivers to install or where to find them, just post back...

See you later... and good luck

slackwarebilly ><>
 
Old 06-14-2005, 11:30 AM   #8
slackwarebilly
Member
 
Registered: Jun 2005
Distribution: !<:Slackware:>!
Posts: 99

Rep: Reputation: 15
Wink OOPS!

Always remember when installing drivers the for a video card the X server has to be totally not on, zero zip, that's right kids (dah-du-dun) a Konsole session!!!

Anywho just thought I'd let you know

slackwarebilly
 
Old 06-14-2005, 11:31 AM   #9
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by lowpingnoob
uh, i already replaced nv with nvidia (in the xorg.conf), and that gives me OpenGL (i already had it with Amer. Army and UT2K4 running flawlessly), DOD and such run perfect, the best $15 i ever spent (as soon as I get CSS and HL2 running). What do I need to do to get 3d acceleration running right?
no where does it say vesa in the xorg.conf here look at it:

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell D1226H"
DisplaySize 340 250
HorizSync 30.0 - 95.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 4 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 06-14-2005, 11:32 AM   #10
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Original Poster
Rep: Reputation: 30
Re: OOPS!

Quote:
Originally posted by slackwarebilly
Always remember when installing drivers the for a video card the X server has to be totally not on, zero zip, that's right kids (dah-du-dun) a Konsole session!!!

Anywho just thought I'd let you know

slackwarebilly
i knew that, i have done the install, OpenGL works right, just not 3D acceleration...(for Cedega)
 
Old 06-14-2005, 11:34 AM   #11
slackwarebilly
Member
 
Registered: Jun 2005
Distribution: !<:Slackware:>!
Posts: 99

Rep: Reputation: 15
Question Did you remember?

Did you remember to also do the upper case VESA and NVIDIA replace? Does "nvidia" and a logo show on your screen when you startup?

Also did you replace "vesa" (lower case) with "nvidia"?

do 'em all.. post back..later

slackwarebilly
 
Old 06-14-2005, 11:37 AM   #12
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Original Poster
Rep: Reputation: 30
Re: Did you remember?

Quote:
Originally posted by slackwarebilly
Did you remember to also do the upper case VESA and NVIDIA replace? Does "nvidia" and a logo show on your screen when you startup?

Also did you replace "vesa" (lower case) with "nvidia"?

do 'em all.. post back..later

slackwarebilly
sorry for not posting back ... later. Look at my Xorg. conf (2-3 posts up), it doesn't say vesa anywhere. It said "nv" and you replace THAT with "nvidia"
 
Old 06-14-2005, 11:37 AM   #13
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Original Poster
Rep: Reputation: 30
and yes I do have the splash screen...
 
Old 06-14-2005, 12:06 PM   #14
slackwarebilly
Member
 
Registered: Jun 2005
Distribution: !<:Slackware:>!
Posts: 99

Rep: Reputation: 15
Unhappy sorry

Sorry, so used to slackware. You may need to change some other stuff. What distro was it again?

Anywho, the monitor, device, and screen sections are the important parts.

You name the device, as you have nvidia, then point the server to use that driver.

Try changing the "videocard0" to "nvidia", but be careful, i'm going to talk to some of my smarter friends about this one. The name of your distribution and version would help. Thx.

slackwarebilly
 
Old 06-14-2005, 01:10 PM   #15
lowpingnoob
Member
 
Registered: Jun 2005
Distribution: Fedora Core 3, soon DSL (DSL backwards is LSD hahahaha)
Posts: 245

Original Poster
Rep: Reputation: 30
Re: sorry

Quote:
Originally posted by slackwarebilly
Sorry, so used to slackware. You may need to change some other stuff. What distro was it again?

Anywho, the monitor, device, and screen sections are the important parts.

You name the device, as you have nvidia, then point the server to use that driver.

Try changing the "videocard0" to "nvidia", but be careful, i'm going to talk to some of my smarter friends about this one. The name of your distribution and version would help. Thx.

slackwarebilly
fedora core 3
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
3d accelleration fail after a while kimothy Linux - Laptop and Netbook 2 08-19-2005 02:42 PM
Suse 9.2 3d accelleration Cryptix SUSE / openSUSE 10 01-29-2005 01:08 AM
3d accelleration [ITA]freeware Linux - Software 3 09-14-2004 06:53 AM
OpenGL Architecture - How it all Works? swinchen Programming 7 05-14-2004 08:23 AM
OpenGL problem, works for root, not users Dusan Linux - Hardware 4 06-22-2003 07:20 AM


All times are GMT -5. The time now is 10:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration