LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-26-2006, 03:21 AM   #1
Tatzel
LQ Newbie
 
Registered: Jan 2006
Distribution: FC4
Posts: 7

Rep: Reputation: 0
Opengl for cedega/ATI?


Hey there,

New to Linux and this forum, so go easy on me..

I installed Fedora core 4 and am now trying to get World of Warcraft to run on Cedega. I installed Cedega without problems, but Cedega tells me my opengl and 3d acceleration are not up to par yet. I installed the latest ATI-drivers for my Radeon 9600, but when i check my glfx-config i see that i still have the mesa-opengl running. how do i change that so that my ATI-drivers kick in and cedega can run the opengl-tests properly?

mind you: I'm getting the hang of linux slowly, but i'm still a noob so explain like you would to a 6 year-old...

thx, Tatz.
 
Old 01-26-2006, 06:41 AM   #2
BinJajer
Member
 
Registered: Sep 2005
Location: Warsaw, Poland
Distribution: Slackware 10.2, Caldera OpenLinux 3.1, Corel Linux (Thanks xhi!), Debian GNU/HURD etc...
Posts: 296
Blog Entries: 1

Rep: Reputation: 30
First of all, hello and welcome to LinuxQuestions. Relax, this is a help forum so no one is going to get mad at you for posting anything.

As for your problem, could you post me 3 things? I need the effect of uname -a (type it in your console), your whole xorg.conf (in /etc/X11/xorg.conf) and your card model. You can also check if you did everything alright, right here: http://gentoo-wiki.com/HOWTO_ATI_Drivers
This is Gentoo documentation, but the part about xorg.conf warks for all distros.

Cheers
BinJajer

Oh, don't worry, everyone was a newbie once!

Edit: uname -a not necessary. You Have FC4. Good that you posted this in your profile. Not many newbies do.

Last edited by BinJajer; 01-26-2006 at 06:47 AM.
 
Old 01-26-2006, 08:55 AM   #3
Tatzel
LQ Newbie
 
Registered: Jan 2006
Distribution: FC4
Posts: 7

Original Poster
Rep: Reputation: 0
okay, my videocard is a Radeon 9600.

my xorg.conf is as follows:

Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "aticonfig Screen 0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "AX3818UTC"
	DisplaySize  310	230
	HorizSync    31.0 - 60.0
	VertRefresh  56.0 - 75.0
	Option	    "dpms"
EndSection

Section "Monitor"
	Identifier   "aticonfig Monitor 0"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
	VendorName  "Videocard vendor"
	BoardName   "ATI Radeon 9600"
EndSection

Section "Device"
	Identifier  "ATI Graphics Adapter 0"
	Driver      "fglrx"
	Option	    "(null)"
	Option	    "VideoOverlay" "off"
	Option	    "OpenGLOverlay" "on"
	BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Screen"
	Identifier "aticonfig Screen 0"
	Device     "ATI Graphics Adapter 0"
	Monitor    "aticonfig Monitor 0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
 
Old 01-26-2006, 10:25 AM   #4
linuxbotx
Member
 
Registered: Oct 2003
Location: USA
Distribution: Fedora Core 4
Posts: 247

Rep: Reputation: 30
Ok, you have multiple devices. Change your devices section as follows:

Section "Device"
Identifier "Videocard0"
Driver "radeon"
VendorName "Videocard vendor"
BoardName "ATI Radeon 9600"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
Option "(null)"
Option "VideoOverlay" "off"
Option "OpenGLOverlay" "on"
BusID "PCI:1:0:0"
EndSection

Change the above to:

#Section "Device"
# Identifier "Videocard0"
# Driver "radeon"
# VendorName "Videocard vendor"
# BoardName "ATI Radeon 9600"
#EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
Option "(null)"
Option "VideoOverlay" "off"
Option "OpenGLOverlay" "on"
BusID "PCI:1:0:0"
VendorName "Videocard vendor"
BoardName "ATI Radeon 9600"
EndSection


Does that fix your problem? You'll need to restart X. ALT+CTL+BACKSPACE
 
Old 01-26-2006, 10:49 AM   #5
Tatzel
LQ Newbie
 
Registered: Jan 2006
Distribution: FC4
Posts: 7

Original Poster
Rep: Reputation: 0
how do i edit xorg.conf? its a read-only file.
 
Old 01-26-2006, 10:50 AM   #6
BinJajer
Member
 
Registered: Sep 2005
Location: Warsaw, Poland
Distribution: Slackware 10.2, Caldera OpenLinux 3.1, Corel Linux (Thanks xhi!), Debian GNU/HURD etc...
Posts: 296
Blog Entries: 1

Rep: Reputation: 30
login as root, go to it's dir, chmod 777 xorg.conf and edit.
 
Old 01-26-2006, 10:55 AM   #7
Tatzel
LQ Newbie
 
Registered: Jan 2006
Distribution: FC4
Posts: 7

Original Poster
Rep: Reputation: 0
okay i can edit it now when i drag the file to the terminal, but i cant save the file then...

Last edited by Tatzel; 01-26-2006 at 11:12 AM.
 
Old 01-26-2006, 11:49 AM   #8
Tatzel
LQ Newbie
 
Registered: Jan 2006
Distribution: FC4
Posts: 7

Original Poster
Rep: Reputation: 0
okay, i was being silly here.

i changed the settings logged in as root, and restarted X, but that gave me an error about the videocard vendor not being defined. it ran a couple of tests and reconfigured xorg.conf.
it changed a bit:
Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "AX3818UTC"
	DisplaySize  310	230
	HorizSync    31.0 - 60.0
	VertRefresh  56.0 - 75.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
	VendorName  "Videocard vendor"
	BoardName   "ATI Radeon 9600"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1280x960" "1280x800" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection
the opengl-tests from cedega still fail
 
Old 01-26-2006, 01:02 PM   #9
Tatzel
LQ Newbie
 
Registered: Jan 2006
Distribution: FC4
Posts: 7

Original Poster
Rep: Reputation: 0
anyone know how to handle this? i tried changing that again, but X wont load on it.
 
Old 01-28-2006, 04:52 AM   #10
Tatzel
LQ Newbie
 
Registered: Jan 2006
Distribution: FC4
Posts: 7

Original Poster
Rep: Reputation: 0
okay, i managed to change my driver from Radeon to fglrx, but my opengl-test still fails in Cedega. anyone that can advise me on what to do?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cedega : OpenGL yes 3D accel. no lowpingnoob Linux - Games 4 06-15-2005 12:28 AM
ati 3d with cedega ylts SUSE / openSUSE 17 05-04-2005 06:13 PM
Cedega 4.2 and ATI support for 3D games? Lleb_KCir Linux - Software 3 01-06-2005 12:18 PM
Overwrite Mesa OpenGL with ATI OpenGL Carl-Fredrik Slackware 12 10-01-2004 03:33 PM
Changing from MESA OpenGL to ATI OpenGL tillyoubreakit Linux - Hardware 19 10-07-2003 07:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration