LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-16-2015, 04:27 PM   #1
razvaneluu
LQ Newbie
 
Registered: Jun 2015
Posts: 8

Rep: Reputation: Disabled
Open Port 5500


Hello . I whant to open port 5500 for a torrent tracker... When i try to seed a torrent my utorrent say No connection Target refused...something.

I try to check on open ports website ... Port 5500 closed

How to open ?
 
Old 06-16-2015, 04:44 PM   #2
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,398

Rep: Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017
You need to open it in any firewall that's between you and the world. That means your router needs the port opened and a port forwarding rule to your server, your server's firewall needs the port opened, and any other NATs or firewalls need the port opened and/or port forwarding rules set up.
 
1 members found this post helpful.
Old 06-16-2015, 04:49 PM   #3
razvaneluu
LQ Newbie
 
Registered: Jun 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
Its an ubuntu server...i dont think there is a router...how and i dont installed any firewall...how i can check if there is a router and how to open and forward port?
 
Old 06-16-2015, 04:53 PM   #4
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,398

Rep: Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017
I believe Ubuntu uses iptables, you'll need to add a rule to let that traffic through.

If you run "ifconfig", does the IP address listed for your network adapter match the one displayed on www.whatismyip.com ? If not, then you have a router doing NAT, possibly built into your ISP's modem. You'll have to consult the documentation for your router to see about opening ports in the firewall and adding a port forwarding rule.
 
1 members found this post helpful.
Old 06-16-2015, 05:20 PM   #5
razvaneluu
LQ Newbie
 
Registered: Jun 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
How to enter to that site if i dont have desktop...i use console
 
Old 06-16-2015, 05:29 PM   #6
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,398

Rep: Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017
Lots of ways to check your public IP from the command line, here are a couple:
Code:
wget -q -O - http://ipecho.net/plain; echo
curl -s checkip.dyndns.org | sed -e 's/.*Current IP Address: //' -e 's/<.*$//'
 
2 members found this post helpful.
Old 06-17-2015, 10:05 AM   #7
razvaneluu
LQ Newbie
 
Registered: Jun 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
root@server:~# wget -q -O - http://ipecho.net/plain; echo
176.223.XXX.x
root@server:~# curl -s checkip.dyndns.org | sed -e 's/.*Current IP Address: //' -e 's/<.*$//'
176.223.XXX.X
root@server:~#

Last edited by razvaneluu; 06-17-2015 at 10:27 AM.
 
Old 06-17-2015, 10:11 AM   #8
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,398

Rep: Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017
As I said before:

Quote:
Originally Posted by suicidaleggroll View Post
If you run "ifconfig", does the IP address listed for your network adapter match the one displayed on www.whatismyip.com ? If not, then you have a router doing NAT, possibly built into your ISP's modem. You'll have to consult the documentation for your router to see about opening ports in the firewall and adding a port forwarding rule.
You've posted your public IP (not a great idea, you should edit your post to remove it), but you haven't posted your private IP, so you still haven't answered the question.
 
Old 06-17-2015, 10:22 AM   #9
Keith Hedger
Senior Member
 
Registered: Jun 2010
Location: Wiltshire, UK
Distribution: Linux From Scratch, Slackware64, Partedmagic
Posts: 2,314

Rep: Reputation: 568Reputation: 568Reputation: 568Reputation: 568Reputation: 568Reputation: 568
Quote:
Originally Posted by suicidaleggroll View Post
Lots of ways to check your public IP from the command line, here are a couple:
Code:
wget -q -O - http://ipecho.net/plain; echo
curl -s checkip.dyndns.org | sed -e 's/.*Current IP Address: //' -e 's/<.*$//'
That's handy!
 
Old 06-17-2015, 10:28 AM   #10
razvaneluu
LQ Newbie
 
Registered: Jun 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
That is the ip that the hosting give it to me ...
 
Old 06-17-2015, 10:40 AM   #11
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,398

Rep: Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017
Yes, and now what is your machine's private IP? Run "ifconfig" and find the inet address for your network adapter.

If this matches your public IP, then your machine has a public IP already and is directly facing the internet, which means you just need to add the iptables rule. If this does NOT match your public IP, then you have a router/NAT that's creating a subnet for your machine, which means in addition to adding the iptables rule, you'll also need to add a hole in the router's firewall and add a port forwarding rule to push incoming connections on port 5500 to your machine's private IP.

Last edited by suicidaleggroll; 06-17-2015 at 10:42 AM.
 
Old 06-17-2015, 10:56 AM   #12
razvaneluu
LQ Newbie
 
Registered: Jun 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
root@server:~# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:9 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 B) TX bytes:480 (480.0 B)

venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:127.0.0.2 P-t-P:127.0.0.2 Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
RX packets:229 errors:0 dropped:0 overruns:0 frame:0
TX packets:255 errors:0 dropped:5 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:26871 (26.8 KB) TX bytes:197704 (197.7 KB)

venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:176.223.xxx.x P-t-P:176.223.xxx.x Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
 
Old 06-17-2015, 11:07 AM   #13
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,398

Rep: Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017
So it looks like venet0 has your public IP, is that correct?

If so, you just need to focus on iptables then.
 
Old 06-17-2015, 11:08 AM   #14
razvaneluu
LQ Newbie
 
Registered: Jun 2015
Posts: 8

Original Poster
Rep: Reputation: Disabled
Yes... How i can open with iptables ?
 
Old 06-17-2015, 11:10 AM   #15
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,398

Rep: Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017Reputation: 2017
There are a lot of howtos on that, which will cover iptables operation in much more depth than I can here. Just search Google for "add exception to iptables". Almost all of the top 10 results are walkthroughs/guides that show you how to configure it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 5: iptables - cannot open port 80 and nat to port 8080 for Tomcat steve willett Linux - Networking 4 09-24-2010 04:03 AM
If I forward a port in iptables, does the port have to be open on the firewall? qwertyjjj Linux - Server 4 08-06-2009 09:22 AM
best port scanner To scan open port in a network tanveer Linux - Security 8 01-21-2007 08:19 PM
10.1 Open office fails /home/user/slot:5500 does not exist 1kyle SUSE / openSUSE 1 03-22-2006 07:37 AM
cannot SFTP to SUSE 9.2 box, port 22 open, can putty in though using same port. jgrady Linux - Networking 6 03-29-2005 08:44 AM


All times are GMT -5. The time now is 01:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration