LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2006, 10:46 PM   #1
mbreith
Member
 
Registered: Feb 2006
Location: oregon
Distribution: PIII fedora2 | P4 fedora2 | Thinkpad fedora2
Posts: 54

Rep: Reputation: 15
oops. No longer able to connect to the internet through my DSL


OK. I don't understand how this happened. I was attempting to connect my fedora computer to the internet. I turned off the suse computer that has the internet, moved the modem cable to the other computer and powered on the second computer. I left the first computer turned off (in fact, I unplugged the power cord). I figured that if I turned the computer on without the modem, it would only confuse the system.

I couldn't get the internet to connect on the fedora computer, so I took the modem back to the suse computer. That computer doesn't connect anymore and I don't understand how it figured out that the modem was detached for a few hours since it was powered off. So now how do I reconnect it?

I know the modem is good and that the internet service is still active. I am using it to type this. I had to connect to one of the Windows systems I have to get it to work.

The error it is giving me is that it cannot find the host or domain of anything I try to look for online. It is also telling me during the startup messages that eth0 and eth1 could not be set up. They are both configured with DHCP. A little later it says that samba was skipped and networking failed.

Any ideas?
 
Old 02-15-2006, 11:37 PM   #2
rk_carol
LQ Newbie
 
Registered: Jan 2003
Location: Bangalore
Distribution: Redhat 9.0
Posts: 16

Rep: Reputation: 0
Connecting to the Internet

You need to ensure that your "old connection", the SuSE machine, gets a new IP address from the DHCP server. Its possible that you did not power off the modem when you switched machines, which means that the modem had "assumed" that the IP address it had earlier dished out was "in-use", which was actually being used by the Fedora machine.

You can do one of the two following things :

1. Reboot the modem ( power-off & restart ) & then reboot the Fedora, or

2. Run the command
#dhclient
from the command line as root.

If the dhcp utils package has been installed, then the dhclient command would get a new negotiated IP address from the modem.

RK
 
Old 02-16-2006, 10:27 AM   #3
mbreith
Member
 
Registered: Feb 2006
Location: oregon
Distribution: PIII fedora2 | P4 fedora2 | Thinkpad fedora2
Posts: 54

Original Poster
Rep: Reputation: 15
Well, I just ripped suse off of my computer and installed fedora. It connected up, but I am not entirely sure how. I have eth0 set up to configure with DHCP and have the DSL modem connected to it. However, when I go to the Network Configuration tool and try to set up an xDSL connection, it fails. Im just curious at this point. Does anyone know why this is working?
 
Old 02-16-2006, 06:29 PM   #4
IamSpOOk
LQ Newbie
 
Registered: Jul 2005
Posts: 15

Rep: Reputation: 1
Arp

Address Resolution Protocol maps a logical IP address to the hardwired flat addressing of your Network Interface. All Interfaces have a MAC address, and this is fixed and unique worldwide. IP addresses, however may be duplicated in separate networks, and for a given machine in any particular network, it can be changed. When you have established a connection from NIC-A to DSL-B, each set up an ARP table entry that maps designated IP-address-A with NIC-MAC-A and DSL-address-B with DSL-MAC-B. This table is maintained on a periodic basis so that ARP is not required for every session. That would be too inefficient. You can see the arp table on your Linux machine using "arp -an". If you have attempted a connection, it will have an entry for the target machine's IP address, and its MAC address. If you then unplug the cable and connect it to a machine that will necessarily have a different MAC address, this table is now incorrect for the new configuration. You can delete the arp entry by hand using the -d option with the arp command. You also have to work out which machine's arp table is incorrect - the DSL router or just your linux? You might need to reset the DSL router.
 
Old 02-16-2006, 10:11 PM   #5
mbreith
Member
 
Registered: Feb 2006
Location: oregon
Distribution: PIII fedora2 | P4 fedora2 | Thinkpad fedora2
Posts: 54

Original Poster
Rep: Reputation: 15
... OK ... I think I understood at least part of that. I ran the arp command and this is what I got.

[@pool-71-111-73-144 ]$ arp -an
bash: arp: command not found
[@pool-71-111-73-144 ]$ /sbin/arp -an
? (71.111.73.1) at 00:90:1A:41:45:C8 [ether] on eth0

It is interesting that the numbers in the local hostname is almost the same as the entry in the arp table. I also didn't set up that host name. I would have chosen something better than pool.

I realize that this is getting a bit off the topic of this thread. Should /sbin be on the command path? This is the second time that a command that is suggested to me has failed to run because I have to add the /sbin/ to it first.
 
Old 02-16-2006, 10:46 PM   #6
IamSpOOk
LQ Newbie
 
Registered: Jul 2005
Posts: 15

Rep: Reputation: 1
/sbin

/sbin is not in your normal path for tidiness. Ordinary users should not have to use these probramsm and do not need to place any of the sbin directories in their path.

Your 'pool' name would be assigned by the DHCP machine. It is a sensible choice for something that has a group if IP addresses to deal out. (a 'pool' of IP addresses). Your arp entry shows the IP address and MAC address of the DHCP device - most likely your DSL router.
 
Old 02-17-2006, 02:40 AM   #7
baikonur
Member
 
Registered: Oct 2005
Location: germany
Distribution: debian
Posts: 255
Blog Entries: 5

Rep: Reputation: 30
@mbreith:
Quote:
However, when I go to the Network Configuration tool and try to set up an xDSL connection, it fails.
The config tool of your distro?
Of course it does.
You are using a dsl router, if I got this right, and all you have to do
is establish a regular network connection within the correct subnet mask...

baik
 
Old 02-17-2006, 02:52 AM   #8
mbreith
Member
 
Registered: Feb 2006
Location: oregon
Distribution: PIII fedora2 | P4 fedora2 | Thinkpad fedora2
Posts: 54

Original Poster
Rep: Reputation: 15
I thought it was just a DSL modem.
...
Actually, since a modem (modulator/demodulator) deals with analog signals, it would be better described as a single port DSL router.

On Suse, I had to set up the DSL... Well, I assume that I did. It may have just ignored anything I told it there. Yast is very nice in some ways, but is also a "magical black box." I have no idea what it was actually doing when it was configuring things.
 
Old 02-17-2006, 08:07 AM   #9
baikonur
Member
 
Registered: Oct 2005
Location: germany
Distribution: debian
Posts: 255
Blog Entries: 5

Rep: Reputation: 30
a modem would not serve as a dhcp server...
and it wouldn't have it's own ip-address.
do you have a web-interface to interact with
that thing? If you do, then you manage the outbound connection
there, right? That would be a router, then.

regards,
Baik
 
Old 02-17-2006, 04:53 PM   #10
gzickert
LQ Newbie
 
Registered: Feb 2004
Location: Orcutt, CA
Distribution: Fedora Core 10
Posts: 9

Rep: Reputation: 0
Multiple computers connected to one DSL modem.

You should purchase a DSL/Cable router. It will allow you to connect multiple computers to your DSL modem. You can use them all at the same time or any one and not have to connect/reconnect cables.
 
Old 02-17-2006, 04:57 PM   #11
mbreith
Member
 
Registered: Feb 2006
Location: oregon
Distribution: PIII fedora2 | P4 fedora2 | Thinkpad fedora2
Posts: 54

Original Poster
Rep: Reputation: 15
Yes, but that costs which is in short supply when you are a college student, married and have two kids.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot connect to internet,(DSL) eth0 not found Neoltlink Slackware 8 01-29-2006 04:45 PM
SUSE Doesn't Connect to Internet with SBC Yahoo! DSL Ninurta SUSE / openSUSE 14 10-08-2005 01:24 AM
suse 9.2 wont connect to internet via dsl 256k sierra92108 Linux - Networking 14 04-23-2005 04:17 PM
can't connect to internet with Bellsouth DSL Malren Linux - Newbie 8 06-01-2004 06:15 PM
cannot connect to internet after switching dsl router Skunk_Face Linux - Networking 4 03-03-2004 05:08 AM


All times are GMT -5. The time now is 05:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration