LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2005, 11:16 AM   #1
shawnada
LQ Newbie
 
Registered: May 2005
Location: Clevelamd, OH
Posts: 4

Rep: Reputation: 0
Only gnome-cd No Sound


I just installed FC3. The sound card test works fine. I can use Sound Juicer to extract music files from Audio CD and play the extracted file with either Real Player or Music Player. They sounds fine, too. My problem is that

1. I cannot use Real Player to play Audio CD directly as gnome-cd does. The gnome-cd device is set to /dev/cdrom which is a link to x-special/device-block (what is it by the way?). Real player does not have a place to set device. Since audio CD does not hold any filesystem, it won't mount and the /media/cdrecorder displays blank. Any one knows how to feed the audo CD into Real Player as default instead of gnome-cd?

2. Why should I bother? Because gnome-cd has no sound. When I insert an audio CD, gnome-cd reads, displays the tracks, and plays. The only job it fails do is to produce sound. I slided the volume control to max. Still no sound. Everything else makes sound except for gnome-cd. That's why I want to feed audio cd to real player instead gnome-cd. Anyone knows how to make gnome-cd utter a sound?

I have searched on the web and tried numerous recipes, none have worked. My goal is to just use a player to play audio CD directly rather than having to extract files first. Please help!
 
Old 05-17-2005, 11:40 AM   #2
tuxrules
Senior Member
 
Registered: Jun 2004
Location: Chicago
Distribution: Slackware64 -current
Posts: 1,144

Rep: Reputation: 56
My guess is that your CD drive does not have a audio output cable attached from the back of your CD Drive to the mother board somewhere. That I think is the reason why you see the cd being played but no sound. Unlike windows (which can read cd's directly and direct its output to speakers), Linux needs a audio cable (must have come with your CD box) attached to motherboard to channel the sound.

This is what I think...I may be wrong!

Tux,
 
Old 05-17-2005, 12:09 PM   #3
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
Quote:
your CD drive does not have a audio output cable attached
yep, that's what I reckon is wrong, but the cable only goes to the motherboard if your mobo has onboard sound. if you have a sound card i.e. in a ISA or PCI slot, the cable will go to there instead of the motherboard. the cable you are looking for looks like this:
http://images.google.com/images?q=tb...img/CDAUDB.jpg

there is only one place the cable can go on the cdrom, so you're right there, but most of the time there is more than one place it can go on the mobo/soundcard. its probably the one that says something like "cdrom1" or "cd in".
Quote:
Linux needs a audio cable
this is not true, it depends on the method the program is using to play the cd. there are linux programs (e.g. totem) that can play cds without the cord in, and apparently there are ones that can choose between which mode you want to use to play the cd, although I don't know which ones.
 
Old 05-17-2005, 12:49 PM   #4
shawnada
LQ Newbie
 
Registered: May 2005
Location: Clevelamd, OH
Posts: 4

Original Poster
Rep: Reputation: 0
Do you mean the gnome-cd is not capable of processing digital sound? If so, any way to set another capable player as default audio cd player?
 
Old 05-17-2005, 01:36 PM   #5
Ynot Irucrem
Member
 
Registered: Apr 2005
Location: Perth, Western Australia
Distribution: Debian
Posts: 233

Rep: Reputation: 30
yeah thats what i mean. go to preferences -> something that has a CD icon, i think it's "removable storage" and you can configure it there
 
Old 05-17-2005, 04:32 PM   #6
shawnada
LQ Newbie
 
Registered: May 2005
Location: Clevelamd, OH
Posts: 4

Original Poster
Rep: Reputation: 0
There is no such a thing as "removable storage" under preference to configure. Can you be more specific?
 
Old 05-17-2005, 07:20 PM   #7
shawnada
LQ Newbie
 
Registered: May 2005
Location: Clevelamd, OH
Posts: 4

Original Poster
Rep: Reputation: 0
OK. now I really understand what you meant. xmms works fine without a cable.
Thanks a lot for your help:-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound not working in GNOME but sound card test works saravkrish Linux - Hardware 3 02-08-2006 12:03 PM
No sound in gnome 2.10 linx win Debian 4 07-05-2005 03:36 PM
GNOME and Sound. naimslim89 Linux - General 2 06-01-2005 02:54 AM
Gnome has sound/switch to KDE no sound Lar Fedora 6 11-05-2004 04:33 AM
sound for gnome-2.4 jogurt666 Linux - Software 1 02-09-2004 11:00 AM


All times are GMT -5. The time now is 04:57 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration