LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-29-2009, 02:13 PM   #1
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 1,389

Rep: Reputation: 101Reputation: 101
Unhappy One of my file systems failed to auto-mount on boot


Ubuntu 9.10 64 bit on a Dell Studio XPS 8000 i7-860, 150 GB and 750 GB hard drives.

This has happened twice in the week or so I have owned the machine. The 750 GB drive has a partition which should be auto-mounted as "quitelarge". From /etc/fstab

Quote:
# /quitelarge was on /dev/sdb2 during installation
UUID=1b47a45b-40e0-405b-858c-86c031f1d7d9 /quitelarge ext3 defaults
When I just now rebooted to change the cable on my second monitor I noticed that /quitelarge was empty. I manually mounted it and all the data is present.

I have looked at several logs (messages, dmesg, bootstrap) and even a grep of /var/log and can find no reference to /var/sdb2. Perhaps I need to search on UUID. Can someone please point me to the appropriate log or logs to search for evidence as to why the file system does not want to mount?

Thanks,

Ken
 
Old 12-29-2009, 02:45 PM   #2
cg40oz
LQ Newbie
 
Registered: Dec 2009
Location: /dev/random
Posts: 15

Rep: Reputation: 0
The error should be in /var/log/messages. You can also do a mount -a, which will re-read /etc/fstab and remount the filesystems. Can you post your /etc/fstab? Is there a # in front of the /quitelarge entry?
 
Old 12-29-2009, 02:51 PM   #3
lieqie
LQ Newbie
 
Registered: Dec 2009
Posts: 2

Rep: Reputation: 0
try to change 'defaults' to remount-ro
 
Old 12-29-2009, 03:55 PM   #4
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 1,389

Original Poster
Rep: Reputation: 101Reputation: 101
Thanks cg40oz,

There is no reference to /dev/sdb2 nor quitelarge in the message log. (My typo on the original post re. /var/sdb2.)

I will add mount -a to my things to remember list!

The applicable entry from /etc/fstab is in the original post. Uguntu uses the UUID of each resource when it writes the fstab during installation. The commented line shows that the file system in question is on /dev/sdb2. The line with the UUID is used to mount the file system as I understand. I generally remove the UUID and mount to the traditional /dev/sdb2 reference - I don't recall exactly why except that UUIDs hosed up my backup and restore strategy some years ago :-(

I had not done that on the new machine yet when the problem occurred. I have now and will reboot again to make sure everything mounts.

Thanks lieqie,

I don't really want the file system mounted read only. Perhaps
Quote:
defaults,error=remount-ro
is what I need?

Ken
 
Old 12-29-2009, 04:04 PM   #5
cg40oz
LQ Newbie
 
Registered: Dec 2009
Location: /dev/random
Posts: 15

Rep: Reputation: 0
taylorkh,

Try commenting out the whole line with the UUID. I have never used it and from reading the man for fstab it is form of label for the drive. That means if you do a backup and restore to a different computer it may not mount.

Try adding this to the fstab:
/dev/sdb2 /quitelarge ext3 defaults 1 2
 
Old 12-29-2009, 04:11 PM   #6
taylorkh
Senior Member
 
Registered: Jul 2006
Location: North Carolina
Distribution: CentOS 6, CentOS 7 (with Mate), Ubuntu 16.04 Mate
Posts: 1,389

Original Poster
Rep: Reputation: 101Reputation: 101
Thanks again cg40oz,

Here is my un-UUID-ed fstab

Quote:
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda1 / ext3 errors=remount-ro 0 1
/dev/sda3 /data ext3 defaults 0 2
/dev/sda5 /home ext3 defaults 0 2
/dev/sdc2 /quitelarge ext3 defaults 0 2
/dev/sda6 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sdb1 /pgpdisks ext3 defaults 0 2
It seems to work OK. Yes, I believe it had to do with restoring to a different hard drive or a reformatted hard drive - a new UUID was assigned to the partition and it would not mount until I tweaked the fstab. I can see how UUIDs would be of value for a removable medium however, for a fixed mounted drive I do not see the attraction.

Ken
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount : local file systems failed athreyavc Linux - Software 3 02-25-2009 07:54 AM
Auto-mount windows share on boot - manual OK, auto not ok! erskie Linux - Newbie 2 02-12-2008 07:42 PM
mount: too many mounted file systems ferdinand2 Linux - Hardware 0 01-23-2006 01:13 PM
Partitioning: File systems and Mount points Ice Dragon Linux - Newbie 3 03-11-2004 04:00 PM
What file contains auto-mount for fsck cbjhawks Linux - Software 1 09-18-2003 08:02 PM


All times are GMT -5. The time now is 02:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration