LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 07-18-2003, 02:03 PM   #1
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Rep: Reputation: 31
Post One answer will fix 2 problems.


I am using suse 8.2. I have 2 problems, both that deal with the PATH. First is java not being recognized by any web browser and the other is my RAR program not being in the path for the front-end to use.

What file contains the path statment and what is the format I type it in?

While I'm at it - anyone familiar with getting realplayer to be recognized be the browers or is that a PATH issue as well.

Note: I prefer and use the Mozilla browser if that helps at all.
 
Old 07-18-2003, 03:01 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,527

Rep: Reputation: 147Reputation: 147
Your PATH variable is set in /etc/profiles. To add something to it, use
export PATH=$PATH:/your/directory

You can just find the line and add your directories at the end.

To make RealPlayer work you need to copy the rpnp.so library to Mozilla plugins directory (the directory name is plugins/)
 
Old 07-18-2003, 11:47 PM   #3
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Original Poster
Rep: Reputation: 31
resolution

Thanks ! I found it. I added:

/opt/rar \
/usr/java/j2re1.4.1_02/bin \
/opt/mozilla/plugins/java2/plugin/i386/ns4 \
/usr/lib/RealPlayer8 \

And things are Looking up. Rar archiver works, I can watch the news/radio with my real player - all is well. I still get an error with trying to run a certain on-line java applet, but typing 'java' in the console proves that it is now in the path. And that is one step closer.

I REALLY appreciate your help. I have looked online on and off for 2 months on where to edit the path. Thanks a lot.
 
Old 07-19-2003, 10:58 AM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,527

Rep: Reputation: 147Reputation: 147
You need to symlink Java plugin library (libjavaplugin_oji.so) to Mozilla plugin directory.
 
Old 07-19-2003, 11:32 AM   #5
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Original Poster
Rep: Reputation: 31
I will give as much info as possible.
Mozilla is installed in: opt/mozilla/
java is installed in: usr/java/j2re1.4.1_02/

From info found on the mozilla webiste I typed in:
ln -s /user/java/j2re1.4.1_02/plugin/i386/ns610/libjavaplugin_oji.so opt/mozilla/plugins/libjavaplugin_oji.so <Enter>(I think it was a -s, I am going of memory)

It created a link (before I did this, apparently I copied the file to that directory, and the mozilla website said not to do that - only create a link, so now I have verified that ONLY a link is there)

It still does not work. I double checked the permissions of the link and I can run it, the link is owned by root and belongs to the group 'bin'. I checked the groups I belong to and I added 'bin'. however it still give me the error.

any ideas? I am off to upgrade Mozilla to the latest version in some hope that will help, although trying the same thing with the newest Netscape didn't help.
 
Old 07-20-2003, 02:02 AM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,527

Rep: Reputation: 147Reputation: 147
When you type 'about:plugins' into the address bar, what do you see? Is there java plugin mentioned?
 
Old 07-20-2003, 02:12 AM   #7
then
Member
 
Registered: Oct 2002
Location: FDR India
Distribution: RH9, Knoppix, MEPIS
Posts: 65

Rep: Reputation: 15
Quote:
I am off to upgrade Mozilla to the latest version in some hope that will help...
The latest Mozilla needs atleast JRE1.4.2beta.

regards
theN
ps: BTW, your source parameter for ln seems wrong. There's no /user...it must be /usr

Last edited by then; 07-20-2003 at 02:16 AM.
 
Old 07-20-2003, 11:59 AM   #8
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Original Poster
Rep: Reputation: 31
As noticed my "then" (previos reply) I did use 'usr', not 'user', sorry for the typo.

I might give too much usless info, but for those who know, maybe it will help.

I downloaded blackdown java and installed it in:
/usr/local/j2re1.4.1/

I created the symbolic link in both my mozilla 1.2 dir (opt/mozilla/plugins) and my mozilla 1.4 dir (usr/local/mozilla/plugins). I am using suse 8.2 and (primarily) KDE 3.1(or is it 3.2? what ever came with the distrobution...) - now the icon that showed up after I created the link looks like a piece of paper with a lock and a shortcut arrow in the lower left. I am guessing I am now doing it right becuase before it was the blue gear icon.

I go to the directory (in the console) where the javaplugin_oji.so is located and type:
ln -s javaplugin_oji.so /usr/local/mozilla/plugins/javaplugin_oji.so <enter> and then:
ln -s javaplugin_oji.so /opt/mozilla/plugins/javaplugin_oji.so <enter>

Why doesn't suse put java in with everything else? I tried mandrake, I think it was 9.1 or something like that, and it worked.

I will fuss around with it some more, maybe something will catch and it will act right. THANKS TO ALL THAT HELPED !!! I REALLY APPRECIATE IT !!! tom
 
Old 07-20-2003, 12:04 PM   #9
tw001_tw
Member
 
Registered: Mar 2003
Location: St. Louis, MO
Distribution: kubuntu-current
Posts: 551
Blog Entries: 4

Original Poster
Rep: Reputation: 31
Sorry - I forgot to add:
when typing in aboutlugins, no there is no mention of java.
 
Old 07-20-2003, 01:28 PM   #10
alkad_mzu
Member
 
Registered: Jul 2003
Location: New York
Distribution: Freebsd 6.2,slackware 12.0
Posts: 48

Rep: Reputation: 15
hello this is my first post,

what about red hat 8.0?, does it have any support for lava.?
I am very new at this, it took me a few days to get my nvidia
card installed properly.
at this point tux racer is flying down hill and chromium
is telling me I'm a loser at a nice 49 fps. @1024.
i also gather that even though my x display settings keep the
"enable 3d acceleration" box inaccessible, 3d acc. is in fact working.
does red hat 8.0 only allow a maximum color depth of 24 millions?
cause i don't see an option for 32 bit color.
i still dont know where to calibrate my joystick, its a saitek cyborg(us b)
red hat sees it and tux uses it by default but its leans too much to the right.
anyway sorry for the multiple questions i should probably
separate them and start new threads.
also i would like to thank
Master c, boftron, and DrOzz for providing the most useful discussion ever
concerning NVIDIA-Linux-x86-1.0-4363.run installation. That took place @
http://www.linuxquestions.org/questi...php?s=&forumid
 
Old 07-20-2003, 05:39 PM   #11
TwistedCranium
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat 7.3
Posts: 11

Rep: Reputation: 0
I noted at the Mozilla plugin site...
http://plugindoc.mozdev.org/javalinux.html
they stated that the compilier used for the mozilla build makes a difference as to which directory to use the plugin from...


in my case, the link command ended up as...

ln -s /usr/java/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so ~/.mozilla/plugins/libjavaplugin_oji.so
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
pkgtool problems and fix jawkins Slackware 10 07-11-2005 07:36 PM
will 9.2 fix my problems ambelos Suse/Novell 13 10-19-2004 12:28 PM
LILO boot problems -- Your answer here. moses Linux - General 18 10-12-2003 10:10 PM
fix your printing problems jymbo Slackware 0 07-18-2003 03:01 PM
to fix all debian X problems. kmistry Linux - Distributions 2 10-18-2002 03:38 AM


All times are GMT -5. The time now is 04:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration