LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-06-2003, 12:20 AM   #1
kenshee
LQ Newbie
 
Registered: Mar 2003
Distribution: Slackware 8.1
Posts: 6

Rep: Reputation: 0
On Permissions AND SBLive! Sound


Hi! I just installed Slackware and I've read somewhere (I forgot) that it's better not to always log on using root but here's the problem:

I created another user with uid of 1001 (default I think) and when accessing my programs which I installed by root I get permission denied. Also I installed my soundcard (SBLive!) in root but I get no sound in the user that I've created.

So I'm wondering if there's a way to make my user have access on files/programs created by root?

Thanks!
-Kenshee

P.S.
Another thing, whenever I reboot or turn off my computer and when I log back in(root), there's no sound and I have to reinstall (using the method on installing SBLive! soundcards at JustLinux.com http://www.justlinux.com/nhf/Soundcards) it again. What gives?

I'd really appreciate the help. Thanks!
 
Old 03-06-2003, 03:25 AM   #2
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
As root, type the following in command line:

chmod 755 /dev/dsp
and
chmod 755 /dev/mixer

This will allow users to listen to sound in GUI mode (aka X). Now, hopefully you didn't go through all that installation process at the link you provided each time. Once you've got the module, and have iton your system, you don't have to compile it each time. Okay, on to the good stuff. Type as root in command line:

modprobe emu10k1

then type:

lsmod

to make sure it's there now--it will print out on screen all the installed modules on your system. Next, type:

cd /etc/rc.d

You can view all the files and directories by typing "ls" without quotes. You need to edit your file (with your favorite text editor) called rc.modules in that directory. You need to uncomment (remove the # in front of) the line with your emu10k1 module and then save the file.

Now, you need to go to /etc:

cd /etc

and edit your file called modules.conf. Add the following:

alias sound-slot-0 emu10k1

and save it. You're done. You should now have sound working all the time for everyone (hopefully). If you need help with the file editing, let me know.
 
Old 03-06-2003, 03:27 AM   #3
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
As for programs installed by root, you'd have to grant them permissions to use it.

chmod 755 <filename>

This will allow you to read and execute it, but not write to it--only root can do that.

For more on chmod command type man chmod and it will give you loads of info. If it still doesn't make sense, let us know.
 
Old 03-06-2003, 04:47 AM   #4
kenshee
LQ Newbie
 
Registered: Mar 2003
Distribution: Slackware 8.1
Posts: 6

Original Poster
Rep: Reputation: 0
Wow thanks a lot!
 
Old 03-06-2003, 11:15 AM   #5
kenshee
LQ Newbie
 
Registered: Mar 2003
Distribution: Slackware 8.1
Posts: 6

Original Poster
Rep: Reputation: 0
Sad to say I still have no sound. I wonder what's wrong. I followed your directions exactly. Please help. Thanks!
 
Old 03-06-2003, 04:51 PM   #6
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Are the programs that were installed by root sitting in root's home directory? For example program TARBALL:

/root/TARBALL

If so, it's the permissions of the directory that you'll have to change--but that's considered very unwise. Instead, try moving the files/programs to another directory that everyone is able to access.

mv /root/TARBALL /usr/local/share

The above is only an example. You don't necessarily have to move it to /usr/local/share. You could move it to your user account home directory if you like /home/kenshee. The man page for the move command is very helpful too: man mv. After it's moved, check the permissions of the file:

ls -l /home/kenshee/TARBALL

This will give you the permissions in the rwx format where r=read, w=write, x=execute. If you need to change the permissions, use the chmod command again. Hope this helps.
 
Old 03-06-2003, 04:55 PM   #7
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
As for the sound, post your /etc/modules.conf file and the entry you added or uncommented in your /etc/rc.d/rc.modules file. Also, type lsmod to see what modules are loaded and post it here as well. This will help in determining what to do next.
 
Old 03-07-2003, 01:33 AM   #8
kenshee
LQ Newbie
 
Registered: Mar 2003
Distribution: Slackware 8.1
Posts: 6

Original Poster
Rep: Reputation: 0
Here's my modules.conf fil:

alias /dev/ttySHSF* hsfserial
alias char-major-240 hsfserial
alias /dev/ttyCUA* hsfserial
alias char-major-241 hsfserial
alias /dev/modem hsfserial
options hsfserial serialmajor=240 calloutmajor=241
alias sound-slot-0 emu10k1

I see emu10k1 in lsmod. Also I tried looking at control center and PCI information. I found out that the soundcard is only accessible to root. What should I do?
Again thanks man, sorry for the trouble
 
Old 03-07-2003, 03:11 AM   #9
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Well, we're getting there. And it's no trouble to me at all. Your modules.conf file looks good.

Did you uncomment the line in your /etc/rc.d/rc.modules file? I know you said you did this already, but I'm just covering all the bases. It should look like this under your Sound Support section (you've got some scrolling to do to get there):

Quote:
### Sound support ###
# Sound Blaster Pro/16 support:
#/sbin/modprobe sb io=0x220 irq=5 dma=3 dma16=5 mpu_io=0x300
# Sound Blaster Live support:
/sbin/modprobe emu10k1
# MAD16 support:
#/sbin/modprobe mad16 io=0x530 irq=7 dma=0 dma16=1
# AD1816(A) sound driver:
#/sbin/modprobe modprobe ad1816 io=0x530 irq=5 dma=1 dma2=3 ad1816_clockfreq=330
00
# Crystal CS4232 based (PnP) cards:
#/sbin/modprobe cs4232
# ES1370 support, such as Sound Blaster 128PCI:
#/sbin/modprobe es1370
# ES1371 support, such as Sound Blaster 64V PCI:
#/sbin/modprobe es1371
# ESS Maestro, Maestro2, Maestro2E:
#/sbin/modprobe maestro
# ESS Maestro3/Allegro:
#/sbin/modprobe maestro3
# (For information on configuring other sound cards with Linux,
# see the documentation in /usr/src/linux/Documentation/sound/,
# and /usr/src/linux/Documentation/Configure.help.
Notice how the only line uncommented (no # at beginning of line) is the emu10k1 line? That's how yours should look.

When you say that the "soundcard is only accessible to root", what exactly are you referring to? I know this sounds like a goofy question, but I'm trying to figure out where this info came from. When you do a "ls -l" for /dev/mixer and /dev/dsp does it look like this?:

phyx@frankenstein:~$ ls -l /dev/mixer
crwxr-xr-x 1 root sys 14, 0 Jul 18 1994 /dev/mixer
phyx@frankenstein:~$ ls -l /dev/dsp
crwxr-xr-x 1 root sys 14, 3 Jul 18 1994 /dev/dsp

If not, chmod 755 both of them again to make sure. Other than this, the only thing I can think of is to check your volume levels. I never asked this before either and I should have--when you say you have no sound, are you getting no sound at all or no sound when trying to play a CD? If it's when trying to play a CD, go into X and load up your XMMS or whatever you're using. Check to make sure that your volume level is up. Also, go into Kmix (if in KDE) or Audio Mixer (if in Gnome) and make sure that your volume levels are up and also not muted or shut off. If it still doesn't work, let me know and we'll see what else we can think of.
 
Old 03-07-2003, 03:20 AM   #10
kenshee
LQ Newbie
 
Registered: Mar 2003
Distribution: Slackware 8.1
Posts: 6

Original Poster
Rep: Reputation: 0
Got it working atlast! I just needed to do "chmod ugo+rwx /dev/dsp"
Also is there a way to turn my sound up so that I don't have to increase the volume of my speakers way up?

Whoo! At last I got sound. Also learned a lot. Thanks!!!
 
Old 03-07-2003, 03:16 PM   #11
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Glad you got it working! Perseverance pays off. See my last post on volume levels.
 
Old 03-08-2003, 04:26 PM   #12
philsta
Member
 
Registered: Feb 2003
Location: Bath England
Distribution: Fedora Core 5, Slackware 10.2
Posts: 38

Rep: Reputation: 15
Good advice Texicle and well put as well...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound SBlive 7.1 micder Slackware 6 07-31-2005 01:21 PM
mandrake 10.1 (sblive no sound) mrevo845 Linux - Hardware 15 11-25-2004 11:10 AM
SBlive no background sound has2k1 Linux - Newbie 0 06-04-2004 01:05 AM
SBLive 5.1 sound repeats over and over... dracflamloc Linux - Hardware 0 02-23-2004 03:38 PM
SBLive 5.1 Analog sound Karts Linux - Hardware 2 05-10-2003 02:37 AM


All times are GMT -5. The time now is 06:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration