LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2005, 05:53 AM   #1
liam_atkins
LQ Newbie
 
Registered: Aug 2005
Posts: 7

Rep: Reputation: 0
Question On Boot up: it goes straight through to XP


Hi

I am a totally new guy to linux and need help!

i have two 160gig hard drives one is using XP pro and the other i want to use Redhat Fedora Linux 9.0.

I installed Fedora last night, using the graphical interface, and set it to boot as xp as default using grub. the installation went through fine, however when it came to reboot it boots straight through to XP??

i have checked to see if a partition was created on the hard drive for the linux using disk management and it partitioned it for linux so i know its there?

please help!

thanks in advance

liam


 
Old 08-04-2005, 06:03 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
First question ... where did you install grub to? It probably should have been installed into the MBR of the first hard drive, but if you installed it into the root directory of the Linux drive, you may run into problems like the one you described.

Baldrick
 
Old 08-04-2005, 07:55 AM   #3
liam_atkins
LQ Newbie
 
Registered: Aug 2005
Posts: 7

Original Poster
Rep: Reputation: 0
i didn't install grub anywhere, all i have done is copy the ISO files downloaded from the redhat site onto cds and read the documentation on how to install (it never said anything about installing grub any where?). then i booted up and followed the insructions on screen thought it was part of the installation? but maybe thats because im so used to windows lol.

so if i need to install grub how do i? and if not what has gone wrong

ah lol
 
Old 08-04-2005, 08:40 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Firstly, you're either using Fedora Core or Red Hat Linux 9.0; there isn't a "Red Hat Fedora Linux 9.0".

If you're using Fedora Core, where did you read the documentation? There is an installation guide here that has a section about the boot loader (section 7). That's where the stuff about GRUB is.

I don't use Fedora, but they have a rescue CD for Fedora Core 4 here (it's for i386 though, which should be ok as long as you're not using a 64 bit CPU). Try downloading the ISO, burning it and then booting from it. It might let you install GRUB there.
 
Old 08-04-2005, 09:12 AM   #5
liam_atkins
LQ Newbie
 
Registered: Aug 2005
Posts: 7

Original Poster
Rep: Reputation: 0
ok thanks i feel a fool!! lol

i have fedora core and i didnt get that far in my reading, however i have set it up right, the only difference being is i set my xp to be the default could this be the reason its not giving me the option on boot up?
 
Old 08-04-2005, 09:22 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
It might just be that you installed GRUB, but not to the MBR, in which case you won't get the menu.
 
Old 08-04-2005, 05:28 PM   #7
liam_atkins
LQ Newbie
 
Registered: Aug 2005
Posts: 7

Original Poster
Rep: Reputation: 0
ah i see!! so i need to edit the mbr but how do i get the mbr to recognise fedora core?

thanks alot for this, you are really helping me!
 
Old 08-04-2005, 05:44 PM   #8
liam_atkins
LQ Newbie
 
Registered: Aug 2005
Posts: 7

Original Poster
Rep: Reputation: 0
below is my boot.ini:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

what do i need to addso i can choose to boot to fedora core or xp?

thanks again
 
Old 08-05-2005, 01:51 AM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
I think it's possible with Windows' boot loader, but I'm not sure how. Google/search LQ to find out, or as I say, maybe try the stuff in this thread to reinstall GRUB .

Last edited by Nylex; 08-05-2005 at 02:09 AM.
 
Old 08-05-2005, 03:13 AM   #10
mani_iips
LQ Newbie
 
Registered: Jul 2005
Location: Indore, India
Posts: 20

Rep: Reputation: 0
friend u dont need to make any changes to ur BOOT.INI file...... bcos that file comes into play ONLY after the DOS has been selected.. i mean thats just for the internal selection of WINDOWS only.....

even i had the same pron earlier..... when i installed RHL9.0... but then it was bcos my LILO failed... so i just had to use the RESCUE mode and configure my LILO again... even u can try the RESCUE mode, if u have that in FEDORA.....

U can even check the "/boot/grub/menu.lst" file....
 
Old 08-05-2005, 04:34 AM   #11
liam_atkins
LQ Newbie
 
Registered: Aug 2005
Posts: 7

Original Poster
Rep: Reputation: 0
ok i shall check this out when i get home tonight and hopfully get it working!! lol

thanks for all your help guys
 
Old 08-05-2005, 06:13 AM   #12
nakedape
LQ Newbie
 
Registered: Jul 2005
Location: Bucharest, RO
Distribution: SUSE 9.3
Posts: 7

Rep: Reputation: 0
Re: On Boot up: it goes straight through to XP

Quote:
Originally posted by liam_atkins


i have two 160gig hard drives

Sounds to me like you're booting directly from your XP drive.
 
Old 08-08-2005, 04:49 PM   #13
liam_atkins
LQ Newbie
 
Registered: Aug 2005
Posts: 7

Original Poster
Rep: Reputation: 0
right still not working! but what happens now is after it tries to boot from cd, it says grub and then nothing happens??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mandriva - doesn't boot straight to kde Leela77 Mandriva 5 10-04-2005 11:44 AM
Is there a way to have my comp boot straight into kdm? gbdavidx Slackware 4 11-04-2004 04:36 AM
Can Fedora boot straight into Text mode? carlosinfl Fedora 2 05-17-2004 05:17 PM
Boot straight into bash? The_fuzzy_cow Mandriva 2 12-07-2003 11:05 PM
How to boot straight to init2 (Text-Mode) satimis Linux - General 3 08-04-2003 10:50 PM


All times are GMT -5. The time now is 12:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration