LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-06-2008, 06:55 PM   #31
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Crdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381

Quote:
Originally Posted by F M J View Post
physics@physics:/etc/rc2.d$ gnome-screensaver --display=:0.0

** (gnome-screensaver:17061): WARNING **: screensaver already running in this session
physics@physics:/etc/rc2.d$


and it still puts screensaver up on all screens
Did you kill gnome-screensaver before that?

Just to be on the safe side, you need:

Code:
killall -s9 gnome-screensaver
gnome-screensaver --display=:0.0
 
Old 09-06-2008, 06:55 PM   #32
F M J
Member
 
Registered: Feb 2004
Location: New Zealand
Distribution: Ubuntu Hardy Heron, Fedora Core 3
Posts: 45

Original Poster
Rep: Reputation: 15
well now the screensaver doesnt work, all screens dim a little bit then go bright again..



Code:
physics@physics:/etc/rc2.d$ gnome-screensaver --help-all
Usage:
  gnome-screensaver [OPTION...]

Help Options:
  -?, --help               Show help options
  --help-all               Show all help options
  --help-gtk               Show GTK+ Options

GTK+ Options
  --class=CLASS            Program class as used by the window manager
  --name=NAME              Program name as used by the window manager
  --screen=SCREEN          X screen to use
  --sync                   Make X calls synchronous
  --gtk-module=MODULES     Load additional GTK+ modules
  --g-fatal-warnings       Make all warnings fatal

Application Options:
  --version                Version of this application
  --no-daemon              Don't become a daemon
  --debug                  Enable debugging code
  --display=DISPLAY        X display to use

physics@physics:/etc/rc2.d$
 
Old 09-06-2008, 06:58 PM   #33
F M J
Member
 
Registered: Feb 2004
Location: New Zealand
Distribution: Ubuntu Hardy Heron, Fedora Core 3
Posts: 45

Original Poster
Rep: Reputation: 15
ok i tried what u just mention, screensaver works again, but on all screens lol...

grrr
 
Old 09-07-2008, 01:50 AM   #34
JonnerR
LQ Newbie
 
Registered: Dec 2005
Posts: 21

Rep: Reputation: 16
Quote:
Originally Posted by i92guboj View Post
I see your point. However, xscreensaver has a -display parameter, -display :0.0 (or :0.1, or whatever) *should* do the trick. And if it doesn't, then there's a problem in your system, or in xscreensaver (and that would be a bug to report).

So, at least xscreensaver, should support this.

If this works, the OP could continue using gnome just like it's now, and launch the xscreensaver daemon manually so it runs only on a given screen. It *should* work.

EDIT: Reading it's man page I see this:

Code:
-display host:display.screen
 	The X display to use. For displays with multiple screens, XScreenSaver will manage all screens on the display simultaniously.
I don't really understand this entirely. The -display parameter accepts a "screen" parameter, but the description doesn't make it so clear. So I don't really know...
Unfortunately, as much as we might think running separate instances of either xscreensaver or gnome-screensaver should work, it doesn't. As I explained, I already tried both. I then discovered the xscreensaver manual which explains its behavior, so it's clearly not considered a bug by the author. It would seem that gnome-screensaver is designed to work similarly. It's not surprising, since most of the time, one wants all screens to blank at the same time. There may be an alternative that doesn't take over the whole session that I'm not aware of.
 
Old 09-08-2008, 12:24 AM   #35
F M J
Member
 
Registered: Feb 2004
Location: New Zealand
Distribution: Ubuntu Hardy Heron, Fedora Core 3
Posts: 45

Original Poster
Rep: Reputation: 15
so where do i go from here then ?
 
Old 09-08-2008, 10:27 AM   #36
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Crdoba (Spain)
Distribution: Gentoo
Posts: 4,063

Rep: Reputation: 381Reputation: 381Reputation: 381Reputation: 381
Quote:
Originally Posted by JonnerR View Post
Unfortunately, as much as we might think running separate instances of either xscreensaver or gnome-screensaver should work, it doesn't. As I explained, I already tried both. I then discovered the xscreensaver manual which explains its behavior, so it's clearly not considered a bug by the author. It would seem that gnome-screensaver is designed to work similarly. It's not surprising, since most of the time, one wants all screens to blank at the same time. There may be an alternative that doesn't take over the whole session that I'm not aware of.
Well, then it's a bug, in my opinion. Even if the authors deny so. Why have a display parameter if the program can't really handle it entirely?


Quote:
Originally Posted by F M J View Post
so where do i go from here then ?
I think that the only available option is to run two separate servers by hand. This will require more work. You need to define two separate layouts in your xorg.conf file. One will use one monitor, the other will use the rest.

Then you need to use startx twice, once for each layout, to launch two separate x servers.

I have never done this, and I don't really know if you will be able to use this solution with only one mouse/keyboard pair...

I know this *should* work at theoretical level, but can't really help you to implement it, because I would be misguiding you probably.

I will do some experimenting with this when I reack home, and will post back again here if I get it to work. This thread is getting long, and I don't want to make it longer if it's not to give a definitive solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
have 2 monitors connected to my pc, but lspci only finds 1.. help nappy Linux - Hardware 4 02-11-2008 10:45 AM
how do I set up dual monitors is Ubuntu 7.0.4 mustang05 Linux - Software 1 06-14-2007 02:28 PM
trouble getting dual monitors set up revolthor Linux - Newbie 5 04-12-2005 12:17 AM
how to set up dual monitors contrasutra Linux - Software 1 04-07-2003 03:32 AM
two monitors set up in X? doublefailure Linux - General 15 04-28-2002 07:26 PM


All times are GMT -5. The time now is 05:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration